Can't set mount point for my ext HDD

Hi, guys. I have read most of the threads related to this topic, but can't seem to fix it by myself.

My 500gb ext HDD is spinning, light on, the name show up on file manager, lsusb, fdisk, blkid, etc, with its capacity, etc but no mount point. And I can't seem to set it mounted with the advice I got from the threads here.

If I wait long enough after clicking the HDD, it shows "unknown error when mounting /dev/sdb1"

I tried pluggin it on Windows, the drive shows up but can't be opened. Took so long to respond. Can't do checkdisk as well, since it wouldn't show up on disk management.

Can anybody please help me? Is it a power thing? Because I don't have any other USB 3.0 cable I can use. Or is my HDD broken?

Thank you so much.

Welcome back.
Could you post the following outputs while the drive is connected?
inxi -Dxxxza sudo smartctl -a /dev/sdb

You might also want to reread this

Hi, Takei!

Thank you for your response and advice. Here is the result of that command.

[yantiamalia@yantiamalia-pc ~]$ inxi -Dxxxza sudo smartctl -a /dev/sdb
Error 22: Unsupported option: sudo
Check -h for correct parameters.


  Kernel: 4.14.176-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-4.14-x86_64 
  root=UUID=558cd6df-c8a3-4433-a340-5a8cf30a0d59 rw 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: X201EP v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X201EP v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X201EP.205 date: 11/30/2012 
  ID-1: BAT0 charge: 37.8 Wh condition: 37.8/38.0 Wh (99%) volts: 7.4/7.4 
  model: ASUSTek X202-51 type: Li-ion serial: <filter> status: Full 
  Topology: Dual Core model: Intel Celeron 847 bits: 64 type: MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 4390 
  Speed: 522 MHz min/max: 800/1100 MHz Core speeds (MHz): 1: 528 2: 528 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0106 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 2000 (SNB GT1) 
  v: 3.3 Mesa 20.0.4 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: ASUSTeK VivoBook X202EV driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k4.14.176-1-MANJARO 
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter 
  vendor: AzureWave AW-NE186H driver: ath9k v: kernel port: f040 
  bus ID: 02:00.0 chip ID: 168c:0032 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros AR8162 Fast Ethernet vendor: ASUSTeK 
  driver: alx v: kernel port: e000 bus ID: 03:00.0 chip ID: 1969:1090 
  IF: enp3s0 state: down mac: <filter> 
  Local Storage: total: 763.82 GiB used: 221.92 GiB (29.1%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS545032A7E380 size: 298.09 GiB 
  block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: A6C0 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Western Digital 
  model: WD My Passport 0730 size: 465.73 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 1015 scheme: MBR 
  ID-1: / raw size: 30.12 GiB size: 29.52 GiB (98.02%) 
  used: 13.24 GiB (44.9%) fs: ext4 block size: 4096 B dev: /dev/sda2 
  ID-2: /home raw size: 259.44 GiB size: 254.37 GiB (98.04%) 
  used: 208.43 GiB (81.9%) fs: ext4 block size: 4096 B dev: /dev/sda4 
  ID-3: swap-1 size: 8.23 GiB used: 258.8 MiB (3.1%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda3 
  System Temperatures: cpu: 89.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 5300 
  Processes: 205 Uptime: 56m Memory: 3.74 GiB used: 2.12 GiB (56.7%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 alt: 7 clang: 9.0.1 Shell: bash 
  v: 5.0.16 running in: xfce4-terminal inxi: 3.0.37 

That should have been 2 seperate commands. You will sadly have to do the sudo smartctl -a /dev/sdb again.

i would test this first before doing something else. some disks need a adapter that uses two usb-ports at the computer to support enough power. using only one usb-port at the computer will cause malfunction. very often the disk will be recognized but any try to read or write to the disk is failing.

1 Like

If you have other USB ports, try these as well, even if they are only USB2.0.

OH! Sorry. Noob. :smiley:

inxi -Dxxxza

  Local Storage: total: 763.82 GiB used: 222.65 GiB (29.1%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS545032A7E380 size: 298.09 GiB 
  block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: A6C0 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Western Digital 
  model: WD My Passport 0730 size: 465.73 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 1015 scheme: MBR 

sudo smartctl -a /dev/sdb

smartctl 7.1 2019-12-30 r5022 [x86_64-linux-4.14.176-1-MANJARO] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke,

Model Family:     Western Digital Elements / My Passport (USB)
Device Model:     WDC WD5000BMVW-11AMCS0
Serial Number:    WD-WXC1A2153991
LU WWN Device Id: 5 0014ee 6abc4eb3b
Firmware Version: 01.01A01
User Capacity:    500.107.862.016 bytes [500 GB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5400 rpm
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS (minor revision not indicated)
SATA Version is:  SATA 2.6, 3.0 Gb/s
Local Time is:    Sun Apr 19 19:51:57 2020 WIB
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART Status command failed: scsi error unsupported field in scsi command
SMART overall-health self-assessment test result: PASSED
Warning: This result is based on an Attribute check.

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(15360) seconds.
Offline data collection
capabilities: 			 (0x7b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					Offline surface scan supported.
					Self-test supported.
					Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 ( 152) minutes.
Conveyance self-test routine
recommended polling time: 	 (   5) minutes.
SCT capabilities: 	       (0x7035)	SCT Status supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     0x002f   198   198   051    Pre-fail  Always       -       274
  3 Spin_Up_Time            0x0027   170   153   021    Pre-fail  Always       -       2491
  4 Start_Stop_Count        0x0032   095   095   000    Old_age   Always       -       5810
  5 Reallocated_Sector_Ct   0x0033   200   200   140    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x002e   200   200   000    Old_age   Always       -       0
  9 Power_On_Hours          0x0032   093   093   000    Old_age   Always       -       5394
 10 Spin_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0
 11 Calibration_Retry_Count 0x0032   100   100   000    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   097   097   000    Old_age   Always       -       3670
192 Power-Off_Retract_Count 0x0032   199   199   000    Old_age   Always       -       818
193 Load_Cycle_Count        0x0032   188   188   000    Old_age   Always       -       37188
194 Temperature_Celsius     0x0022   112   083   000    Old_age   Always       -       35
196 Reallocated_Event_Count 0x0032   200   200   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   200   200   000    Old_age   Always       -       1
198 Offline_Uncorrectable   0x0030   100   253   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       0
200 Multi_Zone_Error_Rate   0x0008   100   253   000    Old_age   Offline      -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

I hope this helps.

Will try to get a hold on another cable tomorrow. Thanks, guys.

This is an old ext HDD and sometimes I have to move the cable or place it in a certain way for it to connect. This morning I was copying a file to my hdd and I accidentally moved it, it was ejected and there's an error message. I tried to mount the hdd again then retried to continue the copying process (which of course ended up failed). The hdd then started making crackling sound. That was the end of my being able to access it.

That's definitely not good. Hard discs are not supposed to make crackling sounds. Given that it lost power while writing, that could mean the head has touched a platter. If true that means there is likely no saving it, which is likely since it has worked before.

It makes crackling sound only if I plug it in the usb port where it functioned the last time. Silent, spinning, lights on when plugged into another usb port.

What about from that smartctl command? What does it actually say?

The only thing that is slightly notable from the S.M.A.R.T. data is the spin up time. Given the old age of the drive that is not really a wonder. Should not give rise to problems though.

Have tried another cable. I think it's highly probable broken. :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by