Can't switch input layout in steam, layout resents in skype

I was learning a bit of japanese last year and installed mozc+fcitx to have a way to input japanese characters on my computer. It required some additional packages before it worked in some apps like chrome and skype. I think it's related to ibus in some way, but I'm newb so dunno exactly what those were.

I run kde manjaro with latest updates.

Right now the issue is steam does not allow me to switch layout at all, this happened for multiple months now. Skype will allow to switch layout, but the layout will reset if the field loses focus. Latest update of skype made it even worse as it changes the input field in such a way my layout resets after first letter I type in.

The reason I mention mozc is because clean manjaro kde install did not have any issues similar to what I have, it's after installing mozc that I had issues like this. Those additional packages were supposed to make it working with some apps through ibus as I remember it.

To recap my issues

Current behavior

  • Keyboard layout is reset to english when I switch input field within the app, all apps have this for me. Skype is the worst example as it resets keyboard layout after first symbol)
  • Keyboard layout is impossible to switch in Steam.

Desired behaviour

  • Keyboard layout is preserved per window or per app, not per input field
  • I can switch layout for steam and input text in any layout I have.

Please help me with possible packages I need to install or ways to diagnose my system. I don't know where to look to learn what I may have misconfigured.

I use this since forever


Don't know if the mozc+fcitx will make it behave differently, but whatever app/window/input-field i access, the layout is the one i set and it never switches to something else, unless i do it via shortcut.

After changing Switching Policy from "Application" to "Global" it works with Steam so that's a win I guess.
Skype still has this weird behavior where I input one character in russian and then layout switches back to english.

Restart your session or the system and see if it behaves correctly after that. I don't have skype (never will) to test, but there should be no issue.

Can't restart right now, will report on that later.

P.S.: Just to document, steam was working briefly after I played with Switching Policy, but it's broken again. Dunno what I even did.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by