Cant use samba ? No smb.conf or smb.conf.default

I dont usually have much trouble browsing my local samba shares but now im using manjaro i cant?

I have no /etc/samba/smb.conf
or /etc/samba/smb.conf.default

I tried locate & find but nothing.

Iv tried uninstalling samba and re-installing it but still nothing.

❰greg❙/etc/samba❱✔≻ smbclient -L //
smbclient: Can't load /etc/samba/smb.conf - run testparm to debug it

❰greg❙~❱✔≻ smbtree
smbtree: Can't load /etc/samba/smb.conf - run testparm to debug it

❰greg❙/etc/samba❱✘≻ testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Error loading services.

❰greg❙/etc/samba❱✘≻ ls -la
total 16
drwxr-xr-x  3 root root 4096 Jan 31 20:47 ./
drwxr-xr-x 91 root root 4096 Jan 31 20:47 ../
drwx------  2 root root 4096 Dec 27 10:54 private/

I have searched around but everywhere says i should at least have a copy of smb.conf* somewhere?

1 Like

Install manjaro-settings-samba


yeap, thats seems to have got it, i now have the conf file, just need to figure how to set it up so i can browse my local shares via dolphin.

Thank you :slight_smile:

My Manjaro KDE install came with manjaro-settings-samba pre-installed, but I also had no smb.conf or smb.conf.default files.
I simply copied over a backup of my pre-configured smb.conf from my archived files.
You can get a copy of the default file from the internt and copy it to /etc/samba/smb.conf

well iv got access now to individual shares, but i cant browse all my local shares

Dolphin/Network/Samba Shares its just blank

also smbtree does nothing either ? (maybe im using it wrong)

❰greg❙/etc/samba❱✔≻ smbtree
❰greg❙/etc/samba❱✘≻ sudo smbtree
[sudo] password for greg: 

Did you use some kind of Firewall, like ufw or gufw?

If so please turn it off and try again.

its off

looking at a specific local IP with smbclient gives some results

❰greg❙~❱✔≻ smbclient -L //
Enter WORKGROUP\greg's password: 

        Sharename       Type      Comment
        ---------       ----      -------
        ADMIN$          Disk      Remote Admin
        C$              Disk      Default share
        Dell C1660w Color Printer Printer   Dell C1660w Color Printer
        Downloads       Disk      
        E$              Disk      Default share
        F$              Disk      Default share                                                         
        IPC$            IPC       Remote IPC                                                            
        mandie-Desktop  Disk                                                                            
        My Docs Mandie  Disk                                                                            
        print$          Disk      Printer Drivers                                                       
        PROGRAMDATA     Disk                                                                            
        Users           Disk                                                                            
        uTorrent_Downloads Disk                                                                         
Reconnecting with SMB1 for workgroup listing.                                                           
Connection to failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)                            
Failed to connect with SMB1 -- no workgroup available

But i would really like to browse all my local hosts/shares with dolphin really

Are you sure the firewall/iptables are off?

Also make sure you set the correct workgroup name in /etc/samba/smb.conf

i dont have ufw or gufw installed , i dont know (or have i touched iptables) , how can i be sure its not on at all?

❰greg❙/etc/samba❱✘≻ sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

its this thats odd, i can access a single node but when i try and look at all available nodes its just blank

You might want to try mounting your shares in /etc/fstab. With the Dolphin reference I'm assuming your A KDE user. Videos play far better across network shares by mounting the shares on KDE. At least that's my way of getting videos to share across an smb network on KDE.

Thx, but i just want to be able to see all my local nodes / computer / phones / etc im not interested in video streaming.

Yea im on KDE

Ok well this will do, i shall just have to make shortcuts to each individual computer on my LAN. Would be nice to be able to see them all listed properly but meh...

Thx all.

If you mount the shares they all appear in Dolphin's drive panel, but shortcuts work too. You can add shortcuts to Dolphins panel as well, but they can be flaky at times and not connect as well as a mounted share.

yea , i could have them all mounted at boot via fstab but i was really looking for the answer why smbtree & dolphin (smb://) just wont work, especially since i can connect to single nodes so the workgroups / hostnames etc should show up even if its just for that one node iv already connected to.

Just don't make sense :-/

Plus it handy to be easily able to see what nodes are on/off line.

I hear ya. I personally think smb is way flakier overall than it used to be. I never used to get the issues you are speaking of until maybe a year or so ago I think. I just decided it's less hassel to mount the shares than fight with smb visibility/conectivity. As I stated videos play way better, so that was also another reason why I went that route.

k well thx, maybe someone will pop-in and already have dealt with this one and have the answer.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by