Can't use WiFi with TP Link RE305 Extender

I have a laptop with Manjaro KDE 20.0.3. I can connect to my main WIFI signal, but cannot connect to TP Link WiFi extender. The same laptop with Windows 10 (dual boot) works fine. Other devices like tablets, ipads or phones are connected to this extender normally. Only in Manjaro 20.0.3 and Ubuntu 20.04 is the problem.

I see the TPLink extender Signal on my Networks, I connect with this network, but the network can't connect to the same time other devices like phones or TV are connected without problems. The same laptop with windows works fine, the issue is only with new versions of the distros. The problem is only with TPlink extender, I can connect fine to my main WiFi signal.

  Kernel: 5.7.0-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Micro-Star product: GL75 Leopard 10SFK v: REV:1.0 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Micro-Star model: MS-17E7 v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E17E7IMS.105 date: 03/09/2020 
  ID-1: BAT1 charge: 47.3 Wh condition: 48.9/53.4 Wh (92%) 
  volts: 12.0/10.9 model: MSI BIF0_9 type: Li-ion serial: N/A 
  status: Discharging 
  RAM: total: 15.46 GiB used: 1.51 GiB (9.8%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Topology: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP 
  arch: N/A L2 cache: 12.0 MiB bogomips: 62431 
  Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 2327 2: 3170 
  3: 1334 4: 1919 5: 3216 6: 2866 7: 1302 8: 3720 9: 4031 10: 3354 
  11: 2428 12: 1274 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat 
  arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
  clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl 
  dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d 
  fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb 
  ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca 
  mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx ospke 
  pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse 
  pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse 
  sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Device-1: Intel vendor: Micro-Star MSI driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9bc4 
  Device-2: NVIDIA vendor: Micro-Star MSI driver: nouveau v: kernel 
  bus ID: 01:00.0 chip ID: 10de:1f14 
  Display: x11 server: X.Org 1.20.8 driver: intel,modesetting,nouveau 
  alternate: fbdev,nv,vesa compositor: kwin_x11 
  resolution: 1920x1080~144Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.0.7 
  direct render: Yes 
  Device-1: Intel vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:06c8 
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f9 
  Sound Server: ALSA v: k5.7.0-3-MANJARO 
  Device-1: Intel driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
  chip ID: 8086:06f0 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: 3000 
  bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Local Storage: total: 953.87 GiB used: 14.95 GiB (1.6%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN730 SDBPNTY-1T00-1032 size: 953.87 GiB speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 11110000 scheme: GPT 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / size: 920.86 GiB used: 14.95 GiB (1.6%) fs: ext4 
  dev: /dev/nvme0n1p2 label: N/A 
  uuid: 62ef47be-a827-48fd-ad56-7ccd9ba2b161 
  ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 label: N/A uuid: FAF7-9188 
  ID-3: /var/lib/snapd/snap/core18/1754 raw size: 54.9 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop1 label: N/A uuid: N/A 
  ID-4: /var/lib/snapd/snap/snapd/8140 raw size: 29.8 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop0 label: N/A uuid: N/A 
  ID-5: /var/lib/snapd/snap/spotify/41 raw size: 163.7 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop2 label: N/A uuid: N/A 
  ID-6: swap-1 size: 17.00 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p3 label: N/A 
  uuid: 4670b395-8fc7-45f2-9c41-3aa174d8fe1a 
  Message: No unmounted partitions found. 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-3:2 info: N/A type: Mouse driver: hid-generic,usbhid 
  interfaces: 1 rev: 1.1 speed: 12 Mb/s chip ID: 0715:0206 
  Device-2: 1-7:3 info: Realtek RTS5129 Card Reader Controller 
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s chip ID: 0bda:0129 
  serial: <filter> 
  Device-3: 1-9:4 info: SteelSeries ApS SteelSeries KLC type: HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 1038:1122 
  Device-4: 1-13:5 info: Acer HD Webcam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 5986:211c 
  Device-5: 1-14:6 info: Intel type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0026 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 
  speed: 10 Gb/s chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 
  speed: 10 Gb/s chip ID: 1d6b:0003 
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: nouveau temp: 26 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
  Processes: 312 Uptime: 2m Init: systemd v: 245 Compilers: gcc: 10.1.0 
  Shell: bash v: 5.0.17 running in: konsole inxi: 3.0.37

Anyone know what could I do?

1 Like

Are you asking for help with Ubuntu or Manjaro? if the former, they have their own forums. If the latter, then please help us help you and provide information about your system:

1 Like

Thank you for your answer.
I've edited the Ubuntu reference, it was an error.
By the other hand, tomorrow I'll insert the log information, I'm newbie at Linux, what kind of logs should I post?

1 Like

The following from the link I posted would be a good start:

1 Like

Perhaps try to "disable MAC Address randomization ". If you search those terms on the forum you should easily be able to find instructions on how to do that.

1 Like

Nothing... I've introduced:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

but it's still not working.

Any suggestions?

Did you reboot after issuing the command?

Sure, I've rebooted the laptop after issuing the command.

You should also reboot the router/AP.

Well then I would go through the settings on your range extender AP and change the settings. Be sure no IP or MAC filtering is in place. Lower the chanel and bandwidth on the 5 GHz band to 40 or below.

Be sure your firmware on the AP is up to date and if settings changes do not work you should reset the AP to the factory defaults. It is irrelevant if other devices or OS's connect to the AP correctly, some Wifi adapters in Linux are finicky on the settings used in the AP.

1 Like

I've tried to reboot and to reset to factory on my Extender but it's still not working...

Did you change the the 5 GHz chanel and bandwidth settings (if you are using the 5 GHz band).

Do you mean doing so on the router or repeater?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by