Can't wake with keyboard

When my computer is suspended, I can wake it only by pressing the power button. I'd like to be able to press a key on the keyboard to wake it.

Keyboard is a Logitech MK710 with the (wireless) Unifying Receiver plugged into a USB port. A wireless mouse is also connected to the receiver.

In a perfect world, only the keyboard would wake the machine, but if both keyboard and mouse wake it, that's okay.

I've seen a lot of threads about the keyboard and mouse not working after suspend, which is not my problem. I've only seen one or two similar to this issue, and none of them seem resolved.

Thanks in advance for your assistance!

The keyboard model is not the issue here. If your BIOS has the option to Wake/Resume or Power ON from keyboard, it should be Enabled.

I'll check the BIOS. That said, the keyboard and mouse wake Windows 10, so I suspect the OS is playing a role.

Does the Windows sleep turn off the fans, does the same in Linux? Does the hibernate work on Windows and did you test in on Linux? Did you try to shutdown and boot in Linux then try to put the computer to sleep. Windows can influence a lot of things, see here some recommendations for dual-boot:


and

Both posts give some ideas about what can happen, what to avoid, and for sure can influence sleep/hibernate ...

From terminal run this command:
cat /sys/power/mem_sleep
then
cat /proc/acpi/wakeup

Someone might have an idea how to help you based on that information.

Thanks for the suggestions. I am not dual booting. I replaced the hard drive and installed Manjaro from scratch.

Results of cat /sys/power/mem_sleep:

s2idle [deep]

Results of cat /proc/acpi/wakeup:

|Device|S-state|  Status   Sysfs node|
|---|---|---|
|UAR1|  S4|*disabled  pnp:00:06|
|PS2K|  S4|*disabled|
|PS2M|  S4|*disabled|
|RP01|  S4|*disabled  pci:0000:00:1c.0|
|PXSX|  S4|*disabled|
|RP02|  S4|*disabled|
|PXSX|  S4|*disabled|
|RP03|  S4|*disabled  pci:0000:00:1c.2|
|PXSX|  S4|*enabled   pci:0000:03:00.0|
|RP04|  S4|*disabled|
|PXSX|  S4|*disabled|
|RP05|  S4|*disabled|
|PXSX|  S4|*disabled|
|RP06|  S4|*disabled|
|PXSX|  S4|*disabled|
|RP07|  S4|*disabled|
|PXSX|  S4|*disabled|
|RP08|  S4|*disabled|
|PXSX|  S4|*disabled|
|GLAN|  S4|*disabled|
|EHC1|  S4|*enabled   pci:0000:00:1d.0|
|EHC2|  S4|*enabled   pci:0000:00:1a.0|
|XHC|  S4|*enabled   pci:0000:00:14.0|
|HDEF|  S4|*disabled  pci:0000:00:1b.0|
|PEG0|  S4|*disabled  pci:0000:00:01.0|
|PEGP|  S4|*disabled  pci:0000:01:00.0|
|PEG1|  S4|*disabled|
|PEG2|  S4|*disabled|

That seems fine. What can be done is to create a rule for keyboard wakeup. First we identify the vendor and device id of the keyboard:
lsusb

look for the line for the keyboard and will be something like this example:
Bus 004 Device 002: ID 04f2:0402 Keyboard

so, still from terminal:
sudo nano /etc/udev/rules.d/10-wakeup.rules
and add

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="04f2", ATTRS{idProduct}=="0402" RUN+="/bin/sh -c 'echo enabled > /sys/bus/usb/devices/usb4/power/wakeup'"

where

  • 04f2 is the Vendor
  • 0402 is the Product
  • usb4 is the Bus 004

Hope this makes sense and will help you out. Of course you have to replace all those with the ones reported by your system.

1 Like

Thanks for your continued help. I added the line to the config file, but it still doesn't work. As best I can tell, putting the computer into suspend is cutting power to the USB port. Do you know how I can configure it to leave that port powered on during suspend?

Should i had said that needs a reboot after that, so the rule becomes active? :slight_smile:
Do you have TLP installed for power management?
See if by using TLPUI will be helpful for you ...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by