Cantata (MPD) not showing embedded album art in ogg files

I just installed Cantata and MPD from the repository to check it out.
My music library is mainly in .ogg and .flac.
Most of them hjave embedded album art, which works fine in Audacious.
But Cantata can not load the album art from the .ogg files. But it can from .flac.

Am I missing something or does Cantata simply not support the album art in .ogg files?

Works for me with Cantata 2.2.0.

$ pacman -Qi cantata
Name            : cantata
Version         : 2.2.0-3
Description     : Qt5 client for the music player daemon (MPD)
Architecture    : x86_64
URL             : https://github.com/CDrummond/cantata
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : qt5-svg  libmtp  libmusicbrainz5  mpg123  vlc  taglib-extras
                  media-player-info  libcdio-paranoia  udisks2
Optional Deps   : perl-uri: dynamic playlist [installed]
                  mpd: playback [installed]
                  ffmpeg: ReplayGain support [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 10.07 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Thu 11 Jan 2018 21:15:35 EAT
Install Date    : Mon 15 Jan 2018 14:06:20 EAT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Cheers,

You are playing ogg files, with only embedded cover art, with the download covers options turned off?

It's worse than that, my covers are not embedded, they're just in the same folder as the files.

However, it is supposed to be implemented: https://github.com/CDrummond/cantata/issues/24

If it doesn't work (I cannot check, as far as I know I don't have embedded covers) report the issue to Craig, he's super responsive.
Cheers,

1 Like

Nice. Embedded covers work in Flac for me, just not with Ogg, I'll report it later.

Alright.
Developer fixed it in the latest git, so it will be in version 2.3.0 when it releases.

Glad it wasn't just me. :stuck_out_tongue:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by