Certain media keys acting strangely, some freeze Pulseaudio widget

Hello, relatively new user here.
When I first installed Manjaro (about a month ago), my laptop's volume and brightness media keys (fn + F5-12) worked fine, but some time later (I don't know what brought about this change) they started acting strangely.

Whenever I try to change the volume, the Pulseaudio widget in the tray stops responding to left-clicks for an arbitrary amount of time and there is no bar in the corner of the screen displaying the change in volume.
Previously the volume would also change over the span of many seconds, as if the requests were being executed in order but ~10 seconds apart and amplified, but after a reinstall of the Pulseaudio plugin, at least the volume changes as it should.

Whenever I try to change the screen brightness, I get the staggered changes I mentioned above, which are sometimes so amplified that the brightness is reduced to zero.

I even found this topic on the Arch forums, where makeworld seems to be having the same problems as I, but the issue hasn't been solved yet.

And some interesting observations about pressing my media keys, if they help: pressing the ones for volume control makes the terminal cursor flicker, pressing the ones for brightness hides the dropdown terminal window and the ones without illustrations - fn + F3 and fn + F4 - open my default mail client and browser respectively, and I don't know why.

Here is my system information

System:    Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 
           info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X555LF v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X555LF v: 1.0 serial: <filter> UEFI: American Megatrends v: X555LF.601 date: 05/06/2016 
Battery:   ID-1: BAT0 charge: 8.6 Wh condition: 10.9/37.3 Wh (29%) volts: 7.6/7.6 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: <filter> status: Charging cycles: 709 
Memory:    RAM: total: 5.77 GiB used: 4.82 GiB (83.6%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 3072 KiB 
           bogomips: 17582 
           Speed: 799 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 799 2: 799 3: 799 4: 799 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts clflush cmov 
           constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority 
           flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx 
           monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse 
           pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall 
           tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
           Device-2: NVIDIA GM108M [GeForce 930M] vendor: ASUSTeK driver: nvidia v: 440.100 bus ID: 04:00.0 chip ID: 10de:1346 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia resolution: 1366x768~60Hz 
           OpenGL: renderer: GeForce 930M/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:160c 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:9ca0 
           Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: 4000 
           bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: AzureWave driver: ath9k v: kernel 
           port: 4000 bus ID: 03:00.0 chip ID: 168c:0036 
           IF: wlp3s0 state: up mac: <filter> 
           IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 145.27 GiB (60.9%) 
           ID-1: /dev/sda vendor: Micron model: M600 MTFDDAK256MBF size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: MU01 
           scheme: GPT 
           Optical-1: /dev/sr0 vendor: Slimtype model: DVD A DA8A6SH rev: GAA1 dev-links: cdrom 
           Features: speed: 24 multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 233.43 GiB used: 145.27 GiB (62.2%) fs: ext4 dev: /dev/sda2 label: N/A 
           uuid: 7cd721cb-266d-48a6-b981-92abfcff072f 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 label: N/A uuid: E51C-8431 
Unmounted: Message: No unmounted partitions found. 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 11 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-1:2 info: Trust Trust Primo Mouse type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 1.1 
           speed: 12 Mb/s chip ID: 145f:01d2 
           Device-2: 1-5:3 info: Realtek USB Camera type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
           chip ID: 0bda:57b5 serial: <filter> 
           Device-3: 1-6:6 info: IMC Networks type: Bluetooth driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s 
           chip ID: 13d3:3423 
           Device-4: 1-8:5 info: Realtek RTS5129 Card Reader Controller type: <vendor specific> 
           driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc interfaces: 1 rev: 2.0 speed: 480 Mb/s chip ID: 0bda:0129 
           serial: <filter> 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 66.0 C mobo: N/A gpu: nvidia temp: 63 C 
           Fan Speeds (RPM): cpu: 3900 
Info:      Processes: 236 Uptime: 18m Init: systemd v: 245 Compilers: gcc: 10.1.0 clang: 10.0.0 Shell: bash v: 5.0.18 
           running in: xfce4-terminal inxi: 3.0.37

I have been trying to fix this for a while and have tried multiple approaches. It isn't a hugely problematic issue, but I would like to regain full control of my media keys, so any help would be appreciated.

Forum kindly sponsored by