Change graphics drivers and now Manjaro doesn't start


Two problems. First, apparently my amd gpu wasn't being used by manjaro (although drivers were installed). Second, after changing drivers manjaro won't start.

Long version

Recently installed Manjaro in new desktop computer. I have a AMD R5450 graphics card. The card's HDMI output is what I use for display and after installation I could see the xfce desktop working so I thought everything was ok. Also mhwd and manjaro settings manager indicated that fglrx (Catalyst) driver was installed.

$ inxi -Fxzc0
System:    Host: tornado Kernel: 4.4.36-1-MANJARO x86_64 (64 bit gcc: 6.2.1) Desktop: Xfce 4.12.3 (Gtk 2.24.31)
           Distro: Manjaro Linux
Machine:   Device: desktop Mobo: ASUSTeK model: M5A97 LE R2.0 v: Rev 1.xx BIOS: American Megatrends v: 2601 date: 03/24/2015
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 42157
           clock speeds: max: 3500 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 2000 MHz 5: 2000 MHz 6: 2000 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] bus-ID: 01:00.0
           Display Server: X.Org 1.17.4 driver: fglrx Resolution: 1280x720@59.94hz
           GLX Renderer: AMD Radeon HD 5450 GLX Version: 4.5.13399 - CPC 15.201.1151 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.4.36-1-MANJARO
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.040.00-NAPI port: d000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros AR9271 802.11n driver: ath9k_htc usb-ID: 001-002
           IF: wlp0s18f2u2 state: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (16.5% used)
           ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
Partition: ID-1: / size: 908G used: 146G (17%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 33.8C mobo: N/A gpu: 62.50C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 171 Uptime: 5:15 Memory: 2100.4/7890.9MB Init: systemd Gcc sys: 6.2.1
           Client: Shell (bash 4.4.51) inxi: 2.3.4

Later I noticed that VLC playing 720p videos lagged the computer a lot and sometimes it would completely stop responding. To see if the gpu was being used I tried aticonfig but it indicated that it was loaded at 0%.

Also Geeks3D gpu benchmanrk (2014) apparently loaded all computing to the cpu (checked with command top) and nothing onto the gpu (checked again with aticonfig).

I read that perhaps it was a drivers issue, so I used settings manager to remove catalyst driver and inmediately after, install the alternative free ati driver. I restarted the computer but now manjaro doesn't start. It's stuck in a black screen showing:

starting version 232
/dev/sda1: clean, xxxxx/xxxxxx files, xxxxx/xxxxx blocks

Why aticonfig showed 0% gpu load? that doesn't make sense to me. Could it be that manjaro wasn't "using" the gpu somehow?

Is there a way to get manjaro working again without reinstalling? I don't have acces to a command line or anything, it's stuck in that black screen.

I'm not very knowledgeable with linux, any help will be appreciated.

Boot into a Live Manjaro environment.

Take note of which driver is being used in Live with mhwd -li.

Mount your system parition to somewhere like /media/sys (you may have to mkdir this). You can use lsblk to list all partitions if you can't remember its device name.

Use the manjaro-chroot command on /media/sys to chroot into your system.

Check logs for any errors are being generated during failed boots using journalctl -p err.

Within a manjaro-chroot Live enviroment you can use mhwd to re-install your graphical driver if required.

Ok, lets see. Booting from a manjaro 15 usb that i had at hand

$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
             video-ati            2015.11.08                true            PCI

the I followed How to save your Manjaro installation when it breaks
Mounted the filesystem
sudo mount /dev/sda1 /mnt
then installes mhwd/chroot and
sudo mhwd-chroot /mnt
and used journalctl -p err in the terminal emulator that opened. It showed errors up to Dec04, here are the entries for that day

Dec 04 15:20:23 tornado kernel: usbhid 5-3:1.0: couldn't find an input interrupt endpoint
Dec 04 15:31:22 tornado ntpd[1379]: bind(26) AF_INET6 fe80::5662:cd9c:c77c:ca94%3#123 flags 0x11 failed: Cannot assign request
Dec 04 15:31:22 tornado ntpd[1379]: unable to create socket on wlp0s18f2u2 (7) for fe80::5662:cd9c:c77c:ca94%3#123
Dec 04 15:35:03 tornado dhclient[12983]: receive_packet failed on wlp0s18f2u2: Network is down
Dec 04 18:18:35 tornado systemd-coredump[14664]: Process 12913 (firefox) of user 1000 dumped core.
                                                 Stack trace of thread 12913:
                                                 #0  0x00007f044cd31f5f raise (
                                                 #1  0x00007f043f8051d3 n/a (
                                                 #2  0x00007f043fcefd41 n/a (

Just all the previous entries they don't seem to mention anything related to amd drivers. except for this two lines that say pci

Dec 03 23:09:25 tornado systemd-udevd[236]: seq 1971 '/devices/pci0000:00/0000:00:07.0/0000:03:00.0/usb2/2-2/2-2:1.0/host8/tar
Dec 03 23:10:49 tornado systemd-udevd[236]: worker [5622] failed while handling '/devices/pci0000:00/0000:00:07.0/0000:03:00.0

Anyways, they don't seem relevant. Next I reinstalled drivers:
Removed video-ati
# mhwd -r pci video-ati
and installed proprietary drivers again
# sudo mhwd -a pci nonfree 0300

Reboot computer and Manjaro starts just like before. Thanks @sueridgepipe, i got my computer working again.

1 Like

BTW if you want to switch to video-ati you need to do it this way

sudo mhwd -r pci video-catalyst
sudo pacman -S "xorg-server>=1.18 xf86-input-libinput"

and then you can install video-ati without a risk. Thats because video-catalyst installs an old xserver version (thats the last one it supports, because catalyst is not supported anymore by amd). When you then uninstall video-catalyst it uninstalls the old xserver but dont installs the new one again. So after a restart you dont have a working graphical interface. thats why you need xorg-server>=1.18.

I switched to video-ati updating xorg-server as indicated but manjaro wouldn't start either, here's the error message i got from journalctl

dic 13 10:06:31 tornado kernel: [drm:drm_edid_block_valid [drm]] *ERROR* EDID checksum is invalid, remainder is 170
dic 13 10:06:31 tornado kernel: Raw EDID:
dic 13 10:06:31 tornado kernel:          00 ff ff ff ff ff ff 00 63 18 29 00 01 00 00 00
dic 13 10:06:31 tornado kernel:          23 12 01 03 80 73 41 78 0a f3 30 a7 54 42 aa 26
dic 13 10:06:31 tornado kernel:          0f 50 54 25 c8 00 31 59 45 59 61 4f 01 01 01 01
dic 13 10:06:31 tornado kernel:          01 01 01 01 01 01 02 3a 75 ff ff ff ff ff ff ff
dic 13 10:06:31 tornado kernel:          ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
dic 13 10:06:31 tornado kernel:          ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
dic 13 10:06:31 tornado kernel:          ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
dic 13 10:06:31 tornado kernel:          ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff

So I booted from usb and reinstalled catalyst using chroot as before.

Leaving aside for a moment the problem of switching drivers, does it make sense that aticonfig shows gpu load 0% when one would expect the gpu to be wolking?

Can you run xrandr --prop? EDID checksum errors usually mean that there are errors in the communication between your PC and your display. This would also explain why you recive whitescreens sometimes with the free driver.

I dont know.. like i've said. fglrx(catalyst) is in End Of Life state. Nobody is working on this driver, fixing bugs or anything. So maybe this tool just can not read "something" and it will always show 0%. Just run a little OpenGL game to be sure that the driver is used. Or glxgears

running xrandr --prop:

$  xrandr --prop
Screen 0: minimum 320 x 200, current 1280 x 720, maximum 8192 x 8192
DFP1 connected 1280x720+0+0 (normal left inverted right x axis y axis) 1152mm x 648mm
	SignalFormat: TMDS 
	ConnectorType: HDMI 
   1280x720      50.00*+  59.94  
   1920x1080     60.00 +  50.00    59.94    50.00    59.94  
   1776x1000     50.00    59.94    50.00    59.94  
   1680x1050     60.00    59.94  
   1400x1050     60.00    59.94  
   1600x900      60.00    59.94  
   1360x1024     60.00    59.94  
   1280x1024     60.00    59.94  
   1440x900      60.00    59.94  
   1280x960      60.00    59.94  
   1280x768      60.00    59.94  
   1024x768      60.00    59.94  
   1152x648      50.00    59.94  
   800x600       60.00    59.94  
   720x576       60.00    59.94  
   720x480       60.00    59.94  
   640x480       60.00    59.94  
DFP2 disconnected (normal left inverted right x axis y axis)
	SignalFormat: TMDS 
	ConnectorType: DVI-D 
CRT1 disconnected (normal left inverted right x axis y axis)
	SignalFormat: VGA 
	ConnectorType: VGA 

Error of comunication... would it make any diffrerence to use VGA instead of HDMI? would have tested by now but i don't have VGA cable at hand.

[quote="anon35400795, post:6, topic:14042"]
Just run a little OpenGL game to be sure that the driver is used. Or glxgears
I tried supertux and it runs alright, does it mean that the driver is used?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by