Changing between two keyboard layouts in Manjaro KDE

Hi,
I have installed Manjaro KDE. I want to be able to easily switch between two keyboard layouts: pl,gb
I've used the manual: https://wiki.manjaro.org/index.php/Keyboard_Layout
I have also went through help topics both for Manjaro and for Arch, they all had similar solutions to wiki page above.
Unfortunately nothing happens when I use alt + shift. I've tried to hold them for long, press together quickly, press and hold one, click another and no results.
Now, my files:

/etc/X11/xorg.conf.d/.00-keyboard.conf

# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "gb,pl"
        Option "XkbModel" "pc105"
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection

/etc/X11/xorg.conf.d/90-mhwd.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.82

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection
 

Hi,
I would take that out. Even maybe use just: Option "XkbLayout" "gb" or Option "XkbLayout" "pl" ( by the way, there is nothing wrong with your configs)

But, on KDE Plasma better make use of the Keyboard Settings:

and set the shortcut there, plus there you have more options. :slight_smile:

3 Likes

Haha, what a failure on my side :smile: that's it. I was looking in the wrong place (Keyboard settings in main menu, not under Input Devices). That's it sorted, thanks a lot! :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by