Changing GPU; Nvidia -> AMD = How?

Hi.

I've been using Nvidia GTX 970 for many years now. Manjaro has been my main OS a couple of them, and now I've gotten hold of a RX 580.

My question is this:

  • How do I properly change said GPUs without getting any software problems because of it?

Currently installed latest Nvidia drivers on KDE installation of Manjaro 5.7 Kernel.

1 Like

Hi,

Just remove the drivers for nvidia, probably need to install the video-linux back, remove the /etc/X11/xorg.conf.d/90-mhwd.conf and /etc/X11/mhwd.d/nvidia.conf files, shutdown the system, swap the GPUs, boot the system.

1 Like

Swift reply, gratitudes.

Didn't think of removing the X11-configs.

Will do this and make a comment on how the experience thereafter is.

Thank you.

1 Like

Okay so stuff happened..

I did what you described, but after booting, I was stuck with a 640x440 window.

I tried a lot of stuff, but weird thing is that my 2560x1440 monitor didn't work, whereas a backup 1080p monitor worked perfectly.

I am at a loss, and might return my card.. I want open source, but what is the reason my main monitor doesn't understand? (Worked under windows)

If you are on XFCE there might be required that you delete
~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml

Maybe you have to add nomodeset at first boot ... There shouldn't be much hiccups.

I'm on KDE.

It has to be something with my specific monitor. Using the 1080p monitor I have, I had no issues. Windows and my 1440p (main) monitor; No issues.

But the UI for Display Settings is showing all the available resolutions and refresh rates in the list ?

image

No.

On my main monitor (ROG PG278Q) it only shows 640x4X0.

I saw this: https://rizvir.com/articles/asus-PG278Q-in-linux/

  • But couldn't use xrandr.

Feel like that would solve it.

I tried creating a modeline in a 10-monitor.conf under xorg.conf.d/, but it didn't work.

So, from what i gathered that GPU has this number of ports:

DVI 1
HDMI 1
Display port 3

So, have you tried to switch them?

Why not? Did you get some error?

I don't think that works without a xorg.conf file or similar.

Correct. Tried all DP. Same on all ports.

Well, cough, it said: "command not found". :stuck_out_tongue:

Install xorg-xrandr package and the command will be available. :slight_smile:

Running any "xrandr" command returned "Could not connect to display".

Are you running on Wayland Session?

Clean install of Manjaro, so whatever is standard.

Video-Linux is all I need installed, right? Not modesetting or vesa?

yes.
If i'm not mistaken it will run a script and mhwd-amdgpu will be involved too. Can't say i know the exact way it works.

Summary:

Don't have the wrong monitor when open sourcing :stuck_out_tongue:

Oh well, I guess I'll return the card..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by