Changing Kernel in Manjaro Live

Greetings!

So, I decided to finally give a shot to Linux - and my eyes were glued to Manjaro Linux due to Aur and Rolling Release
But I've encountered a severe problem - when I try to install newer snapshots of Manjaro with kernels 5.4-5.6, it seems that Calamares is stuck when it tries to load partirion info
Manjaro Architect - same thing - freezes when it comes to partition change
Running sudo -E calamares -d gave me segmentation fault, searching similar topics gave me no solutions because they were not adressing my issue

But! I was able to successfuly install manjaro 18.0 - kernel 4.19, although updating system killed it - and it's easy to understand why - the version is too old

So, is there anything I can do to change kernel in live CD and install current stable release with kernel 4.19?

Another approach could be to choose the proper ACPI kernel argument as described here:

I will give a shot

But Live version of Manjaro is booting and working properly, it's the installation I cannot continue

I am typing it from the Live USB, kernel 5.5
Tried using gparted from here - it cannot access partition table

So, pressing E did nothing - it was a normal boot

Did you actually use the architect ISO files for installation or did you just start architect from a normal live ISO like XFCE, KDE, GNOME, ect. ?
If you did so, can you try if the architect installer works if you use the actual architect ISO?

Asides, If you are interested in making custom ISOs you can always make your own ISO with kernel 4.19: https://wiki.manjaro.org/Build_Manjaro_ISOs_with_buildiso
If you want me to make you an ISO with 4.19, let me know.

1 Like

try this, it's kernel 4.19. I made it for someone else with a similar issue and it's not that old yet to be problematic with updates after install

Yes, I made an installation with the architect ISO - it freezes when I try to access partition table

It's rather interesting issue, I wonder why it's happening

I will try @antikythera ISO with kernel 4.19 and I will let know if it works

Thank you very much for helping!

image

Well, ISO that @antikythera kindly provided did not work for me
Tried using ACPI - no use, same thing every time

I had a hypothesis - so I booted from KDE Neon Live USB - Kernel version 5.3.0-45-generic
I successfully reached disk installation - no problem at all
But it's Ubuntu (and that means debian) based distro, so it's not what I would like to install

The main question is - is it Arch-based problem, Manjaro-based problem or Kernel-based problem?

My goodness, I tried booting using non free video drivers - that was stupid

So, I booted successfully to @antikythera ISO
Tried installing from it - no use
Running sudo -E calamares -d gave me this result

void Calamares::RequirementsChecker::reportProgress()
Remaining modules: 2
"partition"
"welcome"
And this was on loop

Tried running architect - same thing, I was able accessing partition table, but i was not able to write anything to it
Gparted did not work

So, I guess it's not a Kernel problem?

You can easily install kernels or any package from live system.

sudo pacman -Syy
sudo manjaro-chroot -a

This will log you as root into the installed OS and from there you can use mhwd (see manjaro wiki) to install kernels.

However, from your boot output it doesn't look like a kernel problem, but rather a graphical problem. X session won't start. It could be due wrong graphical drivers, wrong configuration of said drivers, wrong lighdm config, wrong xorg config, etc.
I'm assuming this is already installed OS?

Show the output of:

systemctl status lightdm.service

Run the above command as root or with sudo if you are a user.

Also, show your hardware with

inxi -Fxxx0

No, the booting problem was fixed - I tried booting using non-existent proprietary video drivers- so switching to free drivers solved the case in that
But the problem remains - I cannot procced to disk setup during installation

Blockquote
So, I booted successfully to @antikythera ISO
Tried installing from it - no use
Running sudo -E calamares -d gave me this result
void Calamares::RequirementsChecker::reportProgress()
Remaining modules: 2
"partition"
"welcome"
And this was on loop
Tried running architect - same thing, I was able accessing partition table, but i was not able to write anything to it
Gparted did not work
So, I guess it's not a Kernel problem?

Is it by any chance a dual boot? In such case, did you disable fast boot? Fast boot basically suspends Windows and makes the partition (maybe the disk?) inaccessible. Also, there was a matter of disabling secure boot, but I suspect this is not an issue nowadays, or maybe there is? My last dual boot install was 4 years ago, so I can't be sure.

Usually, from live system you have full access to disks and you can do with them all you want, including messing with your windows partitions. The only thing that comes to mind that can prevent it is some lock down from Windows (fast boot, or maybe it's in the updating process), something in BIOS/UEFI settings, or maybe disc encryption? Or maybe not, encryption should prevent accessing the data, not the deletion or formatting of the partition, so I think. Correct me if I'm wrong.

Also, if the partitions are mounted, you cannot do any operations on them, but that is detected by gparted or probably by system installer and solved by asking you if you want it to unmount.

1 Like

I will try changing fast boot.
But the thing is, why I was able to install ubuntu-based distros and not acrh-based distro?

I don't know. Sometimes fast boot blocks the partition, sometimes it doesn't. As to secure boot, Ubuntu got some certificate so the secure boot will allow it, I'm not sure about Manjaro thou.

Or as I said, you are in the middle of the update, so boot into windows, turn off fast boot, shut it down and try installing Manjaro again.

As for the headline for your topic.

You can't change kernel on a live ISO.

I give up
Disabling fast boot didn't do anything

What kind of hardware do you have @Alive_Salad? We can surely spin a new ISO featuring an older kernel like 4.19 series. So which edition of Manjaro worked last for you?

1 Like

I already tried kernel 4.19 that other user had kindly provided. It's no use too - same thing when I try to reach disk setup
The latest Manjaro that did work - Manjaro KDE 18.1.0

This is what my setup looks like

  Host: manjaro-gnome Kernel: 5.6.2-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Gnome 3.36.1 wm: gnome-shell dm: GDM 3.34.1 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: P55-UD3 serial: <root required> 
  BIOS: Award v: F9 date: 06/23/2010 
CPU:
  Topology: Quad Core model: Intel Core i5 760 bits: 64 type: MCP 
  arch: Nehalem rev: 5 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 22392 
  Speed: 1199 MHz min/max: 1197/2794 MHz boost: enabled Core speeds (MHz): 
  1: 1199 2: 1199 3: 1199 4: 1199 
Graphics:
  Device-1: NVIDIA GF114 [GeForce GTX 560 Ti] vendor: Micro-Star MSI 
  driver: nvidia v: 390.132 bus ID: 01:00.0 chip ID: 10de:1200 
  Display: x11 server: X.org 1.20.8 driver: nvidia compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 560 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.132 
  direct render: Yes 
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:3b56 
  Device-2: NVIDIA GF114 HDMI Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0c 
  Device-3: BEHRINGER UMC202HD 192k type: USB driver: snd-usb-audio 
  bus ID: 1-2:3 chip ID: 1397:0507 
  Device-4: Alesis VMini type: USB driver: snd-usb-audio bus ID: 5-2:3 
  chip ID: 13b2:00a2 serial: Ver00.10 
  Sound Server: ALSA v: k5.6.2-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: de00 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 00:24:1d:d3:4d:f4 
Drives:
  Local Storage: total: 1.66 TiB used: 171.46 GiB (10.1%) 
  ID-1: /dev/sda vendor: Western Digital model: WD3200AAJS-00YZCA0 
  size: 298.09 GiB speed: <unknown> serial: WD-WCAYU3281917 rev: 0A01 
  scheme: MBR 
  ID-2: /dev/sdb vendor: Seagate model: ST31000528AS size: 931.51 GiB 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: 6VPB3CVE rev: CC46 scheme: MBR 
  ID-3: /dev/sdg type: USB vendor: Samsung model: HM500JI size: 465.76 GiB 
  serial: 101A108A00462 scheme: MBR 
Partition:
  ID-1: / size: 11.72 GiB used: 690.5 MiB (5.8%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 45 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 45% 
Info:
  Processes: 221 Uptime: 1h 16m Memory: 15.63 GiB used: 1.86 GiB (11.9%) 
  Init: systemd v: 244 Compilers: gcc: N/A Shell: zsh v: 5.8 
  running in: gnome-terminal inxi: 3.0.37 

I hope it gave some useful information

I don't think it's kernel related. Last time kernel 5.6 worked for you and your hardware is not that old or unusual. The thing alone that you cannot partition anything, both in installer or with gparted is something very strange.

Can you modify or format partitions using other Linux systems? I know that Ubuntu worked fine in the past but I mean now. Either something is wrong globally (so independently of live system) or within Manjaro. However, if Manjaro would be at fault, gparted should work anyway.

There is something to figure it out here.

1 Like

Forum kindly sponsored by