Chinese Pinyin Input: I tried all of them and none work

I have read the forum posts on installing pinyin Chinese input method on Manjaro. I tried many of them. Nothing works. Can someone provide the most updated method step by step on how to get Chinese pinyin input method to work? I prefer sogou pinyin but I also want Google pinyin or something else that is intelligent.

I have had this headache with any Linux OS I tried. The only thing that is easy was Ubuntu and installing Sogou pinyin. I don't understand why it is so difficult to set this up in Linux.

1 Like

I tried all of them and none work

It would help a lot of you can please tell us what you've tried.

I have tried all the packages found in the AUR and package manager. Sogou pinyin fails during install. For IBUS, I can see the IBUS choices but when I type and press CTRL space I don't see any Chinese or pinyin dropdowns like you usually would. I have both FCITX and IBUS installed. I can see the menus on my desktop but when typing nothing happens. I tried going into the settings but nothing seems to work. I think I have missed a step somewhere during installation. I am not sure which instructions I should follow. There is a lot on the Internet to choose from.

After some attempts, I found fcitx and sunpinyin to be the best choice. If fcitx is not work, you may need check ~/.xprofile. It should be like this:

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=”@im=fcitx”
1 Like

And in case you don't know, there is a Chinese section here.

你好! 有没有说明怎么安装sunpinyin + cloudpinyin?

pacman -S fcitx-cloudpinyin fcitx-sunpinyin
上面的帖子里面有,如下。

安装方法

  1. 安装
    sudo pacman -S fcitx-im fcitx-configtool fcitx-cloudpinyin fcitx-sunpinyin
  2. 配置文件
    /etc/profile 或者 ~/.xprofile 文件中添加:
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

log out, log in,然后就可以使用fcitx了。

1 Like

请问: `/etc/profile 和 ~/.xprofile 怎么找 怎么打开

Thanks

Dustin

虽然这有点失礼,但是我认为你可能需要先学习下linux的一些基础知识。
~/.xprofile 中,~表示你的home文件夹,文件名前加点表示隐藏文件。如果你用的是dolphin文件管理器,那么ctrl+h可以切换是否显示隐藏文件。一般来说,~/.xprofile 默认是没有的,你得新建一个文件叫这个名字,点击打开。

1 Like

这个解决了! 谢谢。

I followed your instruction on how to install and configure Chinese Pinyin input method. It works but I can type only traditional character. Tried to switcch to simplified character by way of right-clicking the icon on the syatem tray and choosing simplified character. But I can't make it work.

Edit: It seems that I've got it working :slightly_smiling_face:

非常感谢!

祝好

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by