Chromium flash pepper + keyring

Hi. Probably you will not want to disable it. Chromium need a keyring to store your passwords. Whitout it your secrets can't be securely stored.
If you are definite to disable it any way, install seahorse package. It allows you to reset Gnome keyring password. If you choose empty password, you will not see that prompt again.

1 Like

Answer "n" when asked to edit and answer "y" when asked to continue or to install.

1 Like

[code]==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> pepper-flash dependencies:

  • gcc-libs (already installed)

==> Continue building pepper-flash ? [Y/n]
==> --------------------------------------
==> y

==> Building and installing package
==> ERROR: Cannot find the strip binary required for object file stripping.
==> ERROR: Makepkg was unable to build pepper-flash.
==> Restart building pepper-flash ? [y/N][/code]

Make sure you have base-devel group installed:
sudo pacman -Syu base-devel


Please provide details of your system when asking for help. Solution varies with DE/wm. Create an entry here and bookmark it for future reference.

In xfce open xfce4-settings > session and startup > enable gnome services at startup
In other DE/wm-s add the following command to your autostart

/usr/bin/gnome-keyring-daemon --start --components=pkcs11,secrets,ssh

Then create a file ~/.config/chromium-flags.conf and add the following line


If you are using sddm as display manager, change it because it won't play well with gnome-keyring.
That should cover the keyring part.

You already have solution for pepper-flash above ^. Cheers.

1 Like

For Manjaro XFCE: To make the keyring password request go away, I found it was sufficient to open Settings > Session and Startup > Application Autostart Tab and check the box for the existing entry "Secret Storage Service (GNOME Keyring: Secret Service)" then reboot. Beginning with next Chromium start, the requests no longer appeared.


secrets is just one component. ^ enabling "gnome-services" will enable all necessary components. In my command i'm using 3 components, you can add more if available. One Ring to rule them all, and in the Stallman bind them.

Hi same error

I did not understand how to fix???
gnome keyring:secret service active

That is not an error. It is supposed to work this way.

there are two more Chaviero de GNOME, tick those too.

Nein !

Hi,create file,active all service gnome keyring problem continue how fix????

you don't have to add duplicate entries in your start-up, just hover your mouse and read the command(s).
Which display manager are you using ? sddm doesn't work with gnome-keyring, at all.

Oh, and you have to logout then login for effect.

Using LightDM gtk + greeter standard manjaro xfce

You are right. "secret storage service" was the first option I tried to fix the issue and it worked, so I did not test the others. Later, on another machine, I used "Certificate and Key Storage" instead and that also worked.

Tested method above not work,there is another tip
@badbodh Yes created just one service your tip

Yes active service problem continue

open thunar, go to ~/.config/autostart and clean up whatever keyring related *.desktop got created, else they may interfere with next step.

Try this instead (should have been enough for Xfce)

Thank you so much :wink:

I'm also having the issue :frowning: I've tried several of the methods here and on other posts and it still isn't fixed. I've tried individually selecting those services like Secret Storage Service, and that didn't work. I deselected those, and only selected the Launch GNOME services on startup, and that didn't work. Then I deleted the *.desktop files you mentioned, still no fix.

The main issue is that every time I restart my computer, I have to log in to Chromium and any other page I have a login for (facebook, twitter, etc.). I assume it's related to this keyring thing. Anyways, help is appreciated. I feel comfortable editing config files if you have some command line way of getting my settings corrected. Thanks!

my inxi output is here: Dump your "inxi -Fxxxza --no-host" here and bookmark it

That changes things. Once you log into keyring, no more password-typing is needed (except for your primary sync account, which will still ask for password)

Delete these and reset your chromium profile (back up the first one)
and start chromium again. You can always re-sync most of your data.

Forum kindly sponsored by