[cinnamon] No windows in grub

Hi every one and thanks for the coming help.

I just reinstalled manjaro on top of my freshly installed Windows 10.

Both are on a single SSD, with /home and /swap for the new manjaro on another HD.

I did create an EFI partitions with the boot and esp flags, though it does not appear in the output of parted -l.

After installation windows is not an option in the grub. I saw multiple similar issues on the forum, but they are all slightly different from mine so I can't figure out what to do exactly.

Windows boot manager still appears in my efibootmgr though...

I tried with disabled fast-boot, and it does not resolve the issue.

I also updated the grub via sudo update-grub, after setting it to STYLE=menu.

Here's the state of my system :

~]$ efibootmgr -v
[sudo] password for aximili: 
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0002,0000
Boot0000* Windows Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...3................
Boot0001* Manjaro	HD(3,GPT,22e5d0c6-e2e9-4947-9136-e617abf54ae0,0x18491000,0x100000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0002* UEFI OS	HD(3,GPT,22e5d0c6-e2e9-4947-9136-e617abf54ae0,0x18491000,0x100000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
~]$ sudo parted -l
Model: ATA SanDisk SDSSDA24 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  17,8MB  16,8MB               Microsoft reserved partition  msftres
 2      17,8MB  209GB   209GB   ntfs         Basic data partition          msftdata
 3      209GB   209GB   537MB   fat32                                      msftdata
 4      209GB   240GB   30,9GB  ext4


Model: ATA ST2000DM006-2DM1 (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      17,4kB  8591MB  8591MB  linux-swap(v1)        swap
 2      8591MB  2000GB  1992GB  ext4
~]$ sudo blkid
/dev/sda1: PARTLABEL="Microsoft reserved partition" PARTUUID="c99d4183-31bf-4438-9723-f43fdf38c89a"
/dev/sda2: BLOCK_SIZE="512" UUID="8CF8804CF880370C" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="e018f6dc-e42c-406f-9992-04602ca8d6a8"
/dev/sda3: UUID="8864-C8DD" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="22e5d0c6-e2e9-4947-9136-e617abf54ae0"
/dev/sda4: UUID="713b50c9-35e3-41ff-9e16-3586e5f59743" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="02d3d887-3276-4a6a-a381-b6b60955f71e"
/dev/sdb1: UUID="8469d6da-9135-4f5f-9059-1ebf2d767581" TYPE="swap" PARTUUID="cd65ee0f-7f7b-4174-9b70-e30bbb8d0ea8"
/dev/sdb2: UUID="e48094a1-a527-46f6-bd9b-87a168af4fa9" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="32968599-e888-4314-aa73-43f6ea3b5c30"
cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=8864-C8DD                            /boot/efi      vfat    umask=0077 0 2
UUID=713b50c9-35e3-41ff-9e16-3586e5f59743 /              ext4    defaults,noatime,discard 0 1
UUID=8469d6da-9135-4f5f-9059-1ebf2d767581 swap           swap    defaults,noatime 0 2
UUID=e48094a1-a527-46f6-bd9b-87a168af4fa9 /home          ext4    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Please tell me if you need other information !

At manjaro terminal, print output of
chainloader /EFI/Microsoft/Boot/bootmgfw.efi

ls /boot/efi/
ls /boot/efi/efi/
ls /boot/efi/efi/Microsoft/
ls /boot/efi/efi/Microsoft/boot/

If you do not see any /boot/efi/efi/Micrososft, you most likely formatted $esp at /dev/sda3 (/boot/efi) when you installed Manjaro. That would have deleted Microsoft bootloader.
You will need to reinstall windows boot and then reinstall Manjaro bootloader.

You said you created a EFI partition for Manjaro reinstallation.
Was that not present before you reinstall?
Or had you created this partition on top of a present fat32 partition?
Wasn't /dev/sda3 present then for windows to boot?
Windows need a fat32 partition for it to boot as well in uefi/gpt.
Unless..... windows was not booting well before manjaro was reinstalled. Was it?

2 Likes

Windows was booting well before. I don't remember deleting a boot partition during my first install, but I tried reinstalling multiple times since then so I could be wrong.

There's indeed no /boot/efi/efi/Microsoft :

 >ls /boot/efi/efi
boot  Manjaro

In /boot/efi/ there's only /boot/efi/efi.

So then next step is reinstalling windows boot and Manjaro bootloader. Do you have any links with instructions for that ?

thanks a lot !

I'd rather not suggest anything for reinstalling windows boot. I haven't done this personally and there are many here who have done this . Please refer to a windows website on how to do this.
As for reinstalling manjaro boot after you get back your windows, use the [Simple Configfile Method] to do that.

So, I don't really understand all the UEFI stuff, but maybe my recent experience will help.

I recently got my first new desktop since 2012, which used what is now called legacy BIOS, and never had a problem. Yesterday, after some weeks of just playing around with WSL and display servers and distros on Windows 10, I finally got around to dual-booting.

Installed Manjaro KDE, and it went fine. I rebooted. It booted into Manjaro, no Grub, no options.

After hours of headaches and searching and reading and running rescue disks to look at partitions and bootloaders, it was a simple as this:

If I want to boot into Windows I have to hit F12 (on my Dell) to get boot options, scroll down to Windows Bootloader and hit enter. If I want to boot into Manjaro I do nothing.

I think it is legacy v UEFI and safeboot blah, blah, blah....don't know, no longer care...hope it helps.

Hi, thanks for the help !

Unfortunately the windows bootloader doesn't appear in my UEFI bios, so I cannot boot on it that way.

And thinking back about my installation process, I am pretty sure I did not format the windows partition. At first I installed manjaro on the secondary HDD ONLY, without modifying anything on the windows SSD. And the situation was already the same, no windows option possible.

I don't know if that explains anything; but maybe it'll help.

1 Like

Your manjaro /root partition is on the same disk as windows, the Sandisk
Your $esp (/boot/efi) partition is also on the same disk as windows.
Only your /home and swap is on the HDD.

Can you explain the above statement?
Perhaps you inadvertently made these partitions on the SSD?

I first installed everything on the HDD without changing anything on the SSD. When I booted this set up I did not have a grub at all, so I tried to reinstall manjaro /root and /boot/efi on the SSD.

But it did not change anything. I manage to have a grub by setting GRUB_TIMEOUT_STYLE to menu instead of hidden in /etc/default/grub.

But I assume that the problem was already there, as the grub being set to hidden means that windows was already not recognized right ?

thanks again for the help !

Re: modifying ssd

And you removed windows boot either by formatting the $esp or recreated it and erasing the original windows $esp.

So you cannot make that statement (no modifying SSD) without explaining the subsequent action of modifying it.

Re: hidden menu

This has nothing to do with the issue.
Yes, I can understand that having this hidden grub menu had caused you to think that this is the reason that windows is not recognized. Unfortunate that it caused you to think that was the reason when it was not.

Ok, so the only problem at first was that the grub was hidden ?

Well anyway reinstalling the windows loader should not be a huge problem, thanks for the assistance !

It was not the problem. It caused you to think that was the problem.

Good. And good luck. Remember to reinstall back Manjaro's bootloader using the link in my earlier post. Let us know if you need help on this.

You're welcome.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by