Civilization 6 doesn't recognize my GPU

It says 'unknown device', also in 'windowed' mode (and 1920x1080 resolution) the game doesn't take the whole screen.
https://i.imgur.com/L6U6GXG.jpg

What I've tried:

  • Update my gpu driver from 435xx to 440xx
  • Set DRI_PRIME=1 in launch options (I found this here)

PD: Prior to this issue I have the problem that civ doesn't initialize so searching for a solution I found this reddit thread, basically in it says that I have to add this command in the launch options:

LD_PRELOAD=/usr/lib/libfreetype.so.6 %command%

So now my launch options looks like this

LD_PRELOAD=/usr/lib/libfreetype.so.6 %command% DRI_PRIME=1

Fxxxz output
System:    Host: ghost-pc Kernel: 5.4.24-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 Desktop: KDE Plasma 5.18.3 
           tk: Qt 5.14.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME B250M-A v: Rev X.0x serial: <filter> UEFI [Legacy]: American Megatrends 
           v: 0612 date: 03/23/2017 
CPU:       Topology: Dual Core model: Intel Core i3-7100 bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31211 
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI driver: nvidia v: 440.64 bus ID: 01:00.0 
           chip ID: 10de:1c82 
           Display: x11 server: X.Org 1.20.7 driver: nvidia compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.64 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a2f0 
           Device-2: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0fb9 
           Sound Server: ALSA v: k5.4.24-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 723.53 GiB (77.7%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 1A02 scheme: MBR 
Partition: ID-1: / size: 147.28 GiB used: 17.26 GiB (11.7%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 296.52 GiB used: 238.59 GiB (80.5%) fs: ext4 dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 38 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 46% 
Info:      Processes: 222 Uptime: 37m Memory: 23.43 GiB used: 5.85 GiB (25.0%) Init: systemd v: 244 Compilers: gcc: 9.2.1 
           Shell: bash v: 5.0.16 running in: yakuake inxi: 3.0.37

Can we see the output of inxi -Fxxxz please?

Oops I knew I was forgetting something, I just edit my initial post to include that.

I have the same problem. It also shows some tearing if I try to make the game fullscreen (using the fullscreen feature of i3wm).

On a similar note, I see only the integrated GPU as an option. The dedicated GPU(radeon) is not detected, even if I pass DRI_PRIME=1 option.

This is a known issue with myriad threads open here and there all over the Internet. I always suggest the same: please open a ticket on Aspyr's website! Chances are they won't reply (my last ticket has been open for over three months), but who knows if they'll pay attention if enough people mail them.

Yeah, I mean I can play the game just fine, but the problem comes when I want to record or stream it as the only way for OBS to capture the game is choosing the window mode, but it makes the game not taking the complete screen, I even tried to force the size and maximize options but it didn't worked. I already sent a ticket, no response until now.

I guess we just have to wait... or dream lol.

I personally have zero hope regarding this issue. It took Aspyr ages to get the first DLCs out for Linux, never giving a damn about performance.

Perhaps we should be reaching the guys at Firaxis...

Forum kindly sponsored by