Clipboard sharing not working in virtualbox and other problems

Hi folks:

So, I've been trying to get the latest Manjaro xfce edition installed in Virtualbox on my computer--seems like a good way to try out Manjaro and is useful as a VM. I've run into multiple problems, all but one of which I've solved--getting clipboard running between the Manjaro VM and the rest of my machine. Because this is crucial for my use of the VM, I can't proceed with Manjaro unless I can fix this.

I've followed all the instructions on [HowTo] VirtualBox - Installation, USB, Shared folders for Manjaro guest installation and configuration. vboxservice is running. With some effort, I got the shared folder working. But the clipboard is not functioning at all (yup, enabled in Devices menu).

When I run ps aux | grep -i vboxc* I can see VBoxClient entries for display, seamless, and draganddrop, but not for clipboard. On another VM when I run ' VBoxClient --clipboard ', my ability to use the clipboard returns (if it has disappeared). I can run the command here, there's no error msg, but ps aux detects no change in the list of VBoxClient entries and the clipboard remains non-functional. Any thoughts / suggestions? (See system specs below)

As for other problems I encountered and solved, which may be helpful for others, they include these: After initial installation and reboot in virtualbox, Manjaro takes 4 minutes to start, opens under user 'manjaro' rather than the user I gave, and no changes I make remain after reboot. The problem is that the reboot is off the .iso file, not the installed copy of Manjaro. You have to use Virtualbox > Storage >Settings to remove the .iso files. I've never seen something like this happen w/ another distribution so this was very confusing to me.

Another issue is that the Shared folder does not seem to work, even after precise following of instructions to set up the folder. The problem is that Manjaro gives no privileges to 'other' to the /media folder, so my user cannot access the shared folder mounted in it. chown o+rx /media fixed the problem.

System specifics:


$ inxi -Fxz
System: Host: joelm Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Xfce 4.14.1
Distro: Manjaro Linux
Machine: Type: Virtualbox System: innotek product: VirtualBox v: 1.2 serial:
Mobo: Oracle model: VirtualBox v: 1.2 serial: BIOS: innotek v: VirtualBox date: 12/01/2006
CPU: Topology: Single Core model: Intel Core i7-8700 bits: 64 type: MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 6386
Speed: 3192 MHz min/max: N/A Core speed (MHz): 1: 3192
Graphics: Device-1: InnoTek Systemberatung VirtualBox Graphics Adapter driver: vboxvideo v: kernel bus ID: 00:02.0
Display: x11 server: X.Org 1.20.6 driver: modesetting resolution: 1880x968~60Hz
OpenGL: renderer: llvmpipe (LLVM 9.0.0 256 bits) v: 3.3 Mesa 19.3.1 direct render: Yes
Audio: Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0 v: kernel bus ID: 00:05.0
Sound Server: ALSA v: k5.4.6-2-MANJARO
Network: Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: 7.3.21-k8-NAPI port: d010 bus ID: 00:03.0
IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge driver: piix4_smbus v: N/A port: d200 bus ID: 00:07.0
Drives: Local Storage: total: 30.00 GiB used: 4.64 GiB (15.5%)
ID-1: /dev/sda vendor: VirtualBox model: VBOX HARDDISK size: 30.00 GiB
Partition: ID-1: / size: 29.40 GiB used: 4.64 GiB (15.8%) fs: ext4 dev: /dev/sda1
Sensors: Message: No sensors data was found. Is sensors configured?
Info: Processes: 143 Uptime: 43m Memory: 6.14 GiB used: 1.86 GiB (30.4%) Init: systemd Compilers: gcc: N/A Shell: bash
v: 5.0.11 inxi: 3.0.37


Thanks Librewish! I'm not a developer. Do I understand correctly that if I download the pkg files and install them or remove video-vmware and install video-virtualbox, that this may solve the clipboard issue? Just fyi, I'm not having problems resizing my window.

Hi again: I tried installing the two pkg files from the site you mentioned, rebooted, and attempted to use the shared clipboard. Still not working unfortunately, though it seemed you had a plausible explanation.

It may be helpful for someone to know that the shared clipboard was working initially, I believe with the installer.

Hi! Can you go into the MHWD GUI and install video-virtualmachine? After that simply reboot.

I don't know how to install or access mhwd gui (I have a minimal installation; mhwd-gui doesn't appear in the pacman repos).

But when I run mhwd -li, I get feedback that my 'Installed PCI configs' consist of video-virtualbox 2018.11.25 . So I'm guessing that is already installed. The clipboard is not working.

Thanks for the suggestion.

I tried:

killall VBoxClient

Using ps aux, I can confirm that no VBoxClient process is running.

Next I tried to get the clipboard client running:

VBoxClient --clipboard

Now I see six VBoxClient processes running--all 6 that were there before I killed-all. The one thing I don't see is a clipboard process.

Facing the same issue here. The clipboard module is not starting at all. No logs visible in journalctl either.

I have the same problem, but I saw something when I upgrade. When I switch to root user I see this message "VBoxClient: error: No service specified. Quitting because nothing to do!"

@firozp @darklikuid can you give this ISO a shot?

I just tested it and it works as expected (the ISO includes my patches from the forum link above).

1 Like

Any idea if/when the fixes might be implemented back into 4.19 kernel?

@TotallyNotElite, I installed the new version you mentioned but the clipboard sharing still does not work !

Am i missing something ?


Can't reproduce:


Same issue here, 5.4 kernel VirtualBox 6.0.16. Clipboard support broke as of a pacman -Syu a couple days ago.

EDIT: Interesting, in VirtualBox 6.1.2 clipboard support works again, however the annoying VBoxClient: Error ... still shows up every time I open up a urxvt for some reason.

EDIT2: No idea why I'm getting this error in urxvt! Every other terminal emulator launches without error! Real confused as to why. However if I swap to whatever Alt+F2 is I get the error again.

I tried upgrading my VirtualBox to 6.1.2 and now my existing manjaro box freezes when i enter my password in the login screen. Downgrading :worried:

Seems like you have an older version of the virtualbox config, the newer virtualmachine config doesn't use profile.d. I don't know why the clipboard wouldn't work tho.

Where would this virtualbox config live and how do I go about upgrading it? Do you mean on the host or client?

The guest system needs to be updated. Installing the config video-virtualmachine in mhwd should be enough.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by