Come Faccio a mettere auto login su manjaro kfce

Salve sono un utente che ha installato manjaro kfce ma non riesco a mettere auto login quando accendo il pc ho visto tra le impostazione account ma niente CHIEDO AIUTO!

Utilizzi Xfce o KDE? Non esiste kfce. :slightly_smiling_face:

si ho sbagliato a scrivere uso xfce

Assuming you're using LighDM, check this link:

(XFCE doesn't handle logins; that is the Display Managers job, and LightDM is the default Display Manager for XFCE in Manjaro - and the configuration is probably the same as for Arch).

Hello I have already tried to follow this because I read it in another forum I tried again to follow the guide you sent me but when I open the terminal and run the commands found in the guide you sent me it says permission denied from the terminal and also in the file where I put my name and when I save the file, the message is denied, then I try to open the terminal, I go through the procedure, but I always allow it to be denied, NOT TO GIVE THE FAULT TO MANJARO BUT CABBAGE CANNOT PUT AN AUTOMATIC ACCESS BUTTON IN THE SETTINGS, however if can you help me because i'm going crazy and sorry for punctuation if it isn't there

Ah.. luckily that's easy to fix. Those commands are administrative commands that normal users are not allowed to do.

You need to run the commands as root by typing sudo in front of the commands. Also when editing the file, you need to run the editor as root - do sudo nano /etc/lightdm/lightdm.conf. The first time you run sudo you must give your password.

Hope that helps?

Welcome to the Manjaro forum by the way :slight_smile:

ok so if I understand I run the commands in the terminal in this way: sudo nano /etc/lightdm/lightdm.conf I enter the password and it should work try

Yes, that is correct.


  • sudo groupadd -r autologin
  • sudo gpasswd -a *username* autologin

If you see in front of those commands in the Arch Wiki, you'll see a "#".
That is the root prompt.
The normal user prompt is "$"

It means the commands should be run as root. Which means you should use sudo.

It's not exactly easy to understand, but usually when you get an error about access rights, missing privileges, or when commands the should be there is not found, it may be that you have to use sudo.

This is something you'll get the hang on, so don't worry.

It all comes down to protecting you from yourself - the commands that needs root access (sudo) can give you problems with your computer if done wrongly.

It's a little bit like Windows warning you not to mess with the registry :stuck_out_tongue:

But if you don't rush, and follow the description in the Arch Wiki you'll be just fine :slight_smile:

Hi look here is what I did: 1: I opened the .conf file as root 2: on auto-login user I put my name 3 on autologin-user-timeout there is already '0' but when I reboot it always tells me to put my password to and on autologin-session what should I put

And the groupadd and gpasswd commands?
I think you must be a member of the autologin group.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by