Compiz settings lost

Running mate with compiz on top. Started machine today, and compiz seems either to have lost its settings, or is not running properly. Mate-tweak shows compiz as the compositor (I have tried switching to Marco, then back to compiz). Manually running ccsm yields:

Belial ~$ ccsm
Traceback (most recent call last):
File "/usr/bin/ccsm", line 93, in
import compizconfig
ImportError: libprotobuf.so.17: cannot open shared object file: No such file or directory

Any idea how I can get my desktop cube back?


I suppose you use the compiz-manjaro package?

Unfortunately, this package is broken currently: Compiz needs to be rebuilt against the new version of protobuf. It was reported to be broken in Testing, but it was missed, most likely buried under other issues in Testing that we had.

There is not much you can do on your side outside of living without Compiz for a moment, Manjaro Team needs to fix this by rebuilding the package and push it in Stable (and Testing). Do not try to downgrade protobuf: doing so will most likely break other programs that uses protobuf themselves.

Sorry for the inconvenience. :confused:

I personally requested for a urgent rebuild (like others did too). The harm is already done though, unfortunately.

1 Like

No worries. I can live without it for a while. I mean, I have plenty of pills from my psychiatrist, so I'm all set :slight_smile: Thanks so much for the info! You guys are the best! I'll be over here waiting patiently for the fix... rocking back and forth... chanting in latin backwards...

downgrade protobuf to 3.6.1.3 to fix the problem. I tried sim-linking the new version to the filename it wanted and it misbehaved.

I do not use compiz-manjaro as compiz-reloaded (shadowkyoger AUR builds) is more up to date and has more options

If you got Compiz from AUR, it is considered your responsibility to do rebuild software against newer versions of libraries if needed.

Upgrade protobuf to the newest version available again, then remove the AUR package from your system, then rebuild the package, then reinstall the package you just built (the last two steps are often combined in one operation). (I don't think it is needed to reboot in order to make sure that it compiles Compiz against the right version of protobuf.)

it has been a busy day, I have not had a chance to rebuild Compiz-reloaded against the new libraries... mCOLe users will have the updated versions passed to the online repo sometime this evening I expect... I imagine the downgrade will be suitable for compiz-manjaro users until those packages are fixed against the new libraries... =D

Not really, because it can break sotware that are built against the new version of protobuf.

The only true fix is that @philm or any maintainers in the Team to fix their ■■■■ and rebuild compiz-manjaro for Stable and push it in Stable, then rebuild for Testing, then finally rebuild for Unstable. (Unless we are absolutely sure that one single build will work in each branches despite each being more or less different ecosystem currently.)

No, I'm using the manjaro community package for compiz. Thanks.

I can confirm that rebuilding solves the problem... I have uploaded the new set to the mCOLe64 repository for those who are using it so they can update their Compiz files... I am surprised that Manjaro has not picked up the 0.8.16 series of Compiz like the Debian project has...

Thank you everyone. I'm good with waiting for it to get done, assuming that will not be too long :slight_smile: So far, I've been quite pleased with Manjaro, even despite the update hiccup a while ago that made things break on booting. I (thankfully) have some old-school Unix experience, and a bit of Linux behind me, that I'm fairly comfortable making changes, building (compiling) things, etc. But in this case, compiz ain't a show-stopper, and mate is pleasant without it. Well, maybe not pleasant, but certainly functional. Even broken, it's still better than Windows :slight_smile:

https://lists.manjaro.org/pipermail/manjaro-packages/Week-of-Mon-20190325/021853.html

A rebuild for compiz-manjaro has been pushed in Stable. It should be available in your mirror soon.

Please tell us if it does the job.

2 Likes

Yup, that did it. I lost all my settings, but half the fun is setting them all up again! Happy Happy Joy Joy! Thanks to you. I owe ya a pint.

Glad that it now works, albeit a bit late.

Sorry for the inconvenience again.

No sweat. Fixed faster than it would have been on a mac or from M$ :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by