Compositor no longer working with openGL 3.1/2 with Intel HD 630

Hello everyone,
I have run into issues with my intel gpu and compositor. Earlier, compositor could use opengl 3.1 or 2.0 and all desktop effects like blur, slide while switching desktops worked well.

Now, all of a sudden while I was working, my screen went black for a second and now no desktop effects work unless I switch to Xrender.

If I use optimus-manager and switch to nvidia, it all works fine, but my Intel HD 630 refuses to work with opengl for desktop effects.

This makes my system feel really laggy, almost like I'm using XFCE with animations turned off.

So far, I have tried reinstalling video-linux drivers and downgrading the kernel to 4.19, but nothing as helped and since I can't find any similar threads I'm asking for help here.

Thanks in advance!

Systeminfo:-

System:    Host: predator Kernel: 4.19.133-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.19.3                                                     
           tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux                                                                                                        
Machine:   Type: Laptop System: Acer product: Predator PH315-52 v: V1.08 serial: <root required> Chassis: type: 10 
           serial: <root required> 
           Mobo: CFL model: Covini_CFS v: V1.08 serial: <root required> UEFI: Insyde v: 1.08 date: 09/02/2019 
Battery:   ID-1: BAT0 charge: 45.7 Wh condition: 51.0/51.0 Wh (100%) volts: 17.2/15.4 model: SMP KT00407009 AP18E7M 
           type: Li-ion serial: 03128 06/01/2019 status: Charging 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62208 
           Speed: 858 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 897 2: 898 3: 899 4: 899 5: 900 6: 899 7: 893 8: 900 
           9: 899 10: 899 11: 899 12: 900 





Graphics:  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:3e9b 
           Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Acer Incorporated ALI driver: N/A bus ID: 01:00.0 
           chip ID: 10de:2191 
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: intel compositor: kwin_x11 
           resolution: 1920x1080~144Hz 
           OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.1.3 compat-v: 3.1 direct render: Yes 






Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 5000 
           bus ID: 00:14.3 chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: a4:c3:f0:47:be:ef 
           Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Acer Incorporated ALI driver: alx v: kernel 
           port: 3000 bus ID: 07:00.0 chip ID: 1969:e0b1 
           IF: enp7s0 state: down mac: 7c:d3:0a:81:4f:8c 
Drives:    Local Storage: total: 2.05 TiB used: 937.92 GiB (44.6%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM256GDJTNG-8310A size: 238.47 GiB speed: 15.8 Gb/s lanes: 2 
           serial: ND94N310711404U2P rev: 80002C00 scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: S30YJ9EG112145 rev: 0001 scheme: MBR 
           ID-3: /dev/sdb type: USB vendor: Seagate model: BUP Slim BK size: 931.51 GiB serial: NA7GZLYV rev: 0302 scheme: MBR 
Partition: ID-1: / size: 213.06 GiB used: 174.11 GiB (81.7%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-2: /home size: 915.89 GiB used: 763.81 GiB (83.4%) fs: ext4 dev: /dev/sda1 
           ID-3: swap-1 size: 20.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 264 Uptime: 8m Memory: 15.51 GiB used: 2.76 GiB (17.8%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           alt: 8 clang: 10.0.0 Shell: zsh v: 5.8 running in: server inxi: 3.0.37

Forum kindly sponsored by