Compositor not starting after boot [KDE]

Compositor doesn't seem to be starting after boot. If I change a setting under Display and Monitor > Compositor, for example, from OpenGL 3.1 to 2.0 and then apply it everything seems to work again.

When not working, Latte Dock is visually "squared" with lines (see image below) and I get horizontal lines (breakage) when scrolling in Firefox, for example.

There have been some recent updates from the Stable branch or is it possible the Display Port to HDMI adapter that I recently added that goes to a TV could be the issue? I keep this Monitor's (TV) turned off in settings, however, unless I'm actually using it (and turn it on manually at that point.) Could it be either one of those, perhaps?

Is there a place to double check the "Enable Compositor on startup" is taking effect?

Thanks!

latte

Make sure you have no other driver installed in MHWD except the video-nvidia-440xx
If you have to remove some other drivers, do so, and reinstall video-nvidia-440xx or run this command to make sure the configuration for it is used
sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf

Reboot.

To be honest i would be curious about the content of
/etc/X11/mhwd.d/nvidia.conf

Thanks for the reply!

Going to look into your suggestions shortly. In the mean time here is my nvidia.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.64

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Here is what's installed:

drivers

The conf file is fine and you have the proper drivers installed. Can we make sure you also have inside /etc/modprobe.d/mhwd-gpu.conf this lines:

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

and inside /etc/modules-load.d/mhwd-gpu.conf this lines:

nvidia
nvidia-drm

##
## Generated by mhwd - Manjaro Hardware Detection
##
 
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

##
## Generated by mhwd - Manjaro Hardware Detection
##
 
nvidia

Should I add in nvidia-drm? Looks like it's missing.

Yes, make it as is mine. Do a reboot after that and then share

inxi -Gxxza
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: ASUSTeK driver: nvidia v: 440.100 bus ID: 01:00.0 
           chip ID: 10de:1401 
           Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 

Looks fine, but how about the Compositor? Once you enable it and then you reboot, is still switching back to off ?

I changed a setting (switch OpenGL and hit apply) so it fixed the issues and I rebooted again a couple times and it's still doing the same thing, yes. Not sure if there a place that's actually switching it to off, however, as everything still appears to be on in the settings (as you can see from the pic in my original post.) Is there something else I should check, perhaps?

It seems i have to go, so i will no longer able to interact today.
A couple of things to check, try this settings in Desktop Session settings

image

With the Compositor enabled, an like this

image

In my case, doing what i described here was always a beneficial thing in KDE Plasma

Might not apply or help in your case.
Cheers and hope to get is solved.

Okay, thank you! Appreciate your help. Have a good one... I'll give those a try and report back.

Set the first two images the way you had it in settings but, same issue.

I'll looked into your link.

Hi!
I had the same problem in neon, It was latte-dock, remove it from autostart fix the problem, since then I totally removed latte-dock

@visone thanks for the suggestion. That didn't seem to make any difference, however.

I did remove the Display Port to HDMI adapter that was going to the TV and now it's fine again. Weird, right?

I was running HDMI to my Monitor and Display Port adapter to HDMI to my TV and I tried 2 Display Port Adapters to HDMI for both Monitor and TV and it did the same thing (and was kind of wonky with sizing.)

Any ideas why that might be causing this issue? For now, I might just leave the Display Port for the TV unhooked and only hook it up when needed, as I don't use it often. Unless you guys have any ideas, that is.

Thanks again!

Check KWin Scripts, if Parachute is enabled, disable it.
Also check the journal and logs

This is the only thing in Kwin scripts:

kwin-scripts

Is journalctl -x the command to run for journal and logs?

Follow this thread KDE Compositor keeps breaking
It worked for me.However you can start compositor using Alt-Shift-F12 anytime,
Remove the check from allow applications to block compositing

Yes ,.

Okay, I wanted to clear out the journal logs so I could start over fresh, so I did the following:

❯ sudo journalctl --rotate        
❯ sudo journalctl --vacuum-time=1s

Initially I was seeing a ton of stuff from when I was playing with Darling and wanted to clear all that stuff out, either way and is partly why I did that.

I'm not sure why but, after seeing all that I had an idea to clean up my kernel, so I decided to install linux57, rebooted and then removed linux54, rebooted again, then came back and reinstalled 5.4 again, restarted, hit the shift key, went to advanced option and reset linux54 as the main kernel again. Now I'm running the 5.4 again (I hear it's a good idea to have an extra kernal install either way but, not totally sure)

❯ mhwd-kernel -li
Currently running: 5.4.52-1-MANJARO (linux54)
The following kernels are installed in your system:
   * linux54
   * linux57

And low and behold, I think my problem has been solved!

The only other thing I did do between all that was run Shift+Alt+F12, which turned off the compositor, as it was already on so, I ran the key combo again and it came back on; cool tip @tzihad thanks!

Anyway, I'll give this some time before I consider case closed but, right now I think removing the kernel and replacing it with a fresh one has addressed my issue, as I'm currently running my Monitor from HDMI and the TV from Display Port with Display Port to HDMI adapter. Latte looks good and scrolling is smooth and both screens are as expected.


For sake of thoroughness, here are some commands I saw listed in thread you suggested, @tzihad :

❯ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 960/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 440.100
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 440.100
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 440.100
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
❯ journalctl -p err -b
-- Logs begin at Fri 2020-07-24 19:37:23 PDT, end at Fri 2020-07-24 20:13:49 PDT. --
Jul 24 20:01:23 username kernel: sd 6:0:0:0: [sdd] No Caching mode page found
Jul 24 20:01:23 username kernel: sd 6:0:0:0: [sdd] Assuming drive cache: write through
Jul 24 20:01:25 username kernel: scsi 6:0:0:1: Wrong diagnostic page; asked for 1 got 8
Jul 24 20:01:25 username kernel: scsi 6:0:0:1: Failed to get diagnostic page 0x1
Jul 24 20:01:25 username kernel: scsi 6:0:0:1: Failed to bind enclosure -19
Jul 24 20:01:32 username colord-sane[1022]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Jul 24 20:01:39 username kernel: debugfs: File 'le_min_key_size' in directory 'hci0' already present!
Jul 24 20:01:39 username kernel: debugfs: File 'le_max_key_size' in directory 'hci0' already present!
Jul 24 20:01:39 username kernel: debugfs: File 'force_bredr_smp' in directory 'hci0' already present!
Jul 24 20:03:21 username bluetoothd[1453]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Jul 24 20:03:21 username bluetoothd[1453]: RFCOMM server failed for :1.126/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: >
lines 1-12/12 (END)
❯ cat .config/kwinrc
[$Version]
update_info=kwin.upd:replace-scalein-with-scale,kwin.upd:port-minimizeanimation-effect-to-js,kwin.upd:port-scale-effect-to-js,kwin.upd:port-dimscreen-effect-to-js,kwin.upd:auto-bordersize,kwin.upd:animation-speed

[Compositing]
GLCore=true
GLPreferBufferSwap=a
HiddenPreviews=5
OpenGLIsUnsafe=false
WindowsBlockCompositing=false
XRenderSmoothScale=false

[Desktops]
Id_1=cdb66db0-21f9-4f87-b57a-35fe9d6af6d3
Id_2=fd605709-49dc-4c39-9edf-a0dd1f8d2e42
Rows=2

[Effect-CoverSwitch]
TabBox=false
TabBoxAlternative=false

[Effect-Cube]
BorderActivate=9
BorderActivateCylinder=9
BorderActivateSphere=9
TouchBorderActivate=9
TouchBorderActivateCylinder=9
TouchBorderActivateSphere=9

[Effect-DesktopGrid]
BorderActivate=9
TouchBorderActivate=9

[Effect-FlipSwitch]
TabBox=false
TabBoxAlternative=false

[Effect-PresentWindows]
BorderActivate=9
BorderActivateAll=9
BorderActivateClass=9
TouchBorderActivate=7
TouchBorderActivateAll=9
TouchBorderActivateClass=9

[ElectricBorders]
Bottom=None
BottomLeft=None
BottomRight=None
Left=None
Right=None
Top=None
TopLeft=None
TopRight=None

[ModifierOnlyShortcuts]
Meta=org.kde.lattedock,/Latte,org.kde.LatteDock,activateLauncherMenu

[MouseBindings]
CommandActiveTitlebar1=Raise
CommandActiveTitlebar2=Nothing
CommandActiveTitlebar3=Operations menu
CommandAll1=Nothing
CommandAll2=Toggle raise and lower
CommandAll3=Resize
CommandAllKey=Alt
CommandAllWheel=Nothing
CommandInactiveTitlebar1=Activate and raise
CommandInactiveTitlebar2=Nothing
CommandInactiveTitlebar3=Operations menu
CommandTitlebarWheel=Nothing
CommandWindow1=Activate, raise and pass click
CommandWindow2=Activate and pass click
CommandWindow3=Activate and pass click
CommandWindowWheel=Scroll

[NightColor]
Active=true
LatitudeAuto=38.4319
LatitudeFixed=38.4319
LongitudeAuto=-120.5719
LongitudeFixed=-120.5719
Mode=Location
NightTemperature=2600

[Plugins]
highlightwindowEnabled=true
minimizeallEnabled=false
sticky-window-snappingEnabled=true
synchronizeskipswitcherEnabled=false
videowallEnabled=false
windowgeometryEnabled=false

[TabBox]
ActivitiesMode=1
ApplicationsMode=0
BorderActivate=9
BorderAlternativeActivate=9
DesktopLayout=org.kde.breeze.desktop
DesktopListLayout=org.kde.breeze.desktop
DesktopMode=1
HighlightWindows=true
LayoutName=org.kde.breeze.desktop
MinimizedMode=0
MultiScreenMode=0
ShowDesktopMode=0
ShowTabBox=true
SwitchingMode=0
TouchBorderActivate=9
TouchBorderAlternativeActivate=9

[TabBoxAlternative]
ActivitiesMode=1
ApplicationsMode=0
DesktopMode=1
HighlightWindows=true
LayoutName=org.kde.breeze.desktop
MinimizedMode=0
MultiScreenMode=0
ShowDesktopMode=0
ShowTabBox=true
SwitchingMode=0

[TouchEdges]
Bottom=None
Left=None
Right=None
Top=None

[Windows]
ActiveMouseScreen=false
AutoRaise=false
AutoRaiseInterval=750
BorderSnapZone=10
CenterSnapZone=0
ClickRaise=true
DelayFocusInterval=300
ElectricBorderCooldown=350
ElectricBorderCornerRatio=0.25
ElectricBorderDelay=150
ElectricBorderMaximize=true
ElectricBorderTiling=true
ElectricBorders=0
FocusPolicy=ClickToFocus
FocusStealingPreventionLevel=1
GeometryTip=false
HideUtilityWindowsForInactive=true
MaximizeButtonLeftClickCommand=Maximize
MaximizeButtonMiddleClickCommand=Maximize (vertical only)
MaximizeButtonRightClickCommand=Maximize (horizontal only)
NextFocusPrefersMouse=false
Placement=Centered
SeparateScreenFocus=false
ShadeHover=false
ShadeHoverInterval=250
SnapOnlyWhenOverlapping=false
TitlebarDoubleClickCommand=Maximize
WindowSnapZone=10

[org.kde.kdecoration2]
BorderSize=Normal
BorderSizeAuto=true
ButtonsOnLeft=M
ButtonsOnRight=IAX
CloseOnDoubleClickOnMenu=false
ShowToolTips=true
library=org.kde.breeze
theme=Breeze

Glad to hear you solved the issue,
If you run into the same problem again,
Add these two lines into .config/kwinrc
After [Compositing]

Backend=OpenGL
Enabled=true

Then the whole Compositing section will be like this

[Compositing]
Backend=OpenGL
Enabled=true
GLCore=true
GLPreferBufferSwap=a
HiddenPreviews=5
OpenGLIsUnsafe=false
WindowsBlockCompositing=false
XRenderSmoothScale=false

It is a good idea as Manjaro is a rolling distro

Forum kindly sponsored by