Compositor not starting after boot [KDE]

Hi!
That's the better idea for any distributions, I'm usually have 2 or 3 kernel per system. In manjaro is normal to use 5.7 but in deb base distros no so much. I have 2 machines with ryzen+/2 so for better performance I need to use 5.7 no matter what distro am I using

Yes, updated kernels provide smoother experience.My response was regarding the neccesity of multiple kernels in a rolling distro.

Well, I turned on the PC this morning and the compositor was off again. Turned on the compositor with the key combo, restarted and it was still on. Shut'er down and turned on again and compositor was off.

Seems like a restart holds the setting, but a full shutdown does not. Any thoughts on that by chance?

I spoke too soon, now it's doing it on restarts too. Super weird. Not sure what's going on.

Add this line to .xinitrc
qdbus org.kde.KWin /Compositor resume
It will not fix the real issue but compositor will start automatically

Or you can make a startup script (tutorial : https://docs.kde.org/trunk5/en/kde-workspace/kcontrol/autostart/index.html )
and put this on the script file
qdbus org.kde.KWin /Compositor resume

@tzihad thank you for sticking with me on this!

Update: Well, I guess putting your suggestion in an autostart script alone didn't take. I restarted 5 times and a couple shutdowns and it was off every time.

Update 2: I found these two suggestions:

https://bbs.archlinux.org/viewtopic.php?id=198424

What the Arch link suggested seems to have worked (updated bash code below), as it's making sure it's off before turning it on again

For others, this is what I did:

I created a resume-compositor.sh inside ~/.config/autostart-scripts and put the following into it:

#!/bin/bash
qdbus org.kde.KWin /Compositor suspend
qdbus org.kde.KWin /Compositor resume

I then made it executable: chmod +x ~/.config/autostart-scripts/resume-compositor.sh

Once that's complete it showed up under Settings > Autostart, as seen here:

autostart

Note: if you want to get fancy you can create a .desktop file in ~/.config/autostart but, you'll have to put in the proper Files display and Actions, per the link @tzihad shared. It will then show up under Desktop File. I assume this will work the same, assuming you set it up correctly but, untested.

1 Like

However, It is just a bypass for starting the compositor (my solution also)
I was having the same issue, I bypassed using the code I mentioned. But after some days I decided to (really) solve it,
What I have done was,
Clear the journals
Reboot
(Assume compositor is off)
Check the journals
Find the error (Parachute was misconfigured)
Deactivate Parachute

I sticked with the issue as I know the feeling of having a ! KDE plasma desktop without blur, I was so frustrated then

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by