Computer stuck at Dell logo after update, tried startx with no luck

After a stable update (10-10-2019) I restarted my laptop and played some games, suspended to ram and went to sleep.

Today I open my laptop and just the cursor shows, nothing else. I held the power button to do a force shutdown and rebooted, this time just the dell logo and cursor appears, I can move the cursor freely.

I follow the instructions in the FAQ thread and do a ctrl+alt+f2 and login and run "startx", just the pamac software center appears and the cursor.

I can't install or remove anything, please help me.


It is worth mentioning that I've tried everything on the black screen FAQ.


Start with

inxi -Fxxxza --no-host

I have already tried everything in the first thread.

heres the inxi from mhdw-chroot in a live USB :

  Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=br 
  tz=America/Sao_Paulo driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MJRO1810 quiet systemd.show_status=1 apparmor=1 
  Desktop: KDE Plasma 5.16.5 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Portable System: Dell product: Inspiron 5548 v: A08 serial: <filter> 
  Chassis: type: 8 v: A08 serial: <filter> 
  Mobo: Dell model: 0YDTG3 v: A00 serial: <filter> UEFI: Dell v: A08 
  date: 01/29/2018 
  ID-1: BAT1 charge: 25.3 Wh condition: 25.3/43.8 Wh (58%) volts: 12.6/11.4 
  model: SIMPLO DELL 1WWHW463 type: Li-ion serial: <filter> status: Full 
  Topology: Dual Core model: Intel Core i7-5500U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2D 
  L1 cache: 64 KiB L2 cache: 4096 KiB L3 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19167 
  Speed: 798 MHz min/max: 500/3000 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 
  4: 799 
  Vulnerabilities: Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 
  Display: x11 server: X.Org 1.20.5 driver: intel FAILED: modesetting 
  unloaded: fbdev,vesa alternate: ati compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: N/A v: N/A direct render: N/A 
  Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel v: kernel 
  bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Sound Server: ALSA v: k5.2.11-1-MANJARO 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 
  v: kernel port: 4000 bus ID: 02:00.0 chip ID: 10ec:8136 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 4000 bus ID: 03:00.0 
  chip ID: 8086:095a 
  IF: wlp3s0 state: up mac: <filter> 
  Local Storage: total: 946.42 GiB used: 198.72 GiB (21.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM014-1EJ164 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
  serial: <filter> rev: DEMD scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Fit size: 14.91 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.26 scheme: MBR 
  ID-1: / raw size: 922.42 GiB size: 906.94 GiB (98.32%) used: 198.72 GiB (21.9%) 
  fs: ext4 block size: 4096 B dev: /dev/sda2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) 
  cache pressure: 100 (default) dev: /dev/sda3 
  System Temperatures: cpu: 53.0 C mobo: N/A gpu: amdgpu temp: 44 C 
  Fan Speeds (RPM): cpu: 2800 
  Processes: 205 Uptime: 15m Memory: 7.71 GiB used: 1.09 GiB (14.1%) Init: systemd 
  v: 242 Compilers: gcc: 9.2.0 clang: 8.0.1 Shell: bash v: 5.0.11 
  running in: mhwd-chroot-she inxi: 3.0.36

That looks very odd. Try reinstalling your graphics driver.
From the chroot, run a sudo pacman -Syyu just to check you are updated.

Another thought, check the contents of /etc/X11/xorg.conf.d/20-intel.conf try renaming, and reboot, modesetting should take over, been a few years, BRB after I check how to do this.

Arch forum says "Just remove the xf86-video-intel package, no other onfiguration is needed."
I have been using "modesetting" for years - I can't remember :frowning:


Keep in mind that I am new to linux, so I don't know what you are talking about. :sweat_smile:

All from a chroot.

sudo mv /etc/X11/xorg.conf.d/20-intel.conf  /etc/X11/xorg.conf.d/20-intel.conf-old

reboot. That is what I remember. If the Arch forum is correct (and they are the mothership).

sudo pacman -R xf86-video-intel

Reboot. Do not knock yourself - you got into a chroot - not many people do that by themselves.

Apologies for any typos - I am knackered!!!


So I just run that from the chroot?

Yes. :slight_smile:

[manjaro /]# sudo mv /etc/X11/xorg.conf.d/20-intel.conf  /etc/X11/xorg.conf.d/20-intel.conf-old
mv: cannot stat '/etc/X11/xorg.conf.d/20-intel.conf': No such file or directory
[manjaro /]# sudo pacman -R xf86-video-intel
error: target not found: xf86-video-intel

Did not work :frowning:

Yes, when you are in a chroot, every command affects the target OS.

Do the sudo pacman -Syyu as well, many problems are caused by incomplete updates.

As I said I am really tired, I am back working full time after a failed knee replacement, I am back in an admin post because I can't work at my unit (UK hospital ward). Rubbish week, I am now the flu vaccine co-ordinator for my hospital trust, it is one giant mess that I have to sort out.

And I have started my second bottle wine :smiley:


@sgs it 21:15 and I am going to bed :zzz: :smiley:

1 Like

Me too, but here is 22:16 :smiley:

Bewundert ?? You can get tablets for that :rofl: Oh and I have to use Windows 10 :face_vomiting:


I did a force reinstall of video-linux and in the log this showed up:

resolving dependencies...
looking for conflicting packages...
:: xf86-video-ati and catalyst-server are in conflict (xorg-server). Remove catalyst-server? [y/N] error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

:: xf86-video-ati and catalyst-server are in conflict (xorg-server<1.20.0)
Error: pacman failed!
Error: script failed!

I remember that after the update I tried installing amd catalyst and forgot to remove it.

Why? you do not have an AMD card (as far as I could see from the inzi).

I have a Intel/AMD hybrid card, it doesn't show up unless I use DRI_PRIME=1

So you have an on-board intel and a seperate AMD... can't help with that.

But catalyst is totally dead IIRC, should be removed from the repos.

[manjaro /]# sudo pacman -R catalyst-server
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: sddm: removing catalyst-server breaks dependency 'xorg-server'

Well sh*t

Forum kindly sponsored by