Configure the american keyboard to use brazillian letters

Guys I`m runing manjaro on a notebook with an american keyboard layout but I need to be able to type letters like cedilla and brazillian acentuation marks. In windows my config is portuguese with a united states international keyboard. What is the equivalent in linux?

You might try using the US (Mac) keyboard who's layout looks like this:

To get é for example, you use e, release, then e. ǹ? ` and n, and so on. That character map could be better by highlighting the modifier keys, but it does show everything you get... Well, there is one extra key left of the Z, but I just ignore it, it's otherwise right. Me, I want to know how to program unicode into my numeric keypad's unlocked state.

You can choose between different input languages which mimic the language of your choice to the current keyboard layout.
Depending on the Desktop you are using, open the system settings and look for keyboard settings / input method. Then just add the language you like and you should see a tray icon to switch them.

Hi brother,

I have the same issue with a Inspiron 7000...

I remember that it was possible to use the US layout to get pt-br characters before...

It used to work like:
['] + [c] = [ҫ]
['] + [a] = [á]
[^] + [a] = [â]

and so on...

IMO, the option to this behaviour which I guess is ("Portuguese, Brazil Nativo for US keyboards") on the keyboards available for "Portuguese (Brazil)" is BUGGED, since the keyboard showed has nothing to do with the default US keyboard.

The US keyboard we have:


The Layout that "Portuguese, Brazil Nativo for US keyboards" shows...:


Yeah, I've never seem such keyboard neither on Brazil or US.

Hey man I got it fixed here I'm using the following config:

1 Like

Yeah, I confirm that this is the correct behaviour we expected.

Strange thing the configuration is so counter intuitive.

PS.: Don't forget to set the thread as [SOLVED]. Good job Man!

1 Like

The English (US, alt. intl.) is the one that best fit. However, ['] + [c] yelds ć, not ç as expected. Any solution? Thanks

Lemme check my configs but I think you need to enable cedilla. What do you have for WM over there?

In /etc/enviroment enable
Reboot and tell us what does happen

1 Like

I have the same issue, I have a US keyboard on my notebook, but an external Brazilian ABNT2 keyboard (Micro$oft Wireless keyboard 3000 v2.0)

I know M$ and Linux bite each other, but I can't find a working keyboard

ç works but I need the ~^ on top of some letters and the small a_ and o_

Please advice!

@EckyBrazzz what config did you select for your keyboards? You need to select a keymap for ONE of those keyboards.

Guys, I've find a config suitable for me to solve this problem.
Hope it might help others.

Keyboard Model Generic 105-Key PC
Variant Portuguese (Brazil, IBM/Lenovo ThinkPad)


I hope you do not mind me to a bit hijack this thread. I have US keyboard on my DELL notebook and I like in some situations to switch it to SK layout to be able to write special characters in similar manner like your Portuguese letters.

I also see in different suggestion to use different software to define keyboard. I must say I am very confused how one should do this properly in Manjaro. Should we use manjaro setting for the keyboard as showed in reply from @amonobeax ) or XFCE (I guess it is) in reply from @moraesjeremias

I am using GNOME variant of manjaro, should I use GNOME setting for keyboard layout?

I also noticed that mapping remaps also keys which are not in the mapping redefined. Did any of you experience when you switch from US layout to other language layout that CTRL+arrow_key is not working anymore?

Yes, it worked pretty well.
So, chose English (US, alt. intl.) then edit /etc/environment add GTK_IM_MODULE=cedilla and voilà, it is done!

TBH you should try both and use the one that works.

Probably XFCE's solution would be nicer cause it will probably offer more integration (like keyboard hotkeys for layout switch)

EDIT: But it's all speculation, sry I currently don't have any machine running XFCE so I can't help you any further for now

Forum kindly sponsored by