configuring AMD Ryzen 4500u laptop

I have just bought a new laptop and of course wanted to install manjaro again :slightly_smiling_face: . It's the lenovo ideapad 5 14 inch version with the amd ryzen 4500u and a fingerprint reader. However, I encountered some really annoying problems:

  1. In one session, random seems to decide whether the touchpad works or not. If it works, it keeps working, if it doesn't it keeps not working until reboot. When it's not working I get a strange error every few seconds in the system log:
i2c_designware AMDI0010:00: controller timed out
  1. The fingerprint sensor is not working at all. I get the following hardware info:
Manufacturer: ELAN

((Defined at Interface level))


USB Version

Vendor ID
(Elan Microelectronics Corp.)
Product ID


12 Mbit/s


Max. Packet Size

I already tried the libfprint-elantech package but was unsuccessful.
3. I can't adjust the screen brightness. However in windows it worked after updating the graphics drivers to the original amd drivers. When checking the graphics drivers manjaro uses I found:

[olep@ideapad ~]$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Is it true that the latest graphics driver is from 2018?

Additionally I get a strange error on startup and shutdown:

[FAILED] Failed to start Load/Save □ness of backlight:acpi_video0.
  1. This is a bit off-topic, but on my old PC I had eclipse version 2020/03, but now it is only 2019/12, even after updating the system. How is that possible?

Thanks in advance!

This is absolutely brand-spanking-new hardware - does the kernel offer any compatibility for this yet?

Sounds like a driver issue.

Sounds like a driver issue.

Sounds like a driver issue. Or you need to specify the backlight kernel option.

Eclipse was dropped to the AUR.

The rest works perfectly

What can I try to fix them?

The drivers are generally part of the kernel, so you could try a different/newer kernel.

Newer hardware is better supported by newer kernels.

So you would recommend to just wait?

I don't think that's what I said?


I am using the most recent kernel (5.7). I also tried 5.6. However, I can't boot using older kernels, probably due to other issues linked with the new hardware.

You didn't mention that anywhere, so yes, the answer is to wait.

You might try searching the web and the Arch wiki for similar hardware and see if there are specific quirks that will help.

However, IdeaPads aren't known for their Linux-friendliness so things may never work correctly.

I found this thread which seems quite similar to my issue:
However, I don't really know how to apply the hints they provided...

There's nothing in there you can apply other than checking for a BIOS update.

How about the kernel bisec?
And is there any way to use the random behavior? Is there a way to restart the touchpad? Maybe by fetching its i2c address, disabeling and reenabling that device?

Regarding being not able to control the brightness issues:

You can find further details here:

This patched kernel seems to fix it, I am just building it.

FYI: The missing lines of code seem to be already there, but commented out in the source. But looks like people are working on this and it's like @jonathon said only a matter of time until this reaches the manjaro-branch.

Another thing I'd like to ask, because your Lenovo is very similar to my new Acer Swift 3, which also has the AMD Renoir SoC and a 4500U processor:

Does your internal microphone work?

You should also have the following sound chip?!

03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller

My system:

inxi -Fxxxc0                                                   
  Host: milena-acer Kernel: 5.7.0-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Gnome 3.36.2 wm: gnome-shell dm: GDM 3.34.1 
  Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Swift SF314-42 v: V1.02 
  serial: <root required> 
  Mobo: RO model: Kona_RN v: V1.02 serial: <root required> UEFI: Insyde 
  v: 1.02 date: 03/06/2020 
  ID-1: BAT1 charge: 45.9 Wh condition: 53.0/47.8 Wh (111%) volts: 12.3/11.2 
  model: LG 0x41,0x50,0x31,0x38,0x43,0x38,0x0003 type: Li-ion serial: 0003 
  status: Discharging 
  Topology: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 
  type: MCP arch: Zen rev: 1 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 28462 
  Speed: 1395 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 
  1: 1483 2: 1701 3: 1383 4: 1784 5: 1390 6: 1917 
  Device-1: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu 
  v: kernel bus ID: 03:00.0 chip ID: 1002:1636 
  Display: wayland server: 1.20.8 driver: ati,radeon 
  unloaded: modesetting alternate: fbdev,vesa compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD RENOIR (DRM 3.37.0 5.7.0-3-MANJARO LLVM 10.0.0) 
  v: 4.6 Mesa 20.0.7 direct render: Yes 
  Device-1: AMD vendor: Acer Incorporated ALI driver: snd_hda_intel 
  v: kernel bus ID: 03:00.1 chip ID: 1002:1637 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Acer Incorporated ALI driver: N/A bus ID: 03:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.7.0-3-MANJARO 
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 01:00.0 
  chip ID: 8086:2723 
  IF: wlp1s0 state: up mac: b8:9a:2a:55:77:9c 
  Local Storage: total: 476.94 GiB used: 11.23 GiB (2.4%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-00000 
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: S4Y4NF0N170095 
  rev: FXV7000Q scheme: GPT 
  ID-1: / size: 459.50 GiB used: 11.23 GiB (2.4%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: amdgpu temp: 41 C 
  Fan Speeds (RPM): N/A 
  Processes: 248 Uptime: 37m Memory: 7.22 GiB used: 2.95 GiB (40.9%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 clang: 10.0.0 Shell: zsh 
  v: 5.8 running in: gnome-terminal inxi: 3.0.37 

Hi, the backlight fixed it for me as well, I found the patch yesterday. My microphone isn't working as well and it is the same device as yours.
Interestingly I believe I have a different touchpad than other users of this type of device.
They have an elan touchpad while mine is called sth like "MSFT0004:00".

1 Like

I can confirm that my previosly linked patch works for my model as well! (Acer Swift 3 Model: SF314-42 )

Anyone got an idea what to try regarding the microphone?

Some other topics and arch and manjaro forums mentioned seperating the two mic sources and then muting one (and rebooting). But no help here.

And one more thing: Anyone got suspend working with the new mobile AMD 4000 series?

I only found this as a hint in the kernel log:


Maybe it's related to:

Will these issues mostly be ironed out in Linux 5.8? I am getting mine in the post tomorrow and will install Manjaro as soon as it arrives. the touchpad and brightness problems concern me the most as I will be using it on the go for school.

Using the kernel from the mentioned aur package above is pretty straight forward and thus brigthness can be solved until manjaros kernel has included the patches. I don't know, maybe we can already see them in the 5.7 release. But I don't know where to look this kind of stuff up.

I haven't mentioned before: most of the time manjaro won't boot into a graphical UI at all (tried both XFCE and Gnome flavours) so you have to add "2" as a kernel boot parameter to boot only a command line and start your display manager manually with sudo systemctl start gdm/lightdm. With the patched kernel I didn't have any of these cold-boot issues so far.

You're getting one of the new Lenovo Ideapad 5 with Ryzens? As for the new Acer Swift 3, i can tell the touchpad fully works.

Bigger concern for daily usability is the suspend issue.

I am receiving the Ideapad 5 today, and will try the patched kernel when I do. It would certainly be nice to have these patches mainlined and I am hopeful that they will as there are a number of other posts I have seen (mainly on Reddit) asking this same question. Jonathon mentioned before Ideapads have never had great Linux compatibility.

Is that just because the developers haven't put as much effort in as the Thinkpads? Or is it on Lenovo's behalf.

Lenovo's behalf. No Linux support for IdeaPads

I suppose that the 15 inch version currently has a fix for the touchpad:
While the 14 inch version has this random behavior, but it's like this out of the box. However, I am not sure if the type of touchpad used corresponds to the screen size, but it seems like it does.

I just installed Manjaro on my Ideapad and the only issue I found was the touchpad one, everything else (including the brightness) works, although I haven't tested suspend yet.

Forum kindly sponsored by