configuring AMD Ryzen 4500u laptop

Upon digging further it appears the touchpad is not recognised at all, and no amount of rebooting fixes this, however I have noticed that it works in the live session, why would this happen I wonder?

Is there a touchscreen recognized? If yes you can fix it with the link I sent before:
https://bbs.archlinux.org/viewtopic.php?id=256002
Do you have 14 or 15 inches?

I have the 14 inch model with no touchscreen, only a touchpad/trackpad. also compiling a kernel is a bit beyond what I am willing to do, I'm just wondering if it will be fixed in a future kernel update.

After a lot of searching I found this


which looks promising. Would it be possible for the Manjaro kernel maintainers to do whatever these people did when next building the kernel? That would be greatly appreciated.

Edit: I am building the new kernel now and will let you know how it goes after I am done.

Edit 2: turns out I am awful at kernel compiling, and all I got was a kernel panic when I tried to boot.
Someone who has a bit more experience with this kind of thing should probably do it instead.

The touchpad issue has been (albeit temporarily) solved in Touchpad not working Ideapad 5 AMD so the other things that are broken are the mic, fingerprint sensor, and suspend. Is that it, or is there other issues that I am not aware of?

1 Like

For me it looks like, as there might be a difference between the IdeaPad 5 (ARE05) and the IdeaPad Flex 5 (ARE05) - and maybe also between a Ryzen 4500 and a 4700.

I bought a "flex" model (convertible) with a Ryzen 4700 and nearly everything worked perfectly out of the box, including graphics adapter with multiple displays, touchpad and even special keys on the keyboard (as far as I am using them). That the screen is not rotating yet, due to issues with the monitor-sensor, is neither important nor really annoying. I am pretty sure, that the solution will come soon.

So I am sad to read, that others have bigger and more annoying issues (touchpad ..) and I wonder, what the difference is, since I am really very happy with this machine.

I published some HW specs of my laptop in the Arch Wiki and on linux-hardware.org. I can provide more and/or more detailed information on demand.

Kind regards,
Peer

1 Like

I have a lenovo flex 5 4500u and the webcam isn't working I would like to know if it's also the case in yours. I'm on 5.7.0-3. That is the only thing that is not working (after the brightness patch), besides the screen rotation in the different modes, but I don't care about that. The battery life is also great (about 7 hours with the screen at 30% brightness more or less).

My ideapad 5's webcam works perfectly (albeit in grainy 720p) with both 5.7 and 5.8rc so I can't help you, sorry.

Anyone figure out the microphone issue? I'm on an Ideapad 5 4500u, and am just getting the one 'sound card' popping up for audio inputs.

However this only records the system audio, so in fact no hardware microphone is detected regardless of whether I'm relying on the laptop's built in mic or an externally connected mic.

How did you get 5.8rc running?

The mic is detected using linux 5.8, however there are some freezing issues where the whole laptop stops responding. Hopefully it will be fixed in later revisions. In the meanwhile you can install the 5.8 rc 1 if you need microphone access.

1 Like

With the manjaro kernel manager, alternatively sudo pacman -S linux58 linux58-headers

Hmm both pacman and the kernel manager are only showing up to 5.7 for me. Perhaps it's just a waiting game for now.

Had everything working except the microphone and the brightness (which seems to be easily patched) when I last booted Manjaro a week ago, but after another boot just then seems that Bluetooth and trackpad are having trouble :frowning:

Time to do some scouring again

I am using the unstable branch of manjaro, so that's probably why I can see it. I have made a seperate thread about the touchpad that I linked to in a previous post which may be of help (just be advised that there were a lot of solutions that worked for a little while then stopped so make sure you read the whole thing)

1 Like

With the latest unstable kernel update there has been system freezes occurring at random. Do not update your kernel for now.

I'm running Unstable on 5.8 and I was getting system freezes after a few minutes of gaming. I disabled all my Gnome extensions and I haven't seen a freeze since. I am now in the process of enabling extensions one at a time to find the problematic one(s).

I'm on a laptop with a 4700U. The brightness adjustment worked the first boot after updating, but now only adjusts ~70%-100% again.

I also have 5.8 and experience the freezing but I put that down to it being a release candidate. I'm using KDE on mine so there are no extensions to disable. as far as I can tell it is caused by high CPU usage, as it never seems to happen when idle. In the meantime I have downloaded and manually installed the linux57 package from the stable repo and then told pacman to not update it which has fixed it for me.

1 Like

I reinstalled, updated to Testing, and installed 5.8. Brightness control worked all afternoon. This evening it no longer works. I'm no longer sure what is happening.

strange, I have never had any issues with the brightness no matter my kernel.

I went back to 5.7 and the backlight control is working as it should. Something in 5.8rc2 breaks it.

Forum kindly sponsored by