Conflicto Catfish y zeitgeist + no se pudieron ejecutar los «hooks»

Hola, soy nuevo en este sistema operativo.
He instalado el Manjaro Illyria 18.0.2-2018520 en una maquina, y cuando quiero actualizar el manjaro con pacman -Syyu me da error de conflicto entre Catfish y Zeitgeist. Si elimino calquiera de los dos tengo que volver a instalar el sistema operativo porque se queda pillado, y si reinicio se queda en bucle saltando en pantallas negras.

screenshot_20200525-145932_1920x1080

Por otro lado quiero instalar el node.js sudo pacman -S nodejs npm y me da el siguiente error: «hook» /usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook línea 2: el valor Path no es correcto

Hola.
En primer lugar te recomiento que trates de instalar Manjaro siempre desde la última iso (creo que van por la versión 20.0). Así te ahorrarás problemas a la hora de actualizar (ten en cuenta que es una rolling release y no conviene dejar las actualizaciones pendientes mucho tiempo).
En segundo lugar, prueba a desinstalar catfish con sudo pacman -R catfish y después trata de actualizar con sudo pacman -Syu.
Saludos

yo me eh encontrado con algo parecido pero en arquitecturas de 32 bits, quiza te sirva, una solucion es abrir el gestor de paquetes con:

pamac-manager

luego, vas a la pestaña "actualizaciones" e intentas actualizar dandole a "aplicar"

lo se, es lo mismo que intentas hacer desde tu terminal, tranquilo.
una vez que intentes actualizar te saldra un cuadro con el codigo de error y el nombre de los paquetes que te dan el conflicto (en tu caso Catfish y Zeitgeist) . tomas nota de dichos nombres.
ahora vamos a "Preferencias" ingresas tu contraseña.
nos dirigimos a la pestaña "avanzado"
ahora vamos a "ignorar las actualizaciones para" buscas el nombre de los paquetes que te dan problemas e intentas actualizar de nuevo, quiza debas cerrar el gestor de paquetes y volverlo a abrir para que los cambios surtan efecto.

si tu sistema logra actualizarse procede a quitar de la lista de ignorados a los paquetes que te daban problemas, deberían poder instalarse sin problemas.

por lo de instalar "node.js" primero deberias intentar actualizar manjaro, las actualizaciones con frecuencia suelen traer soluciones a problemas de hook en los paquetes.

saludos.

Hola,
Gracias por la respuesta. El primer paso de conflicto entre catfish y zeitgeist esta solucionado, pero ahora aparecio otro. Tengo 2 errores, ahora hay conflicto entre pamac-common y pamac-common-dev. Pero si elijo extra/pacma-gtk antes que extra/pacma-gtk-dev me salto este error y aparece otro que es el siguiente:
screenshot_20200526-093308_1920x1080

Hola.
A ver si te sirven estos enlaces:




No es exáctamente lo que a ti te pasa. Básicamente, están diciendo que el problema viene de no haber actualizado con regularidad el sistema y debido a los cambios en la estructura de pacman.
Sinceramente, mi opinión es que no te compliques la vida. Yo de tí descargaba la iso más reciente de Manjaro y lo instalaba de nuevo. Entiendo, por lo que dices, que lo has instalado hace poco con la versión 18 y por lo tanto es posible que no tengas ni documentos ni descargas que quieras conservar, por lo que sería simplemente "perder" los 15 o 20 minutos que lleva instalar de nuevo el sistema aprovechando el particionado original.

Saludos.

Solucionado,
Era un error con el paquete pacma, lo he solucionado con el siguiente comando sudo pacman -R $(pacman -Qq | grep pamac) && sudo pacman -Sy pamac-gtk
Muchas gracias a todos.

Estupendo

Excelente noticia, sugiero que añadas un [Solucionado] al titulo, así podrás ayudar a otro usuario en su búsqueda, hasta la próxima :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by