Confused installing wifi

I see that I can not trust you. I am a simple user who tries to change to Linux and convince other people that it is possible. Unfortunately, you do not understand why you are locked into professionalism. Of course it is easier to go to a business and buy a computer with Windows or Mac, where everything is already installed and works.
Instead, you speak from the heights of heaven and not with your feet on the earth of the reality of simple people like me.
So it will be then that LInux will continue to be left for a few "specialists" and nothing more.
Anyway, thanks for your voluntary help, which is very appreciated, only it is ineffective.
Josef Carel

Then please stop with the intellectual autopsy and deus vult fallacy towards any user from this forum.
If you lack trust towards me, there is nothing else to talk and your "thanks" at the end was void!
Good day!

1 Like

Could you please explain to him networking setup? (Based on wiki post that I linked) I am quite terrible at explaining

Me too :smiley:

Hello, I have tried to receive answers in the forum, but everything is very confusing and I do not get any real solution.
Install Manjaro Deepin in an External SSD and everything seems to work very well, less the wifi. Searching for solutions on the internet I found a proposal to install the driver with the command "youart Broadcom", and then I chose the most appropriate version in Kernel 4.19.28, but it did not work and then I tried another driver from the same list, that did not work either. Now I have two drivers but none works.
My laptop is a MacBook Pro 5.1 of the year 2010
I hope for an answer soon, because for me it is very important to be able to demonstrate that you can work with a Linux distro
Thank you
Josef Carel

MacBook 5.1 is from 2009. Do you mean. MacBook 7.1?

Sorry, must be 7.1 from 2010

If so see https://wiki.archlinux.org/index.php/MacBookPro7,1#Network for guidance

1 Like

I'm sorry but the instructions on the ArchLunux site are complicated for me. If there is a possibility to explain how to do step by step, then maybe I can fix my problem. I wait for your help.
Thank you
Josef


    1 Preparation
        1.1 Install Boot Manager
        1.2 Shrinking Macintosh HD
        1.3 EFI vs CSM mode
    2 Installation
        2.1 Dual Boot
            2.1.1 EFI-Mode
            2.1.2 CSM-Mode
        2.2 Bootloader
            2.2.1 EFI-Mode
            2.2.2 CSM-Mode or BIOS-compatibility
                2.2.2.1 Can't find root device
    3 Network
    4 Video
        4.1 Nouveau
        4.2 Nvidia

Moore steps???
That would degenerate into unpaid work. :smiley: :wink: :slight_smile:

I hate work :slight_smile:

1 Like

The link @bogdancovaciu already posted for you has the most in detail step by step instructions on how to install the broadcom drivers that you will find anywhere on the internet.

There is no need to install any driver from the Arch Linux AUR repository. As explained in my tutorial all the required drivers are in the Manjaro repositories.

I think one of the biggest complications you are encountering may be from your choice of desktop. Deepin has been experiencing many network related bugs lately and I would highly suggest trying another desktop version.

I would download a Manjaro Gnome or KDE ISO and try out the live boot environment. If you do not find your internet working on those editions then I would suggest trying the Manjarowish Lxqt spin. It does not use network manager and may possibly work if other editions do not.

If you have no success I would not blame Manjaro. Your choice of hardware to run Linux on is the root of your problem. If you want to avoid Wi-Fi issues in Linux do not use Apple and Broadcom products. They are both notoriously Linux unfriendly.

Best of luck, and avoid Apple products if you wish to avoid these issues in the future.

(edit) as a side note I would also test older and newer kernels with any install. The broadcom proprietary driver has been experiencing many issues on kernels 4.19 and 4.20. I would test out kernel 5 and 4.14 or possibly even older kernels to see if you can get the broadcom-wl driver working.

5 Likes

Seems something went very wrong with this thread ...
OP said right away that he is running linux419 and needs a broadcom driver.
So @josefcarel most likely you will need to install the package linux419-broadcom-wl from our repos. No need for AUR or anything more complicated most likely.

sudo pacman -S linux419-broadcom-wl

The only challenge might be how to install the driver without an internet connection present ... :wink:
Do you have access to a LAN connection with the computer in question?

4 Likes

Well, thank you for your kindly help. Yes I have an ethernet connection and I have installed linux419-broadcom-wl. Reboot but there is not a Wireless Network at all, only a Wired Connection. I missed something?

Maybe I need to restart Wireless Network? How to do that?

sudo ifconfig <YOUR NETWORK INTERFACE> down
and then
sudo ifconfig <YOUR NETWORK INTERFACE> up

to see all available network interface :
ifconfig -a
or
ip link show

e.g

sudo ifconfig wlp2s0 down
sudo ifconfig wlp2s0 up

Im very sorry but I get a very large message but I don't know how to copy from the terminal. Sorry for my ignorance

Im in Manjaro

block the text you want to copy right-click and then click copy

I also get : ifconfig: command nor found

then use :
sudo ip link set <YOUR NETWORK INTERFACE> up
then
sudo ip link set <YOUR NETWORK INTERFACE> down

Forum kindly sponsored by