Constant arbitrary stutters in Manjaro, how to identify the source?

Hello,
I try to post this problem in the best way I can describe it. Please excuse me, I am a Newbie, so probably some information will be missing.

I installed Manjaro 5.4.6-2 KDE a couple of days ago and had no problems so far. Today I started the laptop and since then have constant stutters. The screen freezes for a few seconds and does not respond to anything. I can move the mous, click and type, but nothing happens. after a few seconds the typed text appears on the screen and I can go on working. I had these freezes or stutters on this laptop with differrent Linux distros (Kubuntu Manjaro XFCE) before, but far less often. This is highly annoying and practically makes the system unusable. The stutters appear to be completely regardless of the system use. I can have dozens of programs open and using a lot of resources ore simply run on browserwindow. I have googled for about two hours, and found that a lot of people seem to have freezes for very different reasons. Now I am trying to narrow down, what the reason on this machine could be.

Laptop Specs:
Lenovo X250
CPU: intel i5-5300 @2.30 GHz
GPU: INtel HD-Grpahics
RAM: 8 GB
Disc: SSD 500GB Kingston

What I have done so far:

  1. I did a MemTest (twice) which returned no errors
  2. I did a SSD Test with Smart from the Windows Partition which returned that the SSD status is fine.

What to do next?

Try another kernel, e.g. 4.19 LTS. Can be installed via Manjaro setting manager, for example. Then, when booting next time, select "Advanced options" from grub menu to boot into it.

You could try using an earlier kernel generation. 4.19 is a long-term-support kernel, so you could try installing that, and then after selecting it in GRUB at the reboot, see if the problem persists.

Open up a terminal window and enter the following command...: :arrow_down:

sudo mhwd-kernel -i linux419

This will install the kernel and add it to the GRUB menu, but you will have to manually select it in GRUB by choosing "Advanced options for Manjaro Linux".

GRUB will remember the last kernel you booted up with, so you only need to select this once, but right now it's "remembering" the 5.4 kernel you're currently running. :wink:

Thanks for the quick reply. I have just done that, will try it out during the next days and get back to you.

2 Likes

Ok. I tried it with the LTS kernel in different scenarios. The main stutters every few seconds are gone and I can work again. Many thanks!
However, there still are some stutters (about once per hour) which I also had with other distros on this laptop. It appears to happen only when using VLC or the browser to play music. Is there a way to test and document this in any usefull way?

I'm not an expert on these things but I suspect that the cause would lay with the hardware. Not that it would be broken, but perhaps not adequate enough performance-wise.

That said, an i5 processor with 8 GiB of RAM and an SSD should perform well enough, so in the end, there may be something wrong with the hardware. Maybe it would be wise to investigate whether a newer version of the UEFI firmware is available from the manufacturer? :thinking:

1 Like

As far as I know - which is not far - one cannot update UEFI in Linux? So I will try this from my Windows Partition and report back.

In many cases it's possible from Linux but much easier from Windows.

https://wiki.archlinux.org/index.php/Flashing_BIOS_from_Linux
https://wiki.archlinux.org/index.php/Fwupd

https://www.hirensbootcd.org/

I was having similar issues with a Kingston SSD until I updated the firmware, so maybe start there.

Edit: Especially if it's an a400.

1 Like

@Aragorn: Thanks very much for the hint. I did update the firmware and have tested the system since. Result: No more stutters or freezes and all together better performance at different loads.

@10yearslate: I indeed have an a400 unit build in. So I guess that was the problem.

I did the update from Windows like I said. It took about 1 Minute to download the tool from Kingston (https://www.kingston.com/de/support/technical/ssdmanager) and about 10 second to update. No special skills required, luckily.

1 Like

Fortunate you have Windows, Kingston's Linux support is non-existent. Firmware issues on the a400 are really common, as you've just said it's a one minute fix with their tool but if you can't access that you're stuck because they refuse to release the firmware and let people flash it themselves.

SMART reporting also makes no sense with these drives, some raw and normalised figures are reversed while others are missing or outright wrong, presumably on account of their junky firmware.

As you can probably tell I'm not in love with this company at the moment! :sweat_smile:

Glad your problem's fixed!

Fortunate you have Windows, Kingston's Linux support is non-existent. <

Just out of interest could you do an update of the firmware from a VM or a Livestick?

not VM but a WinPE stick might work

Nah tried that. My firmware is already up to date but I tried installing the tool under Hirzen's boot cd out of curiosity, this afternoon infact. No dice.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by