Constant freezing after latest update

issue

Recently after upgrading to the newest version of Manjaro (20.0.3), every single time I use my laptop, when I adjust the brightness or use google chrome, KDE just freezes, then my mouse stops working. The keyboard still works and I can open a terminal with ctrl+alt+t but strangely the terminal prompt doesn't show up. This has worsened to the point where it is unusable. I may have to switch back to Windows due to my urgent need of the laptop. Please advise on what I should do now. Thanks!

system info

System:    Host: surface Kernel: 5.7.9-arch1-1-surface x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux-surface root=UUID=5702874d-3a61-47d1-9b54-4b02fdb09435 rw quiet 
           resume=UUID=7a2f5ee6-3150-456f-8a81-6e8fd16312de udev.log_priority=3 
           Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Microsoft product: Surface Laptop 2 
           v: 124000000000000000000000D:F B:0CA56289 F:U C:0A P:C1 S:01 serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Microsoft model: Surface Laptop 2 serial: <filter> UEFI: Microsoft v: 138.3193.768 date: 03.25.2020 
Battery:   ID-1: BAT1 charge: 38.6 Wh condition: 41.1/45.2 Wh (91%) volts: 8.4/7.6 model: DYN M1005922 type: Li-ion 
           serial: <filter> status: Discharging cycles: 285 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: A (10) microcode: D6 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 799 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Microsoft driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           tty: N/A 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging Unit driver: ipu3-imgu bus ID: 00:05.0 
           chip ID: 8086:1919 
           Device-2: Intel driver: ipu3-cio2 bus ID: 00:14.3 chip ID: 8086:9d32 
           Device-3: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.7.9-arch1-1-surface 
Network:   Device-1: Marvell 88W8897 [AVASTAR] 802.11ac Wireless driver: mwifiex_pcie v: 1.0 port: 3000 bus ID: 02:00.0 
           chip ID: 11ab:2b38 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Marvell Bluetooth and Wireless LAN Composite Device type: USB driver: btusb bus ID: 1-5:2 
           chip ID: 1286:204c serial: <filter> 
Drives:    Local Storage: total: 119.24 GiB used: 11.85 GiB (9.9%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 119.24 GiB block size: physical: 512 B logical: 512 B 
           speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: ADMS0101 scheme: GPT 
Partition: ID-1: / raw size: 110.15 GiB size: 107.92 GiB (97.98%) used: 11.85 GiB (11.0%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 229 Uptime: 12m Memory: 7.70 GiB used: 1.43 GiB (18.6%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: zsh v: 5.8 running in: alacritty inxi: 3.0.37 

Maybe uninstall random?

:woman_shrugging:

Oh I see. a 'surface' kernel ..
What package is that exactly?
Have you tried with other kernels ?

It looks like you arent using a manjaro kernel.
What did you install, how, why ?
Have you tried booting a different kernel, such as a regular manjaro kernel ?

I am using the linux surface kernel. I've tried booting the stock manjaro kernel too but the problem was still there. I have also tried downgrading the kernel to linux-54 but the problem still existed. Seems like this isn't a kernel issue after all.

journalctl -xb -p3

Might tell us more .. or maybe checking something like htop system monitor while using.

journalctl output:

-- Logs begin at Wed 2020-07-22 13:42:36 +08, end at Thu 2020-07-23 20:01:20 +08. --
Jul 23 19:59:58 surface kernel: Bluetooth: hci0: unexpected event for opcode 0x0000
Jul 23 19:59:58 surface kernel: Bluetooth: hci0: unexpected event for opcode 0x0000
Jul 23 20:00:05 surface kded5[1041]: org.kde.plasma.dataengine.geolocation: error:  "Unknown host location.services.mozilla.com: Host not found"
Jul 23 20:00:05 surface kded5[1041]: org.kde.plasma.dataengine.geolocation: error:  "Unknown host location.services.mozilla.com: Host not found"
Jul 23 20:00:05 surface bluetoothd[885]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Jul 23 20:00:05 surface bluetoothd[885]: RFCOMM server failed for :1.56/Profile/HSPHS/00001108-0000-1000-8000-00805F9B34FB: rfcomm_bind: Address already in use (98)
~
~
~

This is not an initrd build by Manajro.

What branch are you using? Even if you are using unstable branch - then using a kernel build by upstream Arch may be inconsistent with other drivers build by Manjaro and probably present on your system.

Please do - the surface laptop is a Microsoft backed product - just like Manjaro has tweaked the distribution to fit certain peculiarities - I am sure Microsoft has done the same thing - so the OS may have some tweaks added to make the hardware shine when used with Windows.

Thank you so much for the advice. I really enjoyed using Manjaro for the past few months and using linux in general, unfortunately the Surface isn't fit for it.

I am having the same problems as the OP except I am using XFCE on a new Asus VivoBook 15. The laptop came with Windows 10 Home, and I wiped it out to do a clean install of Manjaro. It was running perfectly for two weeks, until two nights ago when I allowed some updates. I don't know what a kernel is or which one I'm using. I am brand new to Manjaro. Is there a patch likely to be sent out soon? Or do I need to reinstall?

That's strange. It probrably means that this issue is not only a Surface issue nor a KDE only issue. It might have something to do with Manjaro itself.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by