Could not satisfy dependencies: removing gnome-shell breaks dependency 'gnome-shell>=3.18' required by gnome-shell-extension-manjaro-update

I thought mutter was the default WM for gnome?

Mutter is already the default WM of Gnome Shell and a mandatory dependency of it, just saying

thanks for the correction, i was working off apparently bad memory. i was thinking of the mutter workaround.

im not exactly sure on its current mechanism of workaround, its still maintained. now im wondering just what gnome-shell-performance does? hmmm.. sorry if i caused any confusion :face_with_head_bandage:

Yeah, is already installed on Surface Pro 3 trough Add/Remove Software, AUR. But it does not remove the stutterings. Maybe i try to install it trough the terminal like @Lolix showed here and it then it maybe works. But on the other hand, mutter workaround has helped me to get rid of stutterings back in the days on my PC with GTX 1070 on Manjaro 17. Also installed trough GUI software manager from AUR. Also i have tested newest Fedora yesterday and i have those frickin stutterings :frowning:
@Lolix installing in progress... i'm excited

Ok, installed, restarted. Nothing changed for me. I have no idea why it does not stay smooth all the time and the system has "framerate drops" on animations. No joke, i'm searching for the solution for months already...

i think maybe its time to search other gnome/stutter posts and if nothing sticks out then post relevant info/logs needed. as of now there is nothing for anyone to work with.

I would like to try that out
How to install it? @dglt this comes from another gnome stutter post i have found and it is used by Ubuntu 18 as i know.

that is "clutter" i believe, and its in the manjaro repo's.

but you should post at least basic info if you want to know if others may have had this issue and solved it already. what may work for 1 machine does not necessarily work for every machine, some using wayland, some using nvidia, some using optimus (integrated/discrete). each one presents a different set of paths to travel down in search of solutions.
inxi -Fxxxz
mhwd -li

inxi -Fxxxz:

[dawid@dawid-pc ~]$ inxi -Fxxxz
  Host: dawid-pc Kernel: 4.19.12-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Gnome 3.30.2 wm: gnome-shell dm: GDM 3.30.2 
  Distro: Manjaro Linux 
  Type: Laptop System: Microsoft product: Surface Pro 3 v: 1 
  serial: <filter> 
  Mobo: Microsoft model: Surface Pro 3 v: 1 serial: <filter> 
  UEFI: American Megatrends v: 3.11.2350 date: 01/23/2018 
  ID-1: BAT0 charge: 13.2 Wh condition: 40.5/42.2 Wh (96%) volts: 7.5/7.6 
  model: LGC-LGC X883815 type: Li-ion serial: <filter> status: Discharging 
  cycles: 263 
  Topology: Dual Core model: Intel Core i5-4300U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19963 
  Speed: 798 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Microsoft 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0a16 
  Display: x11 server: 1.20.3 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.2.6 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:03.0 chip ID: 8086:0a0c 
  Device-2: Intel 8 Series HD Audio vendor: Microsoft driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
  Sound Server: ALSA v: k4.19.12-1-MANJARO 
  Device-1: Marvell 88W8897 [AVASTAR] 802.11ac Wireless vendor: SafeNet 
  driver: mwifiex_pcie v: 1.0 port: 3040 bus ID: 01:00.0 chip ID: 11ab:2b38 
  IF: wlp1s0 state: up mac: <filter> 
  Local Storage: total: 238.47 GiB used: 41.43 GiB (17.4%) 
  ID-1: /dev/sda vendor: Samsung model: MZMTE256HMHP-000MV size: 238.47 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 1M0Q scheme: GPT 
  ID-1: / size: 62.61 GiB used: 41.37 GiB (66.1%) fs: ext4 dev: /dev/sda5 
  System Temperatures: cpu: 38.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 221 Uptime: 1h 01m Memory: 7.70 GiB used: 1.45 GiB (18.9%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: gnome-terminal inxi: 3.0.28 
[dawid@dawid-pc ~]$ 

mhwd -li:

[dawid@dawid-pc ~]$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
[dawid@dawid-pc ~]$ 

i noticed the same on my nvidia/intel optimus lappy (prime) when using gnome, but on kde,openbox, and even budgie it stuttered much less than gnome. noticeable mostly when using a browser(FF,chromium,vivaldi).

comparing a desktop with an nvidia gpu and a laptop with an integrated gpu will lead you nowhere useful. this happens with my dell (optimus) lappy, and its happened on my kids lenovo amd a6 apu laptop's. so it really seems a gnome thing more than anything else.

if you do figure it out, please do post what you did to fix it, im interested to know why also.

It didn't work because the dependency, even on the terminal, does exist:

[dawid@dawid-pc ~]$ cd gnome-shell-performance
[dawid@dawid-pc gnome-shell-performance]$ makepkg -scCi
==> WARNING: A package has already been built, installing existing package...
==> Installing package gnome-shell-performance with pacman -U...
[sudo] password for dawid: 
loading packages...
resolving dependencies...
looking for conflicting packages...
:: gnome-shell-performance and gnome-shell are in conflict. Remove gnome-shell? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing gnome-shell breaks dependency 'gnome-shell>=3.18' required by gnome-shell-extension-manjaro-update
==> WARNING: Failed to install built package(s).
==> Cleaning up...
[dawid@dawid-pc gnome-shell-performance]$ 

Any ideas how to install this package?

gnome-shell-extension-manjaro-update depends on gnome-shell. maybe temporarily uninstall>install gnome-shell-performance>install gnome-shell-extension-manjaro-update????

note: may be a better way, i just dont know it.

Please Edit the pkgbuild of your extension and add provides array
And build it..
Not sure this extension solve your issue :wink:

@ Ste74 maybe it is worth to try those packages out before i give up. I do really like linux and manjaro but it is a pain in the a** to not have overall smooth experience...
PKGBUILD already includes this( provides=(‘gnome-shell>=3.18’)):

# Maintainer: Jan Alexander Steffens (heftig) <>
# Patched package maintainer: Saren Arterius <>
# Contributor: Ionut Biru <>
# Contributor: Flamelab <

pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
         gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libcroco libgdm libsecret
         mutter nm-connection-editor unzip gstreamer libibus)
makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
optdepends=('gnome-control-center: System settings'
            'evolution-data-server: Evolution calendar integration')
_commit=2a36bf52cb61ac1a015bc2150807a8d47c7155e4 # tags/3.30.2^0

prepare() {
  cd $_pkgname

  # st-box-layout: Avoid fullscreen relayout on scroll
  git remote add vanvugt || true
  git fetch vanvugt
  git cherry-pick 6a3dd0fa
  git cherry-pick 5aac3f0a

  # js/ui: Use captured-event::instantaneous [performance]
  # Requires mutter MR283/commit "clutter-actor: Add detail to captured-event signal [performance]"
  if pacman -Q | grep mutter-781835-workaround; then
    git cherry-pick d12c86cf || bash
    echo "======= mutter-781835-workaround detected, MR276 is applied ======="
    sleep 3
    echo "======= mutter-781835-workaround not installed, not applying MR276 ======="
    sleep 3

  # messageTray: Re-enable unredirection when banner is destroyed 
  # Fix performance regression with fullscreen apps, merged in master but not in 3.30
  git cherry-pick e5ce3d54

  # Move the plugin to our custom epiphany-only dir
  sed -i "s/'mozilla'/'epiphany'/g"

  git submodule init
  git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
  git submodule update

build() {
  arch-meson $_pkgname build -D gtk_doc=true
  ninja -C build

package() {
  DESTDIR="$pkgdir" meson install -C build

  mkdir "$pkgdir/usr/share/gnome-shell/modes"

Any other ideas to try out?

Can i somehow start the system without loading up Gnome DM and install this package from command line?

Pkgbuild include provides=(gnome-shell)

Remove and install later gnome-shell-extension-manjaro-update or

Install gnome-shell-peformance package with ignore dependecy option (not a thing I advise often)

sudo pacman -Ud full-package-name.pkg.tar.xz

enter from another computer through ssh (the ssh systemd service is called sshd)

As @Lolix say in the pkgbuild is true is present provides array but pacman provides array Don t check the version so you have to specify the version since you need mandatory >=3.18.

Ok changed:




solved that dependency hell and the installation started. Finally.

By the way guys, i wish you a merry christmas!

1 Like

Thank you and merry Chrystmans also for you and your family..

Merry Christmas to you guys

btw @Ste74 I guees you can drop depends on gnome-shell>=3.18 from gnome-shell-extension-manjaro-update , it is at 3.30 now

Forum kindly sponsored by