Crackling and popping sound when using headphones

Hi! I came to manjaro after xubuntu, where i've had the same issue, but was able to fix it. So, the problem is crackling and popping sound when using headphones, probably that happens due to power saving. In the tlp config file power saving for audio devices is disabled.

:+1: Welcome to Manjaro! :+1:

Please read this:

and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...
P.P.S. How did you fix it on Ubuntu?

is that during audio playback or when playback starts or stops ?

please post system information - inxi -Fxxxa

1 Like

Fabby, nikgnomic, thanks for your replies, inxi -Fxxxa info:

  Host: named Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=4c041be7-08e1-4b3f-9024-f4585eb6fc0e rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: Timi product: TM1905 v: N/A serial: <root required> 
  Chassis: type: 10 serial: <root required> 
  Mobo: Timi model: TM1905 v: MP serial: <root required> UEFI: INSYDE 
  v: XMAKB5R0P0502 date: 10/13/2017 
  ID-1: BAT0 charge: 0.0 Wh condition: 53.1/60.0 Wh (88%) volts: 6.7/7.6 
  model: SUNWODA R15B01W type: Li-ion serial: 052C status: Discharging 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse 
  serial: 4055-e2-32-55-94 charge: 50% (should be ignored) rechargeable: yes 
  status: N/A 
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: CA L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 700 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 700 2: 700 
  3: 700 4: 700 5: 700 6: 700 7: 700 8: 700 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Xiaomi driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Xiaomi Mi Notebook Pro 
  driver: nvidia v: 440.82 bus ID: 01:00.0 chip ID: 10de:1d12 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  unloaded: intel,nouveau alternate: fbdev,nv,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.5 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Xiaomi 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.6.7-1-MANJARO 
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 3000 
  Local Storage: total: 238.47 GiB used: 12.06 GiB (5.1%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-00000 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: S33VNA0JA40460 rev: CXB7401Q scheme: GPT 
  ID-1: / raw size: 51.39 GiB size: 50.33 GiB (97.94%) 
  used: 12.04 GiB (23.9%) fs: ext4 dev: /dev/nvme0n1p6 
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 220 Uptime: 7h 00m Memory: 7.66 GiB used: 1.76 GiB (23.0%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  running in: xfce4-terminal inxi: 3.0.37

P.S. yes, that happens when playback starts or stops
P.P.S. I not sure, but probably modifying snd-hda-intel config file fixed that on Ubuntu.

glitches when playback starts or stops is likely a power-management issue with audio device

disable pulseaudio module module-suspend-on-idle temporarily

pactl load-module module-suspend-on-idle

if that works to stop crackling and popping, Pulseaudio configuration can be changed to disable the module permanently

sudo sed -i 's/load-module module-suspend-on-idle/#load-module module-suspend-on-idle/g' /etc/pulse/

this adds a comment tag '#' at the start of the line to stop module being loaded

1 Like


a command?

Result is
bash: load-module: command not found.

my bad - i messed up copy/pasting
edited previous post for correct command

pactl load-module module-suspend-on-idle

hmm.. don't understand how does it work, but after
pactl load-module module-suspend-on-idle
result was "Failure initializing", but i seems that now the problem is gone, no popping noise, even after reboot. In any case, thank you!

oh, that didn't helped, i've just plugged in the laptop, so when i unplug it, the problem comes back
Result of
pactl load-module module-suspend-on-idle
Failure: Module initialization failed
What does it mean?

means i am an idiot and i got it wrong in 2 ways first time around :disappointed:
can't load that module a 2nd time when it is already loaded
want to unload it anyway

pactl unload-module module-suspend-on-idle

but the 2nd command to disable module permanently is ok

(i will go and find some strong coffee now - brb)

1 Like

Finaly, that

fixed it.
The 2nd command made it permanent.
The problem solved, thanks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by