Crash during update


I was installing updates when my computer froze/ crash. I see this on reboot and can't do anything else. Is there a fix? Thanks!

Edit: I think I figured out the problem. I ran out of HD space during the update. Oi.


What does that mean?

chroot - a tool to affect changes to a system from another system.
(such as from a liveusb)
Actually, we have manjaro-chroot which makes it pretty simple. See here for example..

1 Like

I can't do the first one because I don't have a second system to work with. I tried the second option with no luck, and the third option gives me this:

[manjaro@manjaro ~]$ sudo mount /dev/sda2 /mnt
[manjaro@manjaro ~]$ sudo pacman -S mhwd-chroot
warning: database file for 'core' does not exist
warning: database file for 'extra' does not exist
warning: database file for 'community' does not exist
warning: database file for 'multilib' does not exist
error: target not found: mhwd-chroot

Is it fresh install time?

You probably want to use manjaro-chroot
database gets downoaded if you do sudo pacman -Syu

1 Like

Have you tried this?

1 Like

I gave this a shot, but the first command line gave me this:

modprobe: FATAL: Module efivars not found in directory /lib/modules/4.14.21-1-MANJARO

Figured I should post for advisement before running the rest of the commands.

It honestly might be easier to wipe and reinstall everything, the only problem is that I have a wine folder on this hard drive somewhere that I need to pull files from before I wipe my hard drive with a fresh install. Any ideas on how to find it. I know the folder was .wine/drive_c, but I don't see it when browsing the hard drive in the file manager.

If your system to rescue is not UEFI, you may skip the commands that include "efivars".
Else you should boot to a UEFI mode booting system.

I'm currently in using the USB I installed manjaro from and am working out of a live session of that to try to fix it. This is what happened when I try the next command:

[manjaro@manjaro ~]$ mount -t proc proc /mnt/proc
mount: only root can use "--types" option
[manjaro@manjaro ~]$ sudo mount -t proc proc /mnt/proc
mount: /mnt/proc: mount point does not exist.

On the bright side, I found the wine files.

Create folders first

sudo mkdir /mnt/{proc,sys,dev,dev/pts}
[manjaro@manjaro ~]$ sudo mount -t proc proc /mnt/proc
[manjaro@manjaro ~]$ sudo mount -t sysfs sys /mnt/sys
[manjaro@manjaro ~]$ sudo mount -o bind /dev /mnt/dev
[manjaro@manjaro ~]$ sudo mount -t devpts pts /mnt/dev/pts/
[manjaro@manjaro ~]$ sudo mount -t efivarfs efivarfs /sys/firmware/efi/efivars
mount: /sys/firmware/efi/efivars: efivarfs already mounted on /sys/firmware/efi/efivars.
[manjaro@manjaro ~]$ sudo chroot /mnt
chroot: failed to run command ‘/bin/bash’: No such file or directory
[manjaro@manjaro ~]$ 

It was going ok until I hit the chroot command...

I think the live boot I have is 17.1 or something. I know there's been two kernel updates since. If I decide to give up and reinstall everything fresh. Is it going to cause a problem using and old version and then just letting the update run (probably for an eternity)...

You have probably done something wrong to get this message.
If not able to chroot properly (it needs some reading and patience...) and decide to install fresh, it would be better to use a recent ISO version, not your old one.
If you are not fluent or experienced in Linux/Manjaro/Arch it is more than preferred.
Anyway, it's your decision and a cool way to learn more... :wink:

I am definitely not experienced. At my technical aptitude, I should probably be using Windows or even an ipad. However, there are a lot of Linux-only programs I really like and I just don't like what Windows has become.

I did a fresh install with my old USB drive, just so I'm not using a liveboot and you're right, it's grumpy. I have 800+updates that won't install due to some conflict with thunar. I can't get WINE working properly, and I installed tuxcards, but it won't actually open. Now I just need to relearn how to create a bootable USB from an iso. I remember using rufus before (this system was originally windows).

I found this page, but I'm not sure what the drive letter is for my USB (which I apparently need for the . Drive letters don't show in the file manager, though. How do I know?


side note, I think going forward I'll post any and all questions in the newbie forum because, let's be honest, I'm no rocket scientist here.

To find your USB drive, open a terminal and type lsblk to get a list of all drives.

Or you could install etcher (it's in the repos) and use it to create a bootable USB from your ISO - etcher works very nicely.

I did install etcher, but like tuxcards, it won't actually open. Like, I select it from the start menu, but nothing happens.

1 Like

Ah, yes, you're in an older version of Manjaro, which is interfering with installing newer apps. I momentarily forgot that part, sorry.

So you can use the dd command you mentioned above - use lsblk to identify your USB flash drive (it's probably sdb) and make sure you have no typos. dd is a powerful command.

1 Like

So, my current bootable usb was one I made in rufus for 17.1. Can I reuse it with this command, or do I need a fresh drive?

You can reuse the USB flash drive, dd will overwrite it.

so lsblk gets me this:

sda            8:0    1 14.6G  0 disk 
├─sda1         8:1    1  1.7G  0 part 
└─sda2         8:2    1    4M  0 part 
mmcblk0      179:0    0 58.2G  0 disk 
├─mmcblk0p1  179:1    0  251M  0 part /boot/efi
├─mmcblk0p2  179:2    0  4.1G  0 part [SWAP]
└─mmcblk0p3  179:3    0 53.9G  0 part /
mmcblk0boot0 179:8    0    4M  1 disk 
mmcblk0boot1 179:16   0    4M  1 disk 
mmcblk0rpmb  179:24   0    4M  0 disk 

so according to the link above, I think the command should be:

sudo dd bs=4M if=/home/torm/Documents/manjaro-xfce-18.1.5-191229-linux54.iso of=/dev/sda status=progress oflag=sync

Am I getting it? Thanks!

Forum kindly sponsored by