Creating a Data partition

Hi everyone,

I made a small home partition now I need more space.
So I thought I'll just make a new partition I can use. Saw what the user called gohlip said here
so I googled making a data partition. Only thing I saw was mentioning of /data here .
Not having found sufficient info I reckoned I'll try whatever.
Shrunk a Windows partition, 20 gb unallocated, started up Manjaro's live USB to run gparted from there (cause I first thought I could just expand the home partition). Formatted it to ext4, named it data and put the label /data.

Now, the partition is mounted but I can't add anything to it or create a folder etc.
I've seen in similar threads that the output of these 2 commands is often asked so:

lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 465.8G 0 disk
├─sda1 8:1 0 450M 0 part
├─sda2 8:2 0 100M 0 part /boot/efi
├─sda3 8:3 0 16M 0 part
├─sda4 8:4 0 49.5G 0 part
├─sda5 8:5 0 369.8G 0 part
├─sda6 8:6 0 4G 0 part [SWAP]
├─sda7 8:7 0 1G 0 part /home
├─sda8 8:8 0 21G 0 part /
└─sda9 8:9 0 20G 0 part /run/media/michael/_data
sr0 11:0 1 1024M 0 rom

cat /etc/fstab
/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a device; this may
be used with UUID= as a more robust way to name devices that works even if
disks are added and removed. See fstab(5).


UUID=A2D5-CF74 /boot/efi vfat umask=0077 0 2
UUID=c8ba4134-ebe8-4486-8f40-b2256ae0005c swap swap defaults,noatime 0 2
UUID=e43061a2-256a-4d51-83a4-1f27b5bb05ed /home ext4 defaults,noatime 0 2
UUID=f0f7a027-3119-4337-a13e-40a05f0da529 / ext4 defaults,noatime 0 1

I hope I haven't commited any of the major sins of posting a question on a linux forum.
I tried reading an arch wiki about adding new partitions to an existing system but honestly it goes over my head.

I reckon I made a mistake by putting the label /data since that looks like a mounting point thing.
Help?

Its permissions.
Set up permissions on the drive how you would like.
For example - give yourself a folder to own, so its as secure as your home and can be used as a big dump.

Well that was easy. Thanks!

For anyone googling and arriving at this post, what I did was - I typed in the terminal

sudo chown michael /run/media/michael/_data

What I did before that was that I just opened the partition in the file explorer, made sure it was mounted. If your partition doesn't show up with the lsblk command it means it ain't mounted or maybe you missed a step in the creation of the partition.

Where I put michael in the command - you put your username.
And what your "/run/media/michael/_data" part will be, you'll find out with the lsblk command. You can see where it says that for me, it's the next to last line of the lsblk output.

edit: restart and you're done

Oh, for some reason I can copy things to it but when I try and give Chromium that partition as a downloads destination it says disk full?

Never mind, I just restarted the PC and it works now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by