Custom shortcuts have all gone, cant remake them.

On KDE (stable). The custom shortcuts has gone (o why has the custom shortcuts gone :sob: ) along with all my shortcuts. I cant seem to re-make them.

I need shortcuts for ksnip

"print" = ksnip -f
"shift print" = ksnip -r
"Ctrl print" = ksnip -a

plus

"meta space" = python ~/python/text-crypt/text-crypt.bin

And a whole lot of others but if i can figure these im sure i can continue.

I have tried but i can't even get "print" to execute ksnip (even though the application menu launches ksnip fine) and how do i add all the other ksnip shortcuts i need like "shift print" is my area shot?

ZZ_20200429-050809

EDIT:-
I just tested with leafpad and that does not work either, god dam everything was fine, why.

ZZ_20200429-052948

I have now tested about 6-7 different apps and 6-7 different shortcut combos, none of them work!

Plus the Global shortcuts GUI keeps crashing, which I never seen it do before.

I really hope someone can help because I just can't be doing without all my shortcuts.

Check the permissions of '~/.config/kglobalshortcutsrc` and make sure to be set to your user. You can check if you have some funky entries too in the file, and also see if it gets modified when changing some of the shortcuts.

Hi, cheers.
I have figured that I needed to reboot the comp after making any changes to the shortcut settings and I'm a little closer now but I'm still a little stuck.

I can't get rid of spectacle. I have tried removing its shortcuts from both Global shortcuts and from spectacle settings themselves but every time I reboot they all come back again?

Also, no clue what this means
ZZ_20200429-062156

I shall ask how i make multi-entries for ksnip later ^^

I can see Spectacle in the .config file but i really dont want to touch any config files i want to know what to do from the GUI or i will never remember next time i face the same problem.

But it looks ok for permissions and ownership though.

ls -la ~/.config/kglobalshortcutsrc
-rw------- 1 greg greg 20326 Apr 29 06:26 /home/greg/.config/kglobalshortcutsrc

I think it means as long the shortcuts are enabled for it, removing it from list will be reset next boot. So, maybe you have to first remove the shortcuts for it, then remove it from list, or maybe just remove the shortcuts from it.

You can check after making the modification, it should be instant, then correct any issue, or revert back Ctrl+Z or from the Settings UI to set the proper shortcut.

I have tried removing the shortcuts from both but the entries just keep coming back after a logout or reboot.

In fact the entries are still in the config file even after removing them from the GUI's

ZZ_20200429-065543 ZZ_20200429-065445

But when i look inside ~/.config/kglobalshortcutsrc i find

[org.kde.spectacle.desktop]
ActiveWindowScreenShot=none,Meta+Print,Capture Active Window
CurrentMonitorScreenShot=,none,Capture Current Monitor
FullScreenScreenShot=none,Shift+Print,Capture Entire Desktop
RectangularRegionScreenShot=none,Meta+Shift+Print,Capture Rectangular Region
_k_friendly_name=Spectacle
_launch=,Print,Launch Spectacle

Should i just remove it from the config and reboot?

Well, you can try that, but i just noticed an inconsistency with that config file. Is keeping even old entries of a kwinscript that was removed ... hmmm.

Hmm, glad its not just me then :slight_smile:

I'm still going to be wondering about how I am supposed to set up knip in the following manner without creating multiple application menu entries (one for each ksnip argument)

"print" = ksnip -f
"shift print" = ksnip -r
"Ctrl print" = ksnip -a

All this used to be so easy :frowning:

Re-install the plasma group, my guess - something got removed.

sudo pacman -S plasma

Probably khotkeys.

1 Like

Ok, had to take a look at ksnip ... and has is own set of hotkeys settings. Better make use of those, and change them accordingly to your need:

image

The ksnip needs to be started and in tray to work.

Yea I did see them. They would not work at all when I first tried them I think they were interfering with the other shortcut key (that I still can't get rid of "Spectacle"). They are working now after another reboot.
I really did not need yet another tray icon though, thats the point of the ksnip arguments.

It'll do for now.

You are right but why did it get removed I never removed it and what effect will it have because iv got most of the shortcut keys working now, or will reinstalling plasma give me the "custom shortcuts" back again? Im very confused.

❰greg❙~❱✔≻ paclog | grep khot
[2020-01-16T16:51:18+0000] [ALPM] upgraded khotkeys (5.17.4-1 -> 5.17.5-1)
[2020-03-14T18:03:56+0000] [ALPM] upgraded khotkeys (5.17.5-1 -> 5.18.3-1)
[2020-04-08T10:52:30+0100] [ALPM] upgraded khotkeys (5.18.3-1 -> 5.18.4.1-1)
[2020-04-26T17:36:22+0100] [ALPM] removed khotkeys (5.18.4.1-1)

Well blow me backwards, yes it did give me back the "custom shortcuts" as per the title of this thread.

Thank you so much @xircon

ZZ_20200429-100214

You can hide it.

I know but its still a background program running.

It's all academic now anyhow as I'm back to normal with everything working as it used to now i have "custom shortcuts" back again. No clue where or why it went but very glad its back. (bloody linux... grumble grumble ..)

I appreciate your help @bogdancovaciu.

Because is a standalone app, and is not integrated like Spectacle in KDE Plasma, it requires the process to be running in order to invoke the screenshot utility of it and to manage the existing screenshots taken with it, either via tray icon menu or by its predefined hotkeys.

No worries. Glad you got back the shortcuts, but since you mentioned ksnip it required clarification. :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by