Dbus update on unstable (&testing) branch breaks dbus (2016-08-28)

pacman -Syyuu is downgrade.

I was wondering already elsewhere on forum where you guys get this command from? Wrong wiki entry?

Just ignore it and install dbus-openrc. Date versions are treated as newer by pacman.

Yes, I have used the downgrade command on occasion, but rarely ever have to. I understand it's usage
I will manually install the package. Thank you @artoo.

Best regards.

I just saw a new update for dbus-openrc that wants to reinstall dbus and libdbus 1.10.8--what's going on there, @artoo?

And it seems testing is getting updates with unstable. I need to ask about that...

Tbh, I have no idea, I had updated testing yesterday, and now testing has again the old package.
something must have gone wrong when packages were moved from unstable to testing. It wasn't me.

NetworkManager-console has been updated today in both unstable and testing and I encountered a problem on unstable when I did the update...could not connect to my wireless network. The network was showing but no contact. I didn't do much troubleshooting, but did downgrade NetworkManager-consolekit to the previous version and my wireless began working as normal.
I thought I would give a heads up.

I should have started a new topic, as this is a different problem, but the update arrived in both unstable and testing at the same time.

Best regards.

It worked fine for me on laptop with wireless when testing.

@cimarronline

Phil reset it, because testing still has dbus-1.10.8

Thanks. I'll just keep the dbus-openrc I have. Something strange is going on with testing...

The new NetworkManager-consolekit worked fine for me also.

I'll have to reinstall the new version on my unstable branch system and see if I can figure out whats causing the issue. Downgrading NetworkManager-consolekit restored my connection, so it's something in the new package that's not agreeing with me.

I agree @cimarronline...something seems amiss in testing.

Best regards.

On testing and systemd. Also had :

Replace libdbus with core/dbus? [Y/n] y
warning: mhwd-nvidia: local (1:370.23-1) is newer than core (1:367.44-1)

Packages (28) dbus-1.10.10-3  diffutils-3.5-1  elfutils-0.167-1
              ffmpeg-1:3.1.3-1  glib2-2.48.2-1  ldb-1.1.27-1
              lib32-libcurl-gnutls-7.50.1-4  lib32-libdbus-1.10.10-3
              lib32-libnl-3.2.28-1  libcurl-gnutls-7.50.1-3
              libdbus-1.10.8-1 [removal]  libelf-0.167-1  libevdev-1.5.4-1
              liblouis-3.0.0-2.1  libnm-glib-1.4.0-1  man-db-2.7.5-4
              manjaro-documentation-20160829-1  manjaro-release-16.08-1
              manjaro-welcome-20160828-1  mpv-1:0.20.0-1
              networkmanager-1.4.0-1  nfs-utils-1.3.4-1
              nm-connection-editor-1.4.0-1  pacman-mirrorlist-20160829-1
              pamac-4.1.3-2  pango-1.40.2-1  tdb-1.3.10-1  tevent-0.9.29-1


Then I also ran -Syuu for the nvidia downgrade (dont have nvidia anything anyways)

Is it safe to reboot ? Or am I still waiting and sitting on this session til a fix drops ?

There's a 50/50 chance that it'll reboot.:smirk:

Best regards.

yeah. well. wish i woulda seen this thread earlier :sweat:

I don't know if the dbus thing affects systemd init....I had the issue with dbus-openrc.

Best regards.

Kinda seemed that way .. but now I'm scared. I think Ill wait to sacrifice an old floppy disk by moonlight, turn round 3 times and reboot in morning...while quietly muttering the entirety of the GPL.

2 Likes

I had no problem with this on my plasma systemd system.

1 Like

Waited for my server to sync and then when it was, ran -Syyu and was greeted with :

warning: dbus: local (1.10.10-3) is newer than core (1.10.8-1)
warning: lib32-libdbus: local (1.10.10-3) is newer than multilib (1.10.8-1)

I hadnt spotted this, updated… rebooted stops at tlp. Tried downgrading still will not boot. On my phone. Systemd and unstable - how do i fix, i have no wireless so have got a cable out so have internet now

I just switched to unstable, updated, and booted fine. I have network-manager-applet held at 1.0.10-1 as per this bug - Network Manager Applet Error after Suspend - but otherwise nothing odd.
For network, have you tried

systemctl restart NetworkManager.service

Maybe downgrade network-manager-applet or networkmanager itself
(1.4 seemed to have issues all over arch forums ... try 1.2.x)
For dbus . please

sudo pacman-mirrors -g
yaourt -Syyu

Let me know output.

Edit - oo look at this:

I have no idea why we now have systemd and NM on openrc dedicated subforum on dbus.
Seriously people, this is only confusing.

Sorry - didn't not notice it. Was very late last night when this happened and searched and found this.

I fixed ( and screwed up something else due to bleary eyes) by downgrading dbus.

But my machine was also reporting dbus-openrc conflicts which was confusing me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by