deep-plasma

I installed Trizen and Octopi , much prefer it to Discover , pretty much all that's left to do is import bookmarks in to Firefox and setup Timeshift , piece of cake and peace of mind . :wink:

2 Likes

software token: not sure, it got pulled in with openconnect and or plasma-nm

you can right click & hide it if you like :wink:

Thanks @rbrick49 I think your post just answered one of my questions as well as @ant. Been trying to track this down as it is annoying and filling up journalctl (dhcpcd[914]: if_route (ADD): File exists). I won't be able to be sure until later this afternoon but I believe it may have something to do with openconnect.

doubt its that or we'd all have it!?

try this:
sudo systemctl mask dhcpcd@enp5s0.service
reboot
check if it disabled it:
sudo systemctl status dhcpcd@enp5s0.service
check if your internet still works and the error has gone.

Thanks again @ant.
Moved pics here more traffic for @ant :rofl:

@ant
journalctl -p 3 -xb

Summary
Jul 05 18:06:01 elloquinarchplasma kernel: sd 9:0:0:0: [sda] No Caching mode page found
Jul 05 18:06:01 elloquinarchplasma kernel: sd 9:0:0:0: [sda] Assuming drive cache: write through
Jul 05 18:06:01 elloquinarchplasma kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
Jul 05 18:06:01 elloquinarchplasma kernel: scsi 9:0:0:1: Wrong diagnostic page; asked for 1 got 8
Jul 05 18:06:01 elloquinarchplasma kernel: scsi 9:0:0:1: Failed to get diagnostic page 0x1
Jul 05 18:06:01 elloquinarchplasma kernel: scsi 9:0:0:1: Failed to bind enclosure -19
Jul 05 18:06:01 elloquinarchplasma kernel: kvm: disabled by bios
[elloquin@elloquinarchplasma ~]$ 

Nice and clean. Ignore the scsi errors just linux nagging about my external USB.

systemd- analyze blame

Summary
          6.591s pacman-init.service
          1.179s systemd-logind.service
           518ms lvm2-monitor.service
           518ms swapfile.swap
           374ms dev-sdb2.device
           220ms systemd-udevd.service
           209ms systemd-journald.service
           167ms udisks2.service
           109ms upower.service
            96ms systemd-journal-flush.service
            66ms NetworkManager.service
            65ms boot-efi.mount
            64ms polkit.service
            50ms systemd-udev-trigger.service
            35ms user@1000.service
            20ms systemd-fsck@dev-disk-by\x2dpartuuid-af72fea4\x2d9bbf\x2d4d08\x2db990\x2daef8616f18c4>
            12ms systemd-tmpfiles-setup.service
            10ms systemd-tmpfiles-setup-dev.service
             9ms sys-kernel-debug.mount
             8ms systemd-modules-load.service
             8ms dev-hugepages.mount
             8ms kmod-static-nodes.service
             6ms dev-mqueue.mount
             6ms haveged.service
             5ms systemd-sysctl.service
             5ms user-runtime-dir@1000.service
             5ms systemd-update-utmp.service
             5ms systemd-remount-fs.service
1 Like

I beleive this can be blacklisted:
sp5100-tco sp5100-tco: Watchdog hardware is disabled
https://bbs.archlinux.org/viewtopic.php?id=239075

kvm: disabled by bios I think this is Having the ability to use VMs in your OS but its disabled in the bios, enable if you want to use virtualbox, etc

lvm2-monitor.service
you can mask this service if you don't use it, check here: https://wiki.archlinux.org/index.php/LVM
sudo systemctl mask lvm2-monitor.service

pacman-init.service this can be disabled

sudo systemctl stop pacman-init.service
sudo systemctl disable pacman-init.service

if you disable this ^ service make sure you do this after and check you can still update, download.

sudo pacman-key --init
sudo pacman-key --populate archlinux

Any problems after disabling / masking just turn them back on, enable unmask

System should boot a bit quicker now and you have 2 services not being loaded :wink:

anything you don't understand let me know...

1 Like

:rofl:

journalctl -p 3 -xb
```[elloquin@elloquinarchplasma ~]$ systemd-analyze blame
          1.133s systemd-logind.service
           526ms swapfile.swap
           370ms dev-sdb2.device
           213ms systemd-udevd.service
           208ms systemd-journald.service
           164ms udisks2.service
           105ms upower.service
            95ms systemd-journal-flush.service
            64ms NetworkManager.service
            57ms polkit.service
            51ms systemd-udev-trigger.service
            41ms boot-efi.mount
            34ms user@1000.service
            23ms systemd-fsck@dev-disk-by\x2dpartuuid-af72fea4\x2d9bbf\x2d4d08\x2db990\x2daef8616f18c4>
            11ms systemd-tmpfiles-setup-dev.service
            11ms systemd-tmpfiles-setup.service
             6ms dev-hugepages.mount
             6ms sys-kernel-debug.mount
             6ms user-runtime-dir@1000.service
             6ms systemd-modules-load.service
             6ms systemd-update-utmp.service
             5ms haveged.service
             5ms systemd-user-sessions.service
             5ms systemd-sysctl.service
             5ms systemd-remount-fs.service
             5ms systemd-random-seed.service
             5ms dev-mqueue.mount
             3ms rtkit-daemon.service

1 Like

grub tweaks I use: /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="audit=0 nowatchdog mitigations=off"

audit=0 I get a lot of audit messages in my dmesg, so I turn them off

nowatchdog not really needed for desktop and laptop https://wiki.archlinux.org/index.php/Improving_performance#Watchdogs

mitigations=off https://wiki.archlinux.org/index.php/Improving_performance#Turn_off_CPU_exploit_mitigations <--- read important

again any problems just remove what you did. If you edit your grub file make sure to run this after:

Update Grub: sudo grub-mkconfig -o /boot/grub/grub.cfg

Reboot!!

Can use regular fonts ??
Its hard to read bold fonts.

[grumpy@archplasma ~]$ journalctl -p 3 -xb
-- Logs begin at Mon 2019-06-24 19:55:56 +07, end at Sat 2019-07-06 18:24:43 +07. --
Jul 06 18:20:59 archplasma kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
Jul 06 18:20:59 archplasma kernel: kvm: disabled by bios
Jul 06 18:21:30 archplasma dhcpcd[766]: timed out
Jul 06 18:21:30 archplasma systemd[1]: Failed to start dhcpcd on enp42s0.
-- Subject: A start job for unit dhcpcd@enp42s0.service has failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel 1
-- A start job for unit dhcpcd@enp42s0.service has finished with a failure.

Did you change something recently?

nope been the same since install
well apart from updates

OK. I am not sure why there are these issues with dhcpcd. ant stated he doesn't have the issue:


And another post I made which may lend some insight:

I had a similar but different issue with the same service. From what I understand in the above post dhcp should be handled by network manager without this service. Did you try masking it as was suggested to me as the solution? sudo systemctl mask dhcpcd@enp42s0.service

1 Like

thanks that fixed it this time it didnt work when I tried it a couple of days back all good now

1 Like

That's correct, dhcpcd gets installed when making the base ISO then, I install networkmanger and enable its service, that's the correct fix, I will look in to it for the next ISO, thanks for reporting :wink:

1 Like

just took another screenshot of the 34 inch lg widescreen
Screenshot_20190709_202948

2 Likes

Screenshot_20190709_222718

3 Likes

just letting you know when I boot into deep-plasma google chrome is very slow to boot up after first boot it is ok thunderbird was also freezing up but seems to be ok now its all started after updates last night

Hi Ron,

Not much I can do about this, this will probably be a KDE, Chrome or an arch problem, deep-plasma is just a way to get a minimal arch install quickly on your system.

I only have Firefox web browser installed and is working fine :wink:

No issues on chromium here :blush:

Forum kindly sponsored by