deep-plasma

how do i add user to sudoers this problem has jjust occuered since new install

The only time I saw something like this happen with this ISO was when I had a corrupted USB. I downloaded a fresh ISO, checked the Sha Sum, reformatted the stick, and re-imaged the ISO. Then reinstalled. Although the error I was getting was the user did not have permission over the home folder.

ye i fixed it mate it was skipping one part on the install script all good now sudoers works just cleaned this computer out ready for new asrock x570 motherboard maybe it will be installed tomorrow

1 Like

This time try and stay away from Thunderbird. make sure everything works and then if you have problems again after installing Thunderbird you know it was the culprit :laughing:
Glad you got it sorted.

just finished reinstalling all apps and thunderbird no problem with google-chrome or chromium this time
so had no idea what was wrong but the clean install appears to fix it and also the speed of the install of deep-plasma was incredible 15 minutes from clearing all hard drives and partitioning sda and install os to reboot i am as happy as a pig in ■■■■■

1 Like

This is a guide after installing deep-plasma (archlinux)

The very First thing I do after a clean install of archlinux is check the journalctl

journalctl:
In a terminal:
journalctl -p 0 -xb the number zero is for Emergency and needs fixing, if possible
journalctl -p 1 -xb the number one is for Alert and should be fixed, if possible
journalctl -p 2 -xb the number two is for Critical and should be fixed, if possible
journalctl -p 3 -xb the number three is for Error and should be investigated for a possible fix

There are more per this but these are the important ones.

journalctl -p 4 -xb the number four will display Warnings, normally not a problem, but looking through may yield interesting info.

An internet search should get you on your way to fixing most of the problems found in the journal

Ideally you want a clean journalctl -p 3 -xb if possible.
Screenshot_20190712_175232

dmesg:
Another place to look through is dmesg some errors maybe found in here that was never shown in the above, again a quick internet search should give you more info and a possible fix.

Screenshot_20190712_182144

Other useful commands:

sudo systemctl --failed what services have failed, if any
systemd-analyze blame check for causing slow boot up
systemd-analyze the time it took to boot up

After going through all the above and fixing any errors / bugs etc I then move on to installing drivers etc, checking with journalctl -p 3 -xb in between installing them. Software is my next stage and then tweaking my system for optimal performance.

Another thing to do is journalctl -p 3 -xb just before you shut down after various tasks, that should give you any software bugs, if any.

This is what I do straight after installing on any system, assuming it boots, that's another subject for another day :wink:

2 Likes

thanks for that ant that is really helpful
heres what i get
grumpy@archplasma ~]$ journalctl -p 3 -xb
-- Logs begin at Fri 2019-07-12 16:52:14 +07, end at Sat 2019-07-13 02:44:02 +07. --
Jul 13 02:28:09 archplasma kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
Jul 13 02:28:09 archplasma kernel: kvm: disabled by bios
the only thing is watchdog will look it up later
thanks once again

[grumpy@archplasma ~]$ sudo systemctl --failed
[sudo] password for grumpy: 
0 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.
[grumpy@archplasma ~]$ systemd-analyze
Startup finished in 15.705s (firmware) + 6.302s (loader) + 4.947s (kernel) + 7.643s (userspace) = 34.598s 
graphical.target reached after 7.643s in userspace
[grumpy@archplasma ~]$ systemd-analyze blame 
          6.575s pacman-init.service
          1.387s systemd-logind.service
           701ms lvm2-monitor.service
           477ms udisks2.service
           444ms dev-sda2.device
           271ms systemd-udevd.service
           210ms systemd-journald.service
           204ms systemd-journal-flush.service
           157ms upower.service
           116ms NetworkManager.service
            94ms var-lib-snapd-snap-core-7270.mount
            93ms var-lib-snapd-snap-spotify-35.mount
            84ms polkit.service
            82ms boot-efi.mount
            78ms systemd-modules-load.service
            73ms systemd-udev-trigger.service
            61ms ldconfig.service
            50ms user@1000.service
            46ms dde-filemanager-daemon.service
            42ms systemd-fsck@dev-disk-by\x2dpartuuid-e7721945\x2dfe76\x2d4adb\x2daa6a\x>
            32ms systemd-fsck@dev-disk-by\x2dpartuuid-1e019d94\x2def22\x2d4099\x2db108\x>
            29ms systemd-tmpfiles-clean.service
            20ms wpa_supplicant.service
lines 1-23

what do you think of that ant

heres the inxi

System:
  Host: archplasma Kernel: 5.2.0-arch2-1-ARCH x86_64 bits: 64 
  Desktop: KDE Plasma 5.16.3 Distro: Arch Linux 
Machine:
  Type: Desktop Mobo: ASRock model: X470 Taichi serial: <root required> 
  UEFI: American Megatrends v: P1.10 date: 03/30/2018 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB 
  Speed: 2404 MHz min/max: 2200/3700 MHz Core speeds (MHz): 1: 2413 2: 2422 3: 2424 
  4: 2433 5: 2416 6: 2420 7: 2737 8: 2811 9: 2410 10: 2409 11: 2922 12: 2974 13: 2396 
  14: 2477 15: 1773 16: 1796 
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu 
  v: kernel 
  Display: x11 server: X.Org 1.20.5 driver: modesetting resolution: 2560x1080~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  driver: snd_hda_intel 
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel 
  Device-3: Logitech type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo 
  Sound Server: ALSA v: k5.2.0-arch2-1-ARCH 
Network:
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
  IF: wlp39s0 state: up mac: 68:ec:c5:bf:24:44 
  Device-2: Intel I211 Gigabit Network driver: igb 
  IF: enp42s0 state: down mac: 70:85:c2:80:98:63 
Drives:
  Local Storage: total: 1.11 TiB used: 9.01 GiB (0.8%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB 
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  ID-3: /dev/sdc vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB 
  ID-4: /dev/sdd vendor: Intel model: SSDSC2BW240A4 size: 223.57 GiB 
  ID-5: /dev/sde vendor: Intel model: SSDSC2BW240A4 size: 223.57 GiB 
Partition:
  ID-1: / size: 47.81 GiB used: 7.44 GiB (15.6%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 170.51 GiB used: 1.57 GiB (0.9%) fs: ext4 dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 46.6 C mobo: N/A gpu: amdgpu temp: 40 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 935 
Info:
  Processes: 321 Uptime: 12m Memory: 62.90 GiB used: 1.07 GiB (1.7%) Shell: bash 
  inxi: 3.0.34 
[grumpy@archplasma ~]$ 

Screenshot_20190714_120717

:wink:

2 Likes

well after all the problems with watchdog I had to reinstall deep-plasme now that dhcpd problem is back and it wont mask for some reason any ideas

well I went looking some more and found another link you guys sent me inserted it and fixed the problem all good now

If your having to reinstall deep-plasma, maybe you should go back to Manjaro?!?
Watchdog shouldn't cause a reinstall...

i couldnt get watchdog to start it was causing problems with the manjaro install so I reinstalled deep -plasma now its all ok again I wont fiddle with watchdog it gives me a headache
thanks ant

@ant well the install was flawless Is that the Architect installer that Carl Duff made sure looks like it it does a fine job.
Just had little nicks and nacks to do like bluetooth and pulseaudio but that's fine it is a minimal install after all not for new users.
Over all a nice minimal install that can be converted to any Arch flavour.
If only systemd could match Artix openrc on ram usage both arch based, Its creeping up on every systemd update.

4 Likes

It is, its very simple and fast installer :wink:

Can you explain? I can add whatever is needed in the next ISO. I don't use bluetooth and audio was fine for me and other testers.

I'd never recommend installing more than 1 DE on any install.

Thank you :wink:

A post was split to a new topic: bear wallpaper

Its just sudo systemctl enable bluetooth reboot , if you want it right away
sudo systemctl start bluetooth and install pulseaudio-bluetooth nothing much then bluetooth works fine well here it does anyway.

No what I mean the hard work is done so for example you can install mate remove the existing.
And to be honest I only installed deep-plasma to satisfy curiosity i'm a Arch user since 2005 I just love to see what other can do with Arch.

Thanks for that, I never added the systemctl enable bluetooth to the iso, I like to keep services to a minimal , so I'll leave it as is :wink: not everybody has bluetooth.

Oh I see,
Yeah I made it because I like the deepin desktop but as you know, deepin is getting very buggy of late, I also have an archdeepin with the same installer, but I don't think I'll be releasing another ISO until its got its act together :frowning:

Thanks for trying it, let me know how it goes :wink:

Forum kindly sponsored by