Deepin Manjaro Community Edition Issues in Asus ROG GL504GS laptop

Hey i'm a newbie who switched to linux two weeks back and i'm facing some issues.

The manjaro community is great and i've already got some help with some of my problems, but i'm facing some other problems so i'm creating this thread to keep updated on my problems and maybe it will be helpful for others who are facing similar problems on Rog laptops :slight_smile: .

First of all my system configuration :

System:
  Host: bala-pc Kernel: 5.0.5-1-MANJARO x86_64 bits: 64 
  Desktop: Deepin 15.9.3 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: Strix GL504GS_GL504GS v: 1.0 
  serial: <root required> 
  Mobo: ASUSTeK model: GL504GS v: 1.0 serial: <root required> 
  UEFI: American Megatrends v: GL504GS.305 date: 10/12/2018 
Battery:
  ID-1: BAT0 charge: 62.9 Wh condition: 62.9/66.0 Wh (95%) 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  L2 cache: 9216 KiB 
  Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 801 6: 800 7: 801 8: 800 9: 800 10: 800 11: 800 12: 800 
Graphics:
  Device-1: NVIDIA GP104M [GeForce GTX 1070 Mobile] driver: nvidia v: 418.43 
  Display: x11 server: X.Org 1.20.4 driver: nvidia 
  resolution: 1920x1080~144Hz 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
  Sound Server: ALSA v: k5.0.5-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  IF: wlo1 state: up mac: 64:5d:86:2a:fd:28 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 
  IF: eno2 state: down mac: 04:92:26:08:01:bb 
  IF-ID-1: anbox0 state: down mac: 1a:a5:d1:e5:8d:d4 
Drives:
  Local Storage: total: 1.34 TiB used: 153.56 GiB (11.2%) 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: THNSN5512GPU7 size: 476.94 GiB 
  ID-2: /dev/sda vendor: A-Data model: SU650 size: 894.25 GiB 
Partition:
  ID-1: / size: 468.16 GiB used: 153.49 GiB (32.8%) fs: ext4 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nvidia temp: 44 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 317 Uptime: 20h 59m Memory: 31.34 GiB used: 3.27 GiB (10.4%) 
  Shell: bash inxi: 3.0.32 

Fixed :

  1. Paste option disabled on second drive - Here

  2. Lutris not working - Here

  3. My external HDD is not detecting - re- installing manjaro solved the problem, guess i screwed up something when i was changing some settings for keyboard back-light.

  4. One of my usb is not working - Seems to be a issue of the mouse receiver i was using.

Not Fixed :

  1. Keyboard back-light not working : Here (Not solved)

Any help would be much appreciated, thanks in advance :smile:

Form Manjaro Live or the install you have, via terminal:
lsusb
and
lspci -nn

Here are the outputs

lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 13d3:56a2 IMC Networks 
Bus 001 Device 010: ID 04ca:00ac Lite-On Technology Corp. 
Bus 001 Device 005: ID 8087:0aaa Intel Corp. 
Bus 001 Device 004: ID 0b05:1866 ASUSTek Computer, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers [8086:3ec4] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) [8086:1901] (rev 07)
00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 07)
00:08.0 System peripheral [0880]: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model [8086:1911]
00:12.0 Signal processing controller [1180]: Intel Corporation Cannon Lake PCH Thermal Controller [8086:a379] (rev 10)
00:14.0 USB controller [0c03]: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller [8086:a36d] (rev 10)
00:14.2 RAM memory [0500]: Intel Corporation Cannon Lake PCH Shared SRAM [8086:a36f] (rev 10)
00:14.3 Network controller [0280]: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:a370] (rev 10)
00:14.5 SD Host controller [0805]: Intel Corporation Device [8086:a375] (rev 10)
00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller [8086:a368] (rev 10)
00:15.1 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller [8086:a369] (rev 10)
00:16.0 Communication controller [0780]: Intel Corporation Cannon Lake PCH HECI Controller [8086:a360] (rev 10)
00:17.0 SATA controller [0106]: Intel Corporation Cannon Lake Mobile PCH SATA AHCI Controller [8086:a353] (rev 10)
00:1d.0 PCI bridge [0604]: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 [8086:a330] (rev f0)
00:1d.6 PCI bridge [0604]: Intel Corporation Cannon Lake PCH PCI Express Root Port #15 [8086:a336] (rev f0)
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:a30d] (rev 10)
00:1f.3 Audio device [0403]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)
00:1f.4 SMBus [0c05]: Intel Corporation Cannon Lake PCH SMBus Controller [8086:a323] (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller [8086:a324] (rev 10)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP104M [GeForce GTX 1070 Mobile] [10de:1ba1] (rev a1)
02:00.0 Non-Volatile memory controller [0108]: Toshiba America Info Systems NVMe Controller [1179:010f] (rev 01)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)

P.S: I have my external HDD which is not detecting connected right now.

I had some readings and somehow it seems you could try using iommu=soft as kernel boot parameter.

how do i do that?

So, you want me to move your post to #newbies :slight_smile:
From Grub Boot menu press e and add iommu=soft right after quiet (use space between), then press F10 to save and continue booting.
If that helps you add it to /etc/default/grub to the
GRUB_CMDLINE_LINUX_DEFAULT line and then you update grub from terminal:
sudo update-grub

1 Like

Yes please

I have only Manjaro on my laptop, so i don't get a grub boot menu, just ROG logo then deepin lock screen immediately.

Press Esc or Shift right after the Rog logo ... so the grub menu will show.

Moved from #technical-issues-and-assistance to #newbies as requires more assistance

IMG_20190414_133220

There is no quiet in the parameters and if I add the command anywhere else I get the error command iommu not found. Press any key to continue.

image

make sure you go with the cursor to that quiet and after press space and add the iommu=soft

1 Like

Sorry about that, tried it. Nothing happens.

I think it made my second internal SSD not mount. Now it says needs cleaning.

Ok, i'll step back from this, as it seems you added the iommu in the wrong place and i don't need to feel guilty for

Cheers!

i added it after quiet only, did nothing.

Anyways i fixed my secondary ssd mounting by opening gparted and executing check.

For me is not conclusive what you did ... if you say that iommu had no effect ... possible, but i would have asked you to plug that external USB HDD to every USB connector and check.

Tried in all the ports. Not working.

Ok, then let's try something else. Provide from terminal the output for:
cat /sys/module/usbcore/parameters/autosuspend

The output is 2

Change it to -1 by editing that file. Reboot after that and report back. I prefer to use nano, so:
sudo nano /sys/module/usbcore/parameters/autosuspend
then Ctrl+O to write and Ctrl+X to exit

Also provide the:
lsmod | grep hci

Did it, here is the output

ahci                   40960  1
libahci                40960  1 ahci
libata                282624  2 libahci,ahci
sdhci_pci              49152  0
cqhci                  32768  1 sdhci_pci
xhci_pci               20480  0
sdhci                  65536  1 sdhci_pci
xhci_hcd              262144  1 xhci_pci
mmc_core              176128  3 sdhci,cqhci,sdhci_pci

did the -1 changed something ?

Forum kindly sponsored by