deepin / openbox / gnome - Lenovo IdeaPad 520-15ikb installation problems

Hello all!

I have used manjaro openbox successfully in the past and fell in love with it. At one recent point, a few months ago, I upgraded my laptop ssd to a bigger one and had to naturally reinstall. I did a dual boot setup with windows 10 at the time (the other os was manjaro openbox, again) and all worked well. At a later point I decided to go full linux and try one of the other flavors. I decided for deepin and proceeded to install it.

Deepin:
Surprise surprise...first issue I discovered was that I could not connect to my own wi-fi network, with the correct password, of course, both during the installer and after. One other notable issue with this flavour was that, upon shutdown / restart / anything, the system would just hang.

i3:
After deepin I tried i3. No notable issues here, I just decided it was too advanced for me and went on to...

Gnome:
I installed the gnome flavour and with this one, just like for deepin, I could not connect to wi-fi with the correct password. Shutdown / restart made my machine freeze. Another notable issue was that either touchpad or keyboard, or both, would stop functioning at an apparent random point after system start (not always though), rendering the system unusable. I did a full sys upgrade and still no success.

Openbox:
It appears I might have some luck with this flavour. I just installed it and it seems to be working for now.

What could be the reasons for these issues that I am having? Lack of compatibility with my laptop model? Are the distros the problem? Did I not burn the ISOs correctly?

Thankls!

Hello,

Most of the know issues are addressed here for that model
https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_W520
Following those fixes is a must.

Regarding the DE's/WM's - each might or not require some custom settings to work properly.

1 Like

This is indeed a mystery.

Manjaro ISO is build from the same foundation. What makes the difference is the packages chosen for the desktop.

I was once a Gnome user but due to the constant complications I decided to go Window Manager. Openbox has always been attracting me but due to lack of time a never really did configure it to it's full extend.

It took me almost a year customizing my Openbox and when I was almost finished it got released as the Manjaro Openbox and got perfected using the response from the forum.

This following is purely guessing
Openbox is not a desktop environment but a Window Manager which makes it more low-level than a complete desktop environment. This should be understood as there is fewer connections between the Linux kernel and GNU system. The more connections the more things can go wrong.

This does not explain why the network is not working when using deepin or gnome as drivers is mostly included in the kernel.

Which WiFi

inxi -nxxx
2 Likes

I decided to go Openbox as well. Though I have not tried wifi yet, shutdown / restart still make the laptop freeze and manual shutdown is required. Is there a shutdown log somewhere that I could have a look at?

Thanks!

I don't know - after a reboot where the shutdown was hung - you could try

journalctl -xe --system

I have had Manjaro running on a several Lenovo systems with no issues - so maybe it is specific to your system.

  • ThinkPad Z60t (current)
  • ThinkPad T400 (recycled)
  • ThinkPad T410s (with dock) (recycled)
  • ThinkPad T420s (with dock) (recycled)
  • ThinkStation E32 (current)
  • ThinkPad T550 (current)
  • Miix 700 (current)

@bogdancovaciu
The W series is as I remember workstation class so the reference to the W520 is not usable it is not the same as IdeaPad 520 - completely different system.

I really don't see how this is of any help.
I boot UEFI GPT no problem.
There is no pci express power management option in the BIOS.
I use discreet graphics only.
Touchpad does work out of the box under Gnome, as I already pointed out, but it, for some unknown reason, becomes unfunctional (not all the times).
Basically none of my problems are addressed there.

I am inclined to think there is a problem with the distributions themselves, or the compatibility between them and my laptop.

Cheers!

Just as I was full of hope that openbox would work as well, touchpad stopped working on this installation as well.
All I found in journalctl were some errors relating to:

  • nouveau
  • i2c_designware - controller timed out (a bounch of those).

Another thing worth pointing out: system appears to be in hyperdrive. I am at 56 deg (for no reason), 3+ cores at 100%, fans are on overdrive and the whole system lags (tried opening chromium and am still waiting, switching workspaces is very very laggy).
I did not have these problems with previous manjaro version. I think it was 17.xx or something, where openbox had drun or rofi instead of synaptics (which is ugly as hell btw)

Rofi is standard AltF2 - and I think you refer to synapse a search/launcher utility CtrlSpace - I don't use myself but forgot to remove :slight_smile:

The first Openbox release was early 2018 so it could have been labeled 17.x.

nouveau points to a system with both nvidia and intel - is that correct? My current T550 has dual graphics as well.

I have set it up to run on the nvidia using the optimus-manager howto here

For your touchpad - the Openbox edition does not install the synaptics driver but libinput. Though the synaptics driver is no longer maintained you may have better luck with the that.

sudo pacman -Syu xf86-input-synaptics

You may also need to reconfigure the tap to click in /etc/X11/xorg.conf.d/50-touchpad.conf (Openbox Edition)

I can't guess what it may or may not be - I am sorry I cannot be of more help.

What I do know it that some Lenovo systems works without hickups and some don't. The pattern I think I have spotted is that the consumer oriented systems tends to have more issues than the business oriented systems but that is only a general observation as some of the T-series systems can be difficult as well - mostly later systems such as T450 and T460.

I can't possibly know all the models :slight_smile: and for sure i have no ability to know better than the OP the model that sits on their desk, nor if a linux distribution will work on it or not.
Cheers!

1 Like

Indeed. But you do have google. And I thought one of the purposes of any distribution, especially one with a large community behind it, would be to work on most systems. At least the newer ones.

Not even Fedora and Ubuntu work on all systems by default, and both have a huge "army" behind them compared to Manjaro. Yes, Manjaro has a great community and we all can use google, but this, as one of the search results, is not that helpful either
https://bbs.archlinux.org/viewtopic.php?pid=1813700#p1813700
because it states that on same model

If Arch Linux works, then Manjaro should work too.

If that were true :raised_hand: - but truth is - most systems require tweaking one way or another.

1 Like

I understand. I was not expecting this to be so much of a hassle now, I thought hardware producers somehow evolved or whatnot.
The thing is, I'm not that able to tweak my system with it running in full throttle without a reason.
And another thing worth mentioning is that openbox worked (not sure about the touchpad) in the earlier version. Either something happened with the distro or my laptop in the meanwhile.

Could this be a hardware problem with my laptop? What do you guys think? I am going to try some other distros as well as I really don't have the knowledge necessary yet to tweak the system.

On a rolling release distro packages change a lot: from kernel to systemd and what not. I don't think there is a hardware issue that would not manifest on another OS ... Is all i can "speculate" without jumping the gun.

Manjaro is ever evolving so yes that has changed. For the time being Manjaro ships with the LTS 4.19 kernel.

For your laptop - how old is it? and can you post the output from

 inxi -Fxxxc0

Please fence the pasted output with the </> from the post toolbar.

As I understand your replies - it seems that the touchpad is working and then - seemingly out of the blue it does not.

First.
I have had that exact same wifi issue in cause by ME! NETGEAR M1 nighthawk had options for different wifi protocols or something. When OS booted i couldnt see the netgear but my phone could. wrong setting in router. I can't find charger at the moment but will edit this when I do.

The Class of wifi was incompatible. I changed settings. Not Problem since.
Best performance and stability sacrifice battery. Not Optimus. Not TLP.
Your card is optimus not switchable not integrated BUT it has as integrated intel chip.
Optimus is auto. Optimus has different Hardware.
Optimus Software can handle both optimus and switchable.
Re: nVidia OPTIMUS whitepaper.

Tech Specs

Ideapad 520 (15)

Processor 7th Gen IntelĀ® Coreā„¢ i7-7500U Processor (4 MB Cache, 2.7 GHz, 3.5 GHz max)
Operating System
Display 15.6" FHD (1920 x 1080) IPS, anti-glare
Multi-Touch None

Advanced Graphics with NVIDIA. Lenovo website

"The IdeaPad 520 offers advanced graphics performance, with up to NVIDIA GeForce 940MX. A dedicated graphics card relies on its own processor, accelerating graphics performance by more than 3 times."
Download parted magic and use disk erase to shred your drives. only first 10gig.
Are you using NVMe.M.2 OS HD and Hybrid media would CRUSH!.
Manjaro-kde is nvidia No.1 see. phoronix.com
SSD + 8gig RAM? no swap
|Graphics|{??Intel HD graphics in processor??no!] and NVIDIAĀ® GeForceĀ® 940MX, 4GB memory|
True but it is Optimus hardware not Switchable.
|Memory|16GB, 2133MHz DDR4, 1 x 260-pin SO-DIMM socket|
|Webcam|HD 720P with array mic|
|Storage devices|* HDD: 2.5", 5400 rpm, 7mm high

  • SSD: 2.5", M.2 PCIE|
    |Optical drive|DVD Recordable, tray-in|
    |Dimensions (W x D x H)|378 x 260 x 22.9 mm|
    |Weight|Starting at 2.2 kg|
    |Case colour|Iron Grey|
    |Battery|2-cell Li-Polymer (30Wh), integrated|
    |Battery life1|Up to 5 hours|
    |AC adaptor|65W|
    |Keyboard|6-row, multimedia Fn keys, backlit, numeric keypad|
    |Touchpad|One-piece touchpad|
    |Fingerprint reader|Yes|
    |Audio|HD Audio, stereo speakers with HarmanĀ® Certification, 2W x 2 / array microphone, combo audio / microphone jack|
    |Ethernet|10/1000M|
    |Wireless LAN|11ac, 1x1, Wi-Fi + Bluetooth 4.1 combo adapter|
    |Wireless WAN|None|
    |NFC|None|
    |Ports|* 2 x USB 3.0
  • 1 x USB Type-C
  • 1 x HDMI
  • 1 x Ethernet (RJ-45)
  • 4-in-1 Card Reader (MMC, SD, SDHC, SDXC)
  • 1 x Audio combo jack|

That may explain the heavy cpu usage - it is all piped through the CPU.

And it also explains why I had no issues with my T550 - it is switchable.

This kills me...
I have Asus FX503vm / nVidia gtx 1060m Laptop. No one believes its Linux when gaming. No heat issues. battery is sweet if is needed. TLP nearly burnt the CPU/GPU out of the MotherBoard! I aint saying shes malware but she ait messin with no ###. TLP is terrible for nVidia. It gets installed on desktops as well.
Absolutely must install nVidia at OS install. Disable all that intel protection SH#T for install.
intel-DAP intel-NX intel-sct (not smart connect the other one. / security control ).
I installed LTS low latency. I appreciate its geared for audio but its made no bad effects.
kDE has 3 search engines. After install indexes the new System. Thats why its a pig. After indexing is fine. or disable after indexing. run like off access antivirus. some disable kwin compositor. but that is now fully nVidia proprietary egl with wayland supported as of 5.16 in mid june. I installed kwin triple buffer fix(github/arch). super simple and have kwin tiling (Github)script on desktop. its in github. i3 tiling but kde!!!
Also openbox fits native to kde if thats yr thang. Theres a little kickstart script if you search " Are you a Manjaro Noob? I've posted the full version on reddit.
Dont sudo nvidia setting. normal user is fine.AND DONT CREATE XORG.CONF just make changes in nvidia setting a save to nvidia.rc profife down the bottom.[it isnt ideal ]
Manjaro Devs work magic!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by