Deepin terminal cannot change background transparency

After update the newest deepin desktop i found that my deepin terminal cannot change backgroud to transparency, my deepin desktop version is 15.11 and my terminal version is 5.0.0

If you are using Kwin WM you will need to install systemsettings.
You may also find this thread helpful:

systemsettings isn't needed for transparency to work.

image

As always @oberon you are correct. However there are the following conditions currently.

After updating:

  1. Transparency on mutter is broken / not present (slider is gone) requiring the user to install deepin-kwin.
  2. deepin-kwin breaks transparency in the menu and device center (settings) It renders the background with a grainy texture requiring the user to install systemsettings and adjusting the blur settings. I am not at my machine right now to get the specifics.
  3. deepin-kwin-dev also breaks transparency needing systemsettings to correct however the settings only apply to the settings menu and the application menu remains grainy.

This may have changed over the past few days so correct me if I am mistaken and I apologize in advance if that is indeed the case.

edit: I believe the grainyness was present in the terminal background as well in kwin and broken in mutter. I will be reinstalling tonight and I will check again and report back tonight.

I believe @ant still uses mutter.

what version of deepin-wm is Manjaro using ?

deepin-wm 1.9.38-3 fixes them issues

the trouble is though, everybody installed deepin-kwin-dev to get the effects back.

I created a file in autostart with deepin-wm --replaceinstead of uninstalling deepin-kwin, I wasn't sure if it break something.

It doesn't always the latest unstable ISO uses Kwin. The Iso before that used deepin-wm.
And I apologize @oberon I should have said deepin-wm as opposed to mutter.
That is why I asked if the OP was using Kwin. If not the current work around is to install deepin-kwin which after updating breaks transparency so the OP would then need to install systemsettings to make adjustments. like i said I'll do a fresh metal install tonight and post back in the iso thread.

deepin-wm Is installed it just doesn't use it, deepin-kwin-dev over rides deepin-wm that's why I did the deepin-wm --replace file

also if you are using deepin-kwin-dev you have to enable blur by adding it manually to kwinrc file or using systemsettings, deepin-kwin-dev has very few settings in its kwinrc file.

keep us posted :wink:

2 Likes

Thank you for sharing your insight! :sunglasses:
Manjaro deepin-wm version is still pkgrel 1 but we are about to sync with Archlinux.

1 Like

anytime :wink:

what is/was the idea behind creating deepin-kwin-dev and not using deepin-kwin ?

Both are available on Manjaro. The idea with deepin-kwin-dev is to update the package whenever there will be upstream commits, so we can test the latest version and not have to wait until Arch decides to package it, since Felix has decided to freeze at 0.1.0 for now.
deepin-kwin package should still be the default.

edit: Maybe it will be better to call it deepin-kwin-git. I just decided to use -dev since actually their latest commit is realease tag 5.0.0 - strangely, no commits since July 30 ... :wink: :thinking:

Interesting they fix the deepin-wm but don't update the deepin-kwin :thinking:

I assumed Manjaro-deepin was using deepin-kwin-dev but yeah its using default deepin-kwin

Might want to add a custom kwinrc file to the ISO for Manjaro-deepin or include systemsettings that's assuming your going to be doing another ISO :rofl:

Let us know and we will give you some feedback :wink:

I guess this answers that:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by