Deleted Ubuntu Partition. How to fix grub?

So... i had 3 partitions: Windows 8.1, Ubuntu 16.04, and Manjaro (13 community edition). Via the windows partition app, i deleted the Ubuntu partition. Then when trying to boot up the PC i get a

"Error: Partition not found.
Entering Grub Rescue"
Upon trying to boot up an Manjaro ISO file, i am greeted by a black screen with and


Cant type in it or do anything.

Please any help appreciated

Explain, how did you try to boot up the iso file?
Can you boot up Manjaro install media?

That happens to me when I didn't select dd in rufus to put the Manjaro ISO on a USB stick.

yep, just did DD and it worked... but what next (rn im in the live media)

I got the live media up, i had to use DD not ISO mode when using rufus. But im at a lost for whats next


I have followed the following link up to
"Sudo pacman -S mtools os-prober"

mtools couldnt install and os-prober was already installed

Next i tried
"grub-install /dev/sda"
When i run that command i get "grub-install: error: cannot find EFI directory"

(In the command i changed the "sda" to all sda listed (1-5))

Please provide lsblk

loop0 7:0 0 63.3M 1 loop
loop1 7:1 0 259.5M 1 loop
loop2 7:2 0 900.9M 1 loop
loop3 7:3 0 414.6M 1 loop
sda 8:0 0 465.8G 0 disk
├─sda1 8:1 0 300M 0 part
├─sda2 8:2 0 100M 0 part
├─sda3 8:3 0 128M 0 part
├─sda4 8:4 0 134.7G 0 part
└─sda5 8:5 0 128.5G 0 part /
sdb 8:16 1 14.6G 0 disk
├─sdb1 8:17 1 1.7G 0 part
└─sdb2 8:18 1 4M 0 part

So it looks like sda1 is windows recovery, sda2 is your EFI, sda3 (?), sda4 windows partition, sda5 manjaro.

Unfortunately, I don't use grub for Manjaro, I use rEFInd, so I can't help here. Hopefully someone else can chime in. You need to reinstall grub then update grub. Not experienced in that personally.

Else, you can back up files then delete your manjaro partition and reinstall via the live iso.

Tip: use ``` to make your terminal outputs more readable

Do u have any idea how i can access manjaro in the meantime?

Take a look at here: Using livecd v17.0.1 as grub to boot OS with broken bootloader

1 Like

I second that. LiveCD and manjaro-chroot is like a magic wand if used correctly. Although it can also be like a bulldozer to sensitive foundations. Read up first.

1 Like

And make a system backup first before make a change to system

Thanks guys, I was more asking realmain because he said he couldn't help with the grub install. Do any of you guys have a solution to the real issue ATM "grub-install error. Can't find efi directory"

Most likely you booted up live media in uefi when your system is bios-legacy.

If you still cannot solve it, boot up live media and at terminal, provide output of

sudo parted -l
sudo blkid
test -d /sys/firmware/efi && echo UEFI || echo BIOS

Also use file manager of livecd and at installed Manjaro OS partition provide contents of

ps : Happy Vasaki

Alright, nothing worked so I backed up some config files and reinstalled manjaro. Thanks for your help guys but I needed my laptop and couldn't send another all-nighter trying to solve the issue

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by