[Dell XPS 15 9560] Freezing when selecting to reboot/shutdown

I have just installed Manjaro KDE through Manjaro Architect. I have a Dell XPS 15 9560 and a dual-boot setup with Windows 10 using rEFInd as my bootloader. Everything seems to be working fine, but when I choose to reboot or shutdown Manjaro, the whole laptop freezes a second later and I have to hold down the power button to shut it down. The same thing happened when I had Antergos installed a couple of days ago, so I am led to believe it is some sort of hardware issue with my laptop.

The issue persists with sudo reboot.

Also, F1 - F7 do not seem to be working at all, but F8 - F12 do. F1, F2 and F3 are my function keys to mute, increase and decrease volume - all of which don't do anything, but the F8 - F12 function keys to extend the display, toggle the backlight of the keyboard and increase/decrease brightness all worked fine immediately after installation. Even when I manually set the volume control keybindings in KDE's settings, they do not work.

I am unsure if these two issue are linked, but the power button works by bringing up the suspend, reboot and shutdown screen when I press it once.

Any ideas would be much appreciated.


I have got the volume keys working - I just needed to run pulseaudio on start up.

Still having the reboot/shutdown issue though.

Most people have to combine a FN key with those F Keys to get those functions to work. You failed to mention that, so I'm left wondering if your setup has been customized somehow.

To get a better ides why it locks up on reboot, LOGOUT of KDE.
When you see the login prompt, press Ctrl-Alt-F2.
Then login by typing name and password.
Then type sudo systemctl reboot

Now you can watch the process and see how far it gets.

If you see "waiting for a stop job" just wait it out for a while - 5 minutes of so. (write down what the stop job was waiting for if it tells you).

You can also usually see something after you re-boot by typing into a console:

journalctl -b 1 -e

`then read backward looking for any thing that jumps out at you.

1 Like

Thank you for the suggestions.

I got the F keys working - well they were working all along, just my audio devices weren't recognised until I ran Pulse Audio.

I will try Ctrl+Alt+F2 soon, however the whole system freezes up within less than a second of selecting reboot/shutdown, before the screen even fades to black, so I don't think it will even get to the point that it shows any printed output. I will let you know.

The journalctl suggestion will at least show any errors logged when you invoked shutdown / reboot.

Does the same thing happen on logout?

The Ctrl+Alt+F2 suggestion is also valid as from tty2 your shutdown will be separate from your graphical environment (ie X and KDE). If it shuts down / reboots successfully from tty2 cli with no errors then you know it is a graphical environment / KDE issue. Also as @jsamyth said, all generated messages will be accessible, including what works and errors.

Also, the fact you were not able to boot into the latest KDE ISO with your hardware, and had to install from manjaro-architect, is another indicator that your issue may be graphics driver related.

inxi -Fx
mhwd -li
1 Like

@jsamyth @sueridgepipe

I can't even log out of KDE. Same issue where my whole laptop freezes as within a few short moments after selecting to logout.

Interestingly, in KDE's System Settings, anytime I try to go into the "Hardware Configuration" section, the whole application freezes and says "Not responding". Then a window pops up asking to force close the application, or to wait longer. Even if I select to force close, it remains open and completely frozen. The only way to close it is a forced shutdown again.

What about the other info and other suggestions?

Sorry, I didn't have much time. I will try them when I am home later.

As a side thought, one of the suggestions is to use journalctl. I chose to install openrc in Manjaro Architect as opposed to systemd when following a Manjaro Architect installation turorial. Could this be an issue?

It's only one of the most important things to mention. OpenRC does things very differently to systemd.

Could be. Can you give us the output of this command?

rc-status -a

You may or not need sudo in it....

Sorry about that. Would you recommend one over the other? As I only installed yesterday and don't have much set up yet, I would have no problem doing a completely fresh install with systemd instead.

You can use either - it's just useful to know these things when reporting an issue (similar to your running kernel, graphics driver, and DE).

1 Like

I use OpenRC, but systemd is the standard and used much more widely (and so has more support). Unless you have some reason for not using systemd, I'd suggest using it. Especially if you're a newer user. Much of the system and many applications are built to use systemd these days, so it takes extra effort to make them work with OpenRC.


Kernel is 4.11.7-1. Would you recommend using a newer one as well - any specific release you could recommend? I just chose that one as it was what was used in the tutorials, but I don't even know when that tutorial was dated from.

I think I am going to do a completely fresh install as I have already learnt plenty more in the last 24 hours.

The only issue I am now unsure when reinstalling is the fact that I already have rEFInd installed. Will this remain installed if I wipe my Manjaro root partition, and then when I reinstall I just mount the same Windows EFI partition as /boot/efi and choose to install no bootloader, and then rEFInd will recognise my fresh Manjaro install?

rc-status -a                                                                                                 
Runlevel: nonetwork
 local                                                                                                 [  started  ]
Runlevel: sysinit
 sysfs                                                                                                 [  started  ]
 devfs                                                                                                 [  started  ]
 udev                                                                                                  [  started  ]
 dmesg                                                                                                 [  started  ]
 kmod-static-nodes                                                                                     [  started  ]
 udev-trigger                                                                                          [  started  ]
Runlevel: default
 dbus                                                                                                  [  started  ]
 elogind                                                                                               [  started  ]
 NetworkManager                                                                                        [  started  ]
 acpid                                                                                                 [  started  ]
 cronie                                                                                                [  started  ]
 netmount                                                                                              [  started  ]
 xdm                                                                                                   [  started  ]
 local                                                                                                 [  started  ]
Runlevel: boot
 hwclock                                                                                               [  started  ]
 modules                                                                                               [  started  ]
 fsck                                                                                                  [  started  ]
 root                                                                                                  [  started  ]
 mtab                                                                                                  [  started  ]
 swap                                                                                                  [  started  ]
 localmount                                                                                            [  started  ]
 procfs                                                                                                [  started  ]
 binfmt                                                                                                [  started  ]
 sysctl                                                                                                [  started  ]
 bootmisc                                                                                              [  started  ]
 termencoding                                                                                          [  started  ]
 keymaps                                                                                               [  started  ]
 loopback                                                                                              [  started  ]
 net.lo                                                                                                [  started  ]
 consolefont                                                                                           [  started  ]
 hostname                                                                                              [  started  ]
 urandom                                                                                               [  started  ]
Runlevel: shutdown
 killprocs                                                                                             [  stopped  ]
 savecache                                                                                             [  stopped  ]
 mount-ro                                                                                              [  stopped  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 modules-load                                                                                          [  started  ]
 xdm-setup                                                                                             [  started  ]

I don't know which tutorials you were following, but I'd tend to rely on what's on the forum rather than a third-party site.

It actually was on this site, that's why I was happy to trust it. I think I am going to do a full reinstall anyway, with systemd and a few other changes. I'll post an update when I've done so, but I had the same shutdown/reboot issue on Antergos, so I'm inclined to think it's more of an issue with my specific hardware (emphasised by the "Hardware Configuration" section of the settings app crashing whenever I try to open it).

Surprisingly Windows-esc. Not sure I've seen that exact sequence in Linux.
It sounds like it is trying to pop-up a dialog box asking for a password or confirmation of your intent to log out, but that part is failing so it just sits there.

This might be a problem with sddm or lightdm or what ever you ended up with as the DM (login screen thingie) on your install.

Having read the rest of the thread, I suggest you do as you mentioned and re-install into that same partition (using systemd) for your first go.

Side Note: The others (above) try to be neutral about systemd/OpernRC, but OpenRC's sole raison d'etre is political animosity and hide bound resistance to change. One of the principal designers of systemd had all the personality of a cactus in an outhouse, and ruffled a lot of feathers, kicked over sand castles, tortured kittens, pulled the wings from butterflies.

I disliked systemd at first, (because I had to relearn stuff), but undomesticated equines could not drag me back to OpenRC these days. Unless you are deeply familiar with OpenRC there is no earthly reason to start a new system using it.

1 Like

Thank you for the advice and explanation.

Just before I do the fresh install, could you advise me at on how to do so, while already having rEFInd installed, as I mentioned a couple of replies up? Thank you.

I couldn't, because I don't use rEFInd. There are a few threads here on the forum that mention it and some folks that seem knowledgeable about it.

Forum kindly sponsored by