Dependency error when trying to install / update packages

Hey.

I have some dependency issues with the nvidia-utils update that hinders me from installing anything via pacman at all. Everything i try returns this error:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux420-nvidia

I've tried updating with sudo pacman -Syyuu.
As far as i know, the 4.20 kernel is not supported any more and the error is probably because of that, but for some reason I'm unable to install a new kernel since it gives me the same error as everything else I've tried. Any idea what i'm doing that's wrong?

inxi -Fxxxz output.

System:    Host: kmanj Kernel: 4.20.17-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: i3 4.16.1 info: i3bar 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: Z87 Professional serial: <filter> BIOS: American Megatrends v: P1.90 
           date: 07/18/2014 
CPU:       Topology: Quad Core model: Intel Core i7-4770K bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 56022 
           Speed: 1242 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 1200 2: 1200 3: 1200 4: 1200 5: 1201 6: 1202 7: 1202 
           8: 1201 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Gigabyte driver: nvidia v: 430.14 bus ID: 01:00.0 
           chip ID: 10de:13c2 
           Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: compton resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 430.14 direct render: Yes 
Audio:     Device-1: NVIDIA GM204 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fbb 
           Device-2: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK Virtuoso 100 driver: snd_virtuoso v: kernel 
           bus ID: 08:01.0 chip ID: 13f6:8788 
           Device-3: Yamaha type: USB driver: snd-usb-audio bus ID: 2-13.1:6 chip ID: 0499:170f 
           Sound Server: ALSA v: k4.20.17-1-MANJARO 
Network:   Device-1: Intel Ethernet I217-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0 
           chip ID: 8086:153b 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: 5.4.0-k port: c000 bus ID: 05:00.0 
           chip ID: 8086:1539 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.94 TiB used: 226.80 GiB (11.4%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> rev: 2B6Q 
           scheme: MBR 
           ID-2: /dev/sdb vendor: Samsung model: SSD 830 Series size: 119.24 GiB speed: 6.0 Gb/s serial: <filter> rev: 3B1Q 
           scheme: MBR 
           ID-3: /dev/sdc vendor: Western Digital model: WD1002FAEX-00Z3A0 size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 1D05 scheme: GPT 
Partition: ID-1: / size: 101.07 GiB used: 8.90 GiB (8.8%) fs: ext4 dev: /dev/sdb1 
           ID-2: swap-1 size: 16.05 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 31.0 C mobo: N/A gpu: nvidia temp: 38 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 50% 
Info:      Processes: 211 Uptime: 9m Memory: 15.60 GiB used: 1.81 GiB (11.6%) Init: systemd v: 242 Compilers: gcc: 9.1.0 

Hey!
Well i think it's exactly because 4.20 is at end of life. :upside_down_face:

Must have done it through pacman / pamac? It's not a good idea.

You should update your Kernel via one of 2 methods:

  1. Manjaro Settings Manager - Kernel
    Just click install to the right of desired Kernel, then reboot and check if you have new kernel and there are no errors.
    Then you can remove old Kernel in same manager.

  2. mhwd, example:

sudo mhwd-kernel -i linux51

More info in wiki

Thanks for your help!

I sadly do not have the Manjaro settings manager installed since it doesn't come with i3 when you install via architect, never had the need of it before.

The mhwd command gives roughly the same error output as doing it via pacman. I've also tried to remove the 4.20 kernel with the rmc command, but to no avail.

: : Synchronizing package databases...
 core                                                                                                  149.0 KiB  1307K/s 00:00 [#############################################################################] 100%
 extra                                                                                                1758.0 KiB  8.06M/s 00:00 [#############################################################################] 100%
 community                                                                                               5.3 MiB  12.2M/s 00:00 [#############################################################################] 100%
 multilib                                                                                              183.2 KiB  25.6M/s 00:00 [#############################################################################] 100%
The following packages are out of date, please update your system first: nvidia-utils 
Do you want to continue anyway? [y/N] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux420-nvidia

Dummy me didn't check what kernel the latest stable one was when installing via architect, oh well.

Ok, well then try this:

  1. Remove Nvidia driver first
sudo mhwd -r pci video-nvidia
  1. Force sync repo and full update (just in case):
sudo pacman -Syyuu
  1. Install desired Kernel:
sudo mhwd-kernel -i linux51
  1. Install Nvidia driver:
sudo mhwd -a pci nonfree 0300

A word of caution:
Don't reboot unless you sure that you have at least one Kernel installed, and some video drivers :wink:
To check Kernels:

mhwd-kernel -li

To check video drivers:

mhwd -li -d

I think you should be good with those commands, if there are some more errors during the process - post them here :slight_smile:


And for the future, please check out announcements about EOL Kernels - it's usually a very good idea to update Kernel before making system update on EOL Kernel running :slight_smile:

2 Likes

See here

1 Like

Thank you!

Removing the nvidia drivers lets me install another kernel, so that works fine!
But installing the drivers again gives me the following error:

> Using config 'video-nvidia' for device: 0000:01:00.0 (0300:10de:13c2) Display controller nVidia Corporation GM204 [GeForce GTX 970]
> Installing video-nvidia...
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
error: target not found: linux420-nvidia
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
Error: pacman failed!
Error: script failed!

I managed to install the Manjaro Settings Manager afterwards too, but the same error occurs there. Is there some way for me to edit the script so it targets the current kernel?

@Xian
Hmm...That's weird.
Are you sure you have new Kernel installed?

Wonder why drivers still try to install linux420-nvidia then...
Please try to do what's in @masterfix's provided link, and then try to install nvidia Driver again.


Oh yeah, it's logical. Without reboot you effectively still running 4.20, so script assumes that it should do linux420-nvidia.

I'm not completely sure that you won't need TTY after this reboot, are you familiar with it?

Looks like this rn.

Currently running: 4.20.17-1-MANJARO (linux420)
The following kernels are installed in your system:
   * linux51

Running @masterfix commands seems to have solved the issue, outputs read this now:

Currently running: 4.20.17-1-MANJARO (linux420)
The following kernels are installed in your system:
   * linux51

and

   NAME:	video-nvidia
   ATTACHED:	PCI
   VERSION:	2018.08.09
   INFO:	Closed source NVIDIA drivers for linux.
   PRIORITY:	5
   FREEDRIVER:	false
   DEPENDS:	-
   CONFLICTS:	video-hybrid-intel-nvidia-bumblebee video-hybrid-intel-nvidia-390xx-bumblebee video-nvidia-304xx video-nvidia-340xx video-nvidia-390xx 
   CLASSIDS:	0300 0302 
   VENDORIDS:	10de 

So i guess i'm good to reboot now and everything should work? :smiley:

1 Like

Basically you now have new Kernel and it will be used after reboot, but on video drivers you can't be too sure in given circumstances...

I think there's still chance that you might not see graphical target after reboot and will need to log in to TTY, so you can run:

sudo mhwd -a pci nonfree 0300

from terminal and then reboot.


But in best scenario you'll just boot fine :slight_smile:

Tried to reboot and everything works fine.

Had to reconfigure my settings for the nvidia drivers so my screens are arranged correctly, but that's to be expected.

Thanks for all the help guys! :smiley:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by