Desktop does not load after install on laptop (GNOME & Xfce)

I installed Manjaro with the xfce and GNOME desktop multiple times, but without success.

I'm using a Clevo laptop, the P641HK model.

Installation steps:

  • Create bootable usb stick with Rufus on Windows 10. I select the latest Manjaro xfce iso and use DD image writing option.
  • I boot from the usb stick, the system loads into a live version of Manjaro xfce.
  • I proceed with the installation
  • Installation is succesful, I reboot my system into Manjaro
  • Login screen appears, fill in my credentials and login.
  • The desktop just shows a wallpaper and a (movable) cursor, nothing more. On GNOME it just shows a black screen.
  • From the login in screen, when pressing Ctrl+Alt+F2 (or F1-F6), the virtual console does not start, it just shows a black screen. So I can't read any logs etc.
  • I tried various other Manjaro versions and distros, such as Manjaro i3 and Antergos.

What could be the issue? I myself think it has to do with my Nvidia graphics card, but I'm not sure.
I can't make anything of the stuff that appears on my screen, and like I mentioned, I can't get to logs etc.

Some specs:
Model: Clevo P641HK (Laptop)
CPU: Intel i7-7700HQ
GPU: Intel HD Graphics 630 & Nvidia GTX 1050 Ti
Drives: Samsung 960 EVO 250 GB SSD & HGST 500 GB 7200 RPM HDD

I'm installing Manjaro on a 50 GB partition I've created on the 500 GB HDD.

Any support is appreciated. Tried searching for my issue, but didn't find much so far.

Thank you.

EDIT: this reply: Nvidia GTX1050 Ti driver problem solved it for me. It was, as expected, a graphics issue. Now I'm running Bumblebee without problems.
The steps I took to get a working Bumblebee setup:

  1. Add modprobe.blacklist=nouveau to kernel parameters in grub, otherwise xfce would freeze on startup.
  2. Added config files to blacklist nouveau on the system.
  3. Added acpi_osi=! acpi_osi='Windows 2009' to grub config, and regenerated that. This is mentioned on the Fedora docs site:
    Also see:
  4. Auto-installed proprietary driver from Manjaro settings.
  5. Added myself to Bumblebee group (sudo gpasswd -a bumblebee).
  6. Enabled Bumblebee service (systemctl enable bumblebeed.service).
  7. Reboot the system.
  8. Tested Bumblebee as told on the ArchWiki:

That is usually wherein the problem lies.

I don't have a dual-card machine but plenty of others here do.

Someone should be along shortly to help you. :smiley:

Welcome to Manjaro Linux! :smiley:


Yes I thought so, I'm almost sure that has to be the problem.
Thanks for your quick reply!

I have seen many, many posts similar to yours regarding dual-card machines. A forum search may yield you good you a little time getting up & running.


While at the login screen (lightdm) try to go to TTY and if successful check the logs and journal. If it fails, try editing Grub menu while booting and add 3 at the end of linux line. You should get straight to TTY .
Use wgetpaste to upload them.

inxi -SMGxxz
journalctl -b -p3
cat /var/log/Xorg.0.log
mhwd -li
cat /etc/X11/xorg.conf.d/*.conf

It wouldn't hurt to look for similar topics in the forum.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by