Desktop effects gone

As sometimes happens, I found myself forced to restart hard (by pressing the power down button for a long time); All because during an operation that I do not even remember, the system started working too hard (hard drive light always flashing and ram in filling); When I restart desktop effects no longer work and I can not get them running even with normal system restart; At the first reboot of the system I noticed some video anomalies (windows crossed and only partially open), disappeared at the next reboot; I can use everything as usual (changedesktop with either ctrl + f1 / f2 / f3 / etc or through the widget); I'm up to the updates and after the last I did not notice anything wrong and everything worked smoothly. That's all.

More info? Which desktop environment would be a start.........

You are right: Manjaro KDE Plasma 5.9.4, KDE frameworks 5.32.0, QT 5.8, kernel 4.9.22-1-manjaro, 64 bit, processore: 4x Intel core I3 4330 @ 3,50 MHz, ram 3,5 Gb; grafica Intel Hd 4600.

Press alt+shift+f12 - should toggle the compositor. Check:

Make sure it is turned on. Sometimes the effects crash and turn off.

1 Like

That shortcut does not works anymore in plasma; anyway i am sure that composito is on, but still does not works. Now if you want to switch off the effects you have to launch the command kquitapp5 plasmashell; for run it the command is kstart plasmashell; i created two keyboard shortcut, to get the job done; i think that some configuration file went corrupted, but i have no idea of which can be...

It works.

Thats strange. While Plasma is a user of KWin effects, its not a provider of them. Could it be that you're using compiz or anything like this?

Also please show us your:

qdbus org.kde.KWin /KWin supportInformation

I have 4 DEs installed and recently installed compiz. Should I disable every related WM to activate Compiz?

No, you should just use KWin on Plasma, because KWin is the only compositor that is supported by Plasma :wink:

1 Like

I would edit the desktop files and add:


Compiz works well only in Mate & XFCE AFAIK.............

And in other DEs? Mate, Xfce, Cinnamon
How to replace compiz with their WM?

Mate - compiz works as far as I know.
Cinnamon/Gnome/Budgie - do not work with compiz.
XFCE - add compiz --replace to start-up.

1 Like

Definitely works, tried and tested, shortcut is working.

On Mate:
System>Preferences>Look and Feel>CompizConfig Setting Manager
doesn't open.
But if I point the cursor to the left top corner, the screen shows 4 workspace that I think is compiz effect.
I installed Mate desktop on Xfce, so that I guess something is missing.

Cannot assist with Mate, do not use or have it installed.

Thanks!!! I signed up for this forum just to say thanks, lol :slight_smile:

1 Like

Forum kindly sponsored by