Desktop(Gnome) frequently get frozen few seconds and works again.

yeah it wasnt fun, but then again if it didnt happen i likely wouldnt of bothered getting so involved with learning about different optimus configurations like prime and also optimus-switch that i made recently thats been working great.

@leonard , please also post this:

cat /etc/default/grub | grep CMDLINE
cat /etc/modprobe.d/*.conf
cat /etc/modules-load.d/*.conf

They are simply the same as the should be after a fresh installation.

#cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

#cat /etc/modprobe.d/*.conf
blacklist nouveau
blacklist nvidiafb
blacklist rivafb
options nvidia_drm modeset = 1

#cat /etc/modules-load.d/*.conf
lp
ppdev
parport_pc

If this is important note that mine are a bit different - as I said, here too it used to freeze, then not at all, then just very rarely like 10 times a day randomly. So maybe there's something in my config that "fixes" it in a way....


cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=f115e065-b8a3-44d1-b6a5-e4ca4449cc78"
GRUB_CMDLINE_LINUX=""

cat /etc/modprobe.d/*.conf
# This file was added by the program 'hda-jack-retask'.
# If you want to revert the changes made by this program, you can simply erase this file and reboot your computer.
options snd-hda-intel patch=hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw
blacklist nouveau
blacklist nvidiafb
blacklist rivafb
options nvidia_drm modeset=1

cat /etc/modules-load.d/*.conf
vboxdrv
vboxnetadp
vboxnetflt
vboxpci
vboxdrv
vboxnetadp
vboxnetflt
vboxpci
vboxdrv
vboxnetadp
vboxnetflt
vboxpci
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
nvidia
nvidia-drm
# List of modules to load at boot
##
##loads necessary modules for nvidia gpu
##
 
nvidia
nvidia-drm
[tio@tio-pc ~]$

Are you trying to use Wayland that could be the cause wayland only plays with certain Nvidia cards. works sort of on free drivers on desktop, just the odd freeze no problems with xorg and free or non free.
Can you disable the Intel card in bios

No I cannot disable it. My bios does not support it. And, I do not plan to use wayland in fact.:sweat_smile: I has little known about it.

should look like this, no space between modeset = 1, just modeset=1

options nvidia_drm modeset=1

which is probably why your inxi info looks like this:

and should look like this:

Display: x11 server: X.Org 1.20.4 driver: modesetting,nvidia

in addition to that, i found some having issues with the nvidia and nvidia_drm not being fully loaded before Xorg starts. to fix that:

sudo nano /etc/modules-load.d
copy/paste:

##
##loads necessary modules for nvidia gpu
##
 
nvidia
nvidia-drm

save/exit

What repro are you using mutter was updated yesterday i think on Arch so could be in unstable, If everything was fine before a update downgrade mutter, But Nvidia is also going through a bad patch with Linux so try free drivers if you get a black screen remove the free drivers black listing,

https://mirror.alpix.eu/manjaro/unstable/extra/x86_64/mutter-3.32.0+49+gb2d0184c6-1-x86_64.pkg.tar.xz

is that the same package you have?

nm, just checked, it's same version in arch repo

Hey guys. Finally I move to xfce4 and everything works smoothly. I think my life can be back to normal way now:smile: :smile:

1 Like

As an update, with mutter-781835-workaround it seems to not be doing the freeze. But with the default mutter it gets to freeze every several minutes, especially if you lock your computer and unlock it. I am very disappointed in this and that I don't seem to find a solution for it. It makes your computer kinda impossible to use. I am wondering no one else got this issue but me and 2 other people? :smiley:

EDIT: I will try the open source drivers, the default Manjaro install, let's see if it solves the issue.

if thats working, why change it?

Oh, because I experienced weird bugs with that mutter installed. Like after locking up my laptop then unlock, 3 out of 5 times I could not open any gnome applications and my internet wasn't working either, almost like the entire computer didn't work. I have to reboot when using it. Also, I would like to stick to a closer Manjaro install as possible (the defaults) else I am concerned I will create a monster. Right now I am using that mutter workaround else I can't use my computer.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by