Desktop gone after update

After a system update yesterday my desktop remains black and I see no icons. I do have a menu bar and a mouse cursor so luckily I can still work, but what's going on? Does anybody have an idea how to debug this? I am of course happy to provide any input necessary. This is Manjaro with a 4.19 kernel and an xfce desktop using lightdm.

Looks like xfdesktop is gone. What happens if you drag around a window, do you get an image of that window as background?

1 Like

I don't. Is that good or bad?

What happens if you righ-click on the desktop?

Nothing whatsoever. I can still configure the desktop background using the desktop app, but it has no effect. I also just reinstalled xfce-4 without that changing anything.

Also, my menu bar icons are completely different, and windows appearance has changed as well. And I used to be able to start without logging in, now I get a login window.

Panel. It's called a panel. That's what I still got.

Hm, seems I mostly solved it. Booted into my other partition and deleted ~/.cache/sessions, now at least I got my desktop back. I reckon the rest can be solved by configuration. :grinning:

Thanks for the help! :+1:

1 Like

Well, getting auto login to work again seems more of a challenge than I thought ... the easy way via user account -> groups no longer seems to have any effect. I'll keep digging.

Looks like I am stumped. Whatever I do, I have to login not only when I start the computer, but also to unlock the screen. Nothing helps. :neutral_face:

Well, can anybody try and point me in the right direction? I think I've exhausted my options, but I can't believe this is impossible ...

When you get the issue, can you switch to TTY2 (Ctrl+Alt+F2), login and run the command
loginctl unlock-session 2

Thank you, I noted this and will try. :neutral_face:

Hm, this didn't really change anything. Doing the steps described here

I got to the point that I no longer need to enter a password. I still get a login screen though. Used to be the computer would simply start without any need to login ... and I don't know what I did wrong so this is no longer so?

Ah, it seems I finally got my computer back. :+1:

Enable Autologin in XFCE brought the solution. At least for starting without login screen. One will see about screensaver locking ...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by