Different errors opening external HDD


Hi everyone,

I have an external 4 Tb HDD formatted ext4 that I use for non-essential files and backup.
Since weeks there are different issues when I mount it.

  • It appears to be mounted normally, but there is no access to the content using thunar file manager

  • It shows the main folders, but when I try to access them, it says that there is an input/output error

  • A pop-up states: "Error mounting: wrong fs type, bad option, bad superblock, missing codepage or helper program or other error"

I tried running:

$ sudo fsck.ext4 -f /dev/sdb1
e2fsck 1.45.6 (20-Mar-2020)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Backup: 27225/244195328 files (4.9% non-contiguous), 917411271/976754369 blocks

$ sudo e4defrag -c /dev/sdb1
e4defrag 1.45.6 (20-Mar-2020)
Fragmented files
Total/best extents 1381/1325
Average size per extent 3888 KB
Fragmentation score 0
[0-30 no problem: 31-55 a little bit fragmented: 56- needs defrag]
This device (__) does not need defragmentation.
Done.

I also tried to use the tool "check and repair" on GParted, but the issues persisted.

Any idea of what might be the cause?

@N3m0

Have you consult man page ?

SYNOPSIS

e2fsck [ -pacnyrdfkvtDFV ] [ -b superblock ] [ -B blocksize ] [ -l | -L bad_blocks_file ] [ -C fd ] [ -j external-journal ] [ -E extended_options ] [ -z undo_file ] device

last item is ... device ( /dev/sdX), since you specified an external drive ... it is surely not / (sudo fsck.ext4 -f / sudo e4defrag -c /)

Good luck

This is may be happening when kernel has been updated but system not rebooted.

The filesystem is kernel supported - if the physical kernel differs from the in-memory kernel - it throws similar messages - depending of course on what the kernel is trying to read from modules.

1 Like

Why don't you try installing an alternate file manager. Try midnight commander, it is a Terminal User Interface (TUI) based file manager.

Check if things work properly using mc in the terminal. If that doesn't work, then I'd try creating a new user account to test if things work under a new user account. You could also test from a live environment with a different DE or distro to narrow down the cause of the problem.

This tests your root filesystem - not your external hdd. Check the correct device.

I omitted the name of my device, but I put the correct position

I don't like midnight commander aesthetically and I haven't found another file manager that does not require packages for another DE and I like.

I omitted the name of my device in the code I posted, but I put the correct position

The default colour scheme of MC is horrendous, but there are many good looking alternate themes. When your desktop and GUI apps freeze you will truly appreciate MC then (take my word for it).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by