Discord refuses to update with yay

I'm trying to download the latest version of Discord, as when I start the app it refuses to continue until updated. Fine, I try

yay -Syyu discord

It tries to reinstall Packages (1) discord-0.0.10-

Yet on the AUR it's 0.0.11-1: https://www.archlinux.org/packages/community/x86_64/discord/

Am I doing the update wrong or something? Everything else seemed to update fine, Discord is still pulling an older version for some reason.

It refuses to start with 0.0.10 and really needs me to update, so I'm sorta stuck

1 Like

Thats not the AUR. Thats just Arch repos.

If you cant wait for stable branch updates .. you might consider changing branches.
(currently only Unstable is on 0.0.11-1)

Or if you absolutely must manually grab the new version and insert it into stable branch, then at least grab from our repos.
Like this:

6 Likes



should help

2 Likes

Ahhh for some reason I thought it was downloading from AUR. Unfortunately it refuses to start with the old version/absolutely needs the update to start now

So I'm going to need to download the unstable I guess. Might be better to push it to stable ASAP otherwise a lot of people are going to run into this

Edit: Worked wonderfully, thanks!

So while I get and like that Manjaro has it's package updates delayed from Arch.
When an application refuses to open (like now with discord). Aren't package updates pushed anyway? So that atleast it'll work?

What I got when I tried to launch the 'old' (current version in manjaro repo's):

>>> discord                                                                                                                                                                                                                    
Discord 0.0.10
Starting app.
Starting updater.
[Modules] Modules initializing
[Modules] Distribution: remote
[Modules] Host updates: enabled
[Modules] Module updates: enabled
[Modules] Module install path: /home/thibault/.config/discord/0.0.10/modules
[Modules] Module installed file path: /home/thibault/.config/discord/0.0.10/modules/installed.json
[Modules] Module download path: /home/thibault/.config/discord/0.0.10/modules/pending
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0230
[Modules] No updates to install
[Modules] Checking for host updates.
[Updates] You are out of date!
[Modules] Host update is available. Manual update required!
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0230
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0230

Personally, i think Discord is at fault here: an application shouldn't make itself unusable because of a pending update, on every update.

5 Likes

Of course. Don't even know how this could have happened. But while Discord is at fault here. I'm just wondering/saying what the procedure is for Manjaro repo's in this situation

Of course, but I think in this case fast-tracking into stable is faster than asking Discord to unlock the old version. Because currently no Manjaro user on stable can use Discord and that's quite bad

1 Like

web browser client is still working

1 Like

It's also possible to just do sudo pacman -U https://manjaro.moson.eu/unstable/community/x86_64/discord-0.0.11-1-x86_64.pkg.tar.zst, but I'm more concerned about some users trying to install the .deb or tar file that Discord helpfully shows ([Package Update Request] Discord new release)

1 Like

I'm more concerned about some users trying to install the .deb or tar file

most users will probably realise they want the Linux (tar.gz) option and not the Ubuntu option

Fast-tracking is usually only for security updates. This is a regular update here.
Unlocking for the next update shouldn't be so hard, even so for packages installed through package managers: they could just provide an option (or even a build option) not to check for updates!

I'm switching to the Snap package personally. Although it would be better if my friends got Steam Voice Chat working again, so i can ditch it... :unamused:

Also a good alternative. Although i have other issues there as Firefox puts a mic icon overlay even on fullscreen games... :dizzy_face:

flatpak has latest version too
https://www.flathub.org/apps/details/com.discordapp.Discord

1 Like

Personally... I swapped to unstable just to grab that one Discord package, because Discord does not work unless you're always on the latest update.

For me, it was:

sudo pacman-mirrors --country United_States --api --set-branch unstable --protocol https
sudo pacman -Syy discord
sudo pacman-mirrors --country United_States --api --set-branch stable--protocol https

I was too lazy to find the mirror + package link to use sudo pacman -U <insert package link from mirror>

It seems that one can trick Discord by modifying the version in it's build_info.json file.
Described in this post: https://support.discord.com/hc/en-us/community/posts/360057789311/comments/360009476712

But anyhow, this behaviour is really annoying. This reminds me to Windows, "I will perform some updates now, no matter what." :smile:

The last version had the same problem when the update came. But the newest version was quickly available after a day or so.
So I had hoped it would be the same this time around.
What Discord is doing is pretty bad. Really not a good user experience.

The application is just not working at all until it is updated. It is already a really good reason to fast-track an update even it isn't for the sake of security. It should have been handled immediately, not just slowly get it from branches to branches.

browser version is working
flatpak and snap packages have latest version
new version is also now available in testing branch
AUR package discord_arch_electron Last Updated: 2020-08-04 22:36
or download and updated manually

What is the point of supporting Discord in the official repositories then, if there's no commitment to do the required work to maintain it? Not having the latest version immediately is fine when we can still use the application (e.g. not having the latest version of LibreOffice, I can still work on my documents and spreadsheets), but when the software provided does not work at all anymore because you need the update, the maintainer should provide it quickly.

At that point, it could just be removed from the repositories, so we tell people to use alternative sources of software to get it, such as Flatpak or Snap. It might not please everyone of course, but it would at the very least be consistent.

Now, you are currently telling "we have Discord in our repositories, but it doesn't work until we decide to update it and we won't do it until a couple of days maybe, so get it somewhere else in the mean time." I'm afraid it is hard to take it seriously and stay credible with such answer to the issue.

2 Likes

I switched to Lightcord to fix this problem. Wroks faster than Dirscord client and has built in better discord

4 Likes

Forum kindly sponsored by