Disk E on HDD is unreadable after install over Widows 10 located on SSD

I have a notebook with SSD+HDD and Windows 10 was installed on SSD(disk C and D) and HDD(disk E) that was used for data storage.
Before moving to Manjaro KDE 18.1.5 I have copied most important data to HDD and performed a clean install over Windows. During installation I haven't seen any configs related to HDD and I have expected that everything should be fine.
The problem is that after installation I cannot mount the HDD because of following error:

➜  ~ sudo ntfs-3g -o ro /dev/sdb2 /media/win
ntfs_mst_post_read_fixup_warn: magic: 0xf019479b  size: 1024   usa_ofs: 14714  usa_count: 51790: Invalid argument
Record 0 has no FILE magic (0xf019479b)
Failed to load $MFT: Input/output error
Failed to mount '/dev/sdb2': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

This is the output of fdisk:

Disk /dev/sdb: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000LM035-1RK1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 82FBBCC2-074C-11E9-A9A9-0492267046D7

Device     Start        End    Sectors   Size Type
/dev/sdb1     34      32767      32734    16M Microsoft reserved
/dev/sdb2  32768 1953523711 1953490944 931.5G Microsoft Storage Spaces

Partition 1 does not start on physical sector boundary.

I have tried to run ntfsfix but without success:

➜  ~ sudo ntfsfix /dev/sdb2
Mounting volume... ntfs_mst_post_read_fixup_warn: magic: 0xf019479b  size: 1024   usa_ofs: 14714  usa_count: 51790: Invalid argument
Record 0 has no FILE magic (0xf019479b)
Failed to load $MFT: Input/output error
FAILED
Attempting to correct errors... ntfs_mst_post_read_fixup_warn: magic: 0xf019479b  size: 1024   usa_ofs: 14714  usa_count: 51790: Invalid argument
Record 0 has no FILE magic (0xf019479b)
Failed to load $MFT: Input/output error
FAILED
Failed to startup volume: Input/output error
Checking for self-located MFT segment... ntfs_mst_post_read_fixup_warn: magic: 0xf019479b  size: 1024   usa_ofs: 14714  usa_count: 51790: Invalid argument
OK
Unrecoverable error
Volume is corrupt. You should run chkdsk.

It is possible to recover data from the HDD using Linux?
Or even reinstalling Windows won't help?
I have some important data that I need, also the HDD is too big to make a image to play with.

I'm not sure this is the problem but you can try it:

  1. Boot Windows
  2. Check HDD for errors
    3. Disable Windows 10 fast statup
  3. Boot Linux and see if the problem goes away.

Don't use ntfs as the filesystem type in your mount command ─ it's deprecated. Use ntfs-3g instead.

Please edit your post and paste the output using Preformatted text (Ctrl+Shift+C or the </> button) instead of screenshots. They're hard to see on mobile and the text can't be indexed for searching or copied.

1 Like

I have already configured my linux instalation and I don't want to reinstall. It is possible to restore HDD without installing Windows?

I see... I reread the OP, as I thought Windows was still there. Well, in this situation I'd try to use testdisk to recover the partition. If it fails, use testdisk to recover the data. Then delete the partition and create an ext4 to use with linux.

No - ntfs-32 driver has no repair capabilities.

If you have ditched your windows - you could try Hirens BootCD mentioned in this topic

I have already tried testdisk but repair didn't worked, also I have performed a full scan for files but it could find only some broken folders and Linux stuff(I had a virtualbox with Linux on it).

It seems that re-installing Windows is the only solution, I hope that will work.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by